White TPU Text on a Black TPU object - No White extruded!

I’m trying to print an object that is basically a disk of black Matterhackers Build TPU. The last 2 layers of the print is some White Materhackers Build TPU text (0.5 mm high) which is created and painted white in Bambu Studio.

I’ve done the same process using PLA which is housed inside the AMS… but TPU can’t be used in the AMS, so I have it feeding directly from my filament dryer into the external filament port on the X1 Carbon.

After slicing the print, I insert a pause in the preview, just as the white text starts to appear (layer 31 of 32).

When the printer pauses, I unload the Black TPU.
The Black TPU is cut and I remove it.
The X1C purges the Black TPU.
I then load the White TPU . The XC1 grabs the White TPU and a bunch of the White TPU is squirted out of the nozzle as expected.
I then continue the print.

The print head moves over the black TPU disk and is clearly trying to print the White text but no White TPU is extruded!

I tried the reverse, printing Black TPU Text on a White Disk, but the same exact thing happened!
When printing alone, each color TPU prints really well on the print bed.

It seems that it’s not possible to pause the X1C and exchange one color of TPU for another color of TPU. The new TPU simply doesn’t extrude onto the existing TPU base.

Or maybe I’m doing something wrong?

Any ideas?

I’ve attached the Bambu Studio Project.White TPU Letters on Black TPU Disk

What happens if you just release the pause without changing any filament - does it extrude the letters ok in the black?

How about trying having something larger than just the text in the last lsyer - to see whether it eventually starts to ectrude the white?

1 Like


Thanks for your reply.

I just printed the top 8 layers of the disk, including the white text… but printed it all in the same Black TPU. The printer paused where the filament change should be made. I clicked continue and the printer continued to print the remaining layers in the same TPU. It printed the text layers just fine in the same Black TPU as the disk base.

I’ve doubled the extruded text from 0.5mm to 1mm to see if that will print in the White TPU.

Stay tuned!

It seems that making the text layers 1 mm instead of 0.5 mm did the trick! The White TPU text was successfully extruded onto the black TPU disk.

Now… why was only 1/4 of the top of the disk ironed and the rest left looking unfinished? Hmm!

1 Like

Great you are now getting some white out - I wonder though whether it is only coming out in the 2nd layer. I wonder if you need to simulate some sort of prime tower.

As mentioned in another TPU multi material thread, Im wondering whether a method that involves the AMS - but actually has the TPU manually fed in a way that the printer thinks it is coming out of the AMS might work - that way you would get a prime tower which might solve the non extrude problem.

Think i will have a go at some multi material TPU printing myself tomorrow.

1 Like

Hi again.

Actually, I realized my description of the project was incorrect in my initial post. The text was not created in Bambu Studio, rather it’s a Sketch and Extrusion in the OnShape document. Only the color of the text is painted in white in Bambu Studio. This shouldn’t make any difference, and in fact didn’t, as it’s the exact same process I’ve used with dual-color PLA parts. The only difference being that PLA works in the AMS!

Because the project lists 2 colors of TPU (White and Black) filament, my project includes a prime tower when it is sliced and printed. I disable the AMS in the print dialog box and put a Pause on the layer where the text starts. When the print pauses, I swap out the Black TPU for the White TPU on the external input to the printer.

I’m printing the full object now, including the white text, and will see how it turns out. It’s solid TPU, so it’s taking 4.5 hours to print…2 hours to go!

Ah interesting - didn’t realise you could still have a prime tower without using the AMS.

Just did my first ever non AMS print after over 600 hrs printing as I want to do some TPU myself - ideally mixed with PLA - had to install the spool holder for the test.

I just did a test with PLA not in the AMS - 2 layers of white, and 1 layer of blue with the text on it.
With the pause inserted at the beginning of layer 3.

Followed your instructions and it worked fine for me - I got the blue filament ok on the top layer of the prime tower, then the letters worked ok in blue, and that was with only 0.2mm of Blue - so still don’t really understand why your white Text didn’t work, especially as I presume with your 0.5mm test you had a couple of layers of it - Out of interest did the top layer of the prime tower didn’t get any white on it? NB/ I suppose my test was with PLA rather than TPU though.

Going to try a half AMS, half external feeder test next - by running the same test run, but this time selecting AMS, and unplugging the PTFE before it inserts the 2nd colour and replacing it with my external feeder filament to see if I can trick the printer into thinking it is getting the external feeder filament from the AMS. Will try it with and without the pause.

1 Like

Update - Managed to get a combined AMS + External spool test to work - thought it might be of interest - or maybe I should document results in a separate thread.

I inserted a pause at the start of Layer 3 in a 3 layer print (with layer 1&2 colour1 and layer 3 colour 2 -

When the pause was invoked I disconnected the PTFE from the AMS - and the old colour1 filament was still in there - so hadn’t been unloaded yet.

I resumed, let the colour1 filament pull out, then immediately started to insert the ‘real colour2’ filament from the external spool holder.

The AMS wasn’t that keen and kept retracting and resending the ‘dummy colour2’ filament down again and eventually gave up and said there must be a clog.

I eventually worked out that what needs to happen for it to work is for the dummy filament coming out of the AMS to be restrained (which must get picked up by the hub/buffer stringed section I presume) at roughly the same time as the filament being manually fed down to the nozzle hits the sensor at the print head.

Took me a few goes to get the timing right - but eventually the printer accepted my side loaded filament and completed the print ok. At the end as soon as the printer started retracting the dummy AMS filament I pulled out the real filament and rewound it on the side spool.

NB/ I had to continue restraining the dummy filament from coming out of the AMS tube - while the side loaded real filament was printing - otherwise the AMS just kept feeding more dummy filament.

In my test both the Colour1, Dummy2 and Real2 were all PLA. But I can’t see why it wouldn’t work if Dummy2 in the AMS is defined as PLA - but with TPU settings, and Real2 is the real TPU.

Not really sure therefore that my proposed approach is really feasible as a way of doing mixed AMS PLA etc. filament together with manually loaded side spool loaded TPU in the same job and whether it will have any adverse affects on the AMS - but technically at least it does seem to work.

1 Like

Thanks for posting this. This is the info I needed aswell. Ive been want to print pla/tpu prints but didnt know you could splice multicolor without the ams.

1 Like

Finally got around to trying a TPU print for real and couldn’t really get my AMS tricking method to work despite a few tries - so in the end settled for printing the PLA parts separately, and then pausing the TPU print and slotting the PLA parts in. They go in quite easily because the TPU is flexible.

In my case I was just using PLA for TPU support and it ended up working quite well.

Would be nice if a future version of the AMS eventually supports TPU, but in the meantime I have settled on this method.

Almost dusted off my IDEX printer - but like the X1C so much - decided that the mucking around was worth it.

Demo model here Iphone 15 Pro Max case - TPU supported by PLA - with Credit card holder Remixed by Ukdavewood - MakerWorld

1 Like