X and y belt tension errors and now no input shaping

hey everyone.
i have a bambu labs P1s with just over 1000 hrs on it.

at the 800 hr mark it has been giving me the x and y belt tension error codes
as well as violently chattering around the print area.
I replaced the tool head control board and ribbon cables as well as the board on the back of the tool head, the problem went away for awhile. hard resetting seems to clear it for a while. but now its back worse than before.
Circles are ovals and it layer shifts around the bed. i dont seem to be able to post a video but i would say its trying to do corners at full acceleration.

i have tried
cleaning the guide rods.
tightening the belts
downgrading firmware.

i have a support ticket in but im not expecting a response for 2 weeks like the last time i sent one in.

i am unsure where to go from here.
this happens with files that are sliced and sent to the printer and existing ones that worked on the SD Card.

This phrasing raises questions in my mind. Did you loosen the tensioner screws, move the head through its full range of motion to relieve static friction in the tensioner so the springs could apply correct tension to the belts, and then retighten the screws?

Or did you manually increase tension on the belts?

Because the belts can be too tight.


I had dimensional accuracy problems with my K1. On this CoreXY printers, the belts cannot be too tight, too loose or have different tension between them. If they are too tight or too loose but have the same tension, parts can be a llitle bit larger or smaller in X and Y axis, and have vibration marks on them. Different tensions wil produce geometry deformations. On my K1 I’ve fond a Belt tension gauge on Printables and it gave me at least a way to see difference betwwen belts. Maybe this can help you.

I have received a response from bamboo labs. We will see what they say next.

They are wondering where I placed the printer.

On a table and such.