X1C Firmware 1.08 WiFi Issues

I have been experiencing a recurring issue with network connectivity following a firmware upgrade from 1.07.03 to 1.08.00. No WiFi networks are shown after a power cycle, and networks can’t be connected from the “add other network” option either. A factory reset was the only way to restore WiFi functionality, and following a downgrade to 1.07.03 all WiFi functionality is restored and persists after power cycles. Has anyone else encountered this with the 1.08 firmware?

Unfortunately no, not on latest stabler release or the 4 BETA versions previously I was testing.

All my network problems went away with the very first beta that introduced the Wifi updates. Before that I had to power cycle or switch Wifi off/on once a day on average. I guess you’re unlucky enough to experience the opposite. Just open a ticket with Bambu so they can track it down.

1 Like

I just had a similar issue.

I upgraded a few days ago and all was well.

However last night Bambu Services were down so I had to use LAN mode, once services were back up I went back to WAN mode and did a few more prints.

This morning however the printer decided it couldn’t see any of my networks, but could see others. I rebooted my router and the printer, confirmed other devices could connect to my 2.4Ghz networks. However the printer still refused to see or connect to any of them, even if I entered everything manually.

Eventually I factory reset the printer and all my networks appeared.

Interestingly my 2.4Ghz networks seem to be on channel 13 and I live in the UK. I know that in the US channel 13 is avoided so maybe the printer is forgetting it’s locale somehow.

Most odd

1 Like

I had a loss of wifi a while back after an update. I spent huge amounts of time going round and round with B support, finally got a replacement board which fixed the problem. But, I’m semi-convinced it was a firmware issue. New board got an update that fixed the problem, firmware in the old board wouldn’t update. Given that B won’t let you roll back to earlier known-good versions, I’m now afraid to update until others have been hosed and B fixes issues. On the plus side, B seems to now be getting their support staff back to what we should expect. Kudos for that.

Hey Baz!

I am having the exact same problem after the firmware update. I also tried out the LAN mode for the first time because Bambu Servers were down and it actually worked very well!

The next day I wanted to use my wifi again but the X1C couldn’t find the SSID anymore. Same after power cycling and I also use channel 13 in Germany, because no one in my neighbourhood is using it.

Then I had the idea to open a hot spot on my iPhone and what do you know? The printer could connect to it immediately! So I started a test print.

I did not reset the printer yet, I will do that after my current print.

Good to know I was not the only one having this problem.

I have just had to downgrade to 1.07.02 as I had an issue with AMS Slot 2 whereby it would just sit purging. Others have reported issues with slot 2 on 1.08 so I have decided to give up on it for now