A1 mini Z-axis homing failed

Hello all. Exactly one week after having my new A1 mini and having used it fairly lightly, I’ve run into a z-axis issue I can’t seem to resolve. After cancelling a print, then starting a new one, I noticed that on initial homing one of the axes hit its maximum and the motor continued, making a grinding noise. It started with near-max z and near-max x, and tried to move beyond it physical limit on one of those axes (not sure which) making a grinding noise. Now, the printer cannot fully home, as its z-axis calibration fails, giving a 3004000 code occasionally.

I’ve tried the following, to no avail:
-Turning off/on
-Homing (failed)
-Factory resetting (no change)
-Placing object on bed and homing (leveling sensor)
-Running calibration (failed)
-Running device self-test (failed)
-Checking hotend and nozzle
-Checking toolhead usb-c connection
-Inspecting for obstructions on z-screw
-Downgrading firmware, attempting homing, and reinstalling latest firmware

I’ve noticed that sometimes after an attempt at homing the z-axis raises completely. Then, on the next attempt at homing, it grinds against the top without recognizing it has reached its limit. I haven’t found anything online that matches what I’ve been experiencing on the A1 mini, and solutions to similar problems posted by others didn’t help.
I’ve submitted a ticket, but would greatly appreciate any suggestions in resolving this!

I have this same problem, it is when it doesn’t know what hight it is at. The best solution is to lower the z-axis before homing it, I don’t think there is going to be any solutions, I’ve had my A1 Mini for 3 months now, I only have this problem when I have really tall prints and then try and go home. I don’t think there will be any solutions to this problem because it has no idea what height it is so it has no idea where the max height is so it’ll keep going up. That or they’d have to have the printer save the z-axis height so they would know where the max height is. For me I just pay attention to how tall it is and manually lower it on the LCD before homing it.

Thanks for the reply. I’ve tried this, moving the z-axis down to the nozzle nearly touching the bed, but when I try to home from this position it does something like this: x-y homing with the small up-down of the z-axis, then a pause of five seconds, then a larger up-down movement on z-axis. When I then try to move the z-axis on the screen, it says it still needs to home. X and y can move without the homing prompt showing up, but can’t be held down for continuous movement (one increment per press).

Update: Based on a somewhat similar issue someone online had with an A1, I tried removing the hotend and rerunning the same homing and calibration attempts as before. Nothing changed. Does this mean it’s not detecting the presence of the nozzle, so there’s an issue with a sensor on the printer head? It even let me adjust the nozzle temp without it in place, which I assume would only be allowed with maintenance mode on. I’m not sure if this is significant, but thought it might offer a clue.

You have to push the z axis button and then when it prompts you to home, you have to click cancel and then down and do it all over again until it was low enough to not hit the top and then click home and it will be fine. There shouldn’t be any issues with the sensor of the printer nozzle. It’s simply that it just does not know what height it is at, because when a print is done it goes up but is no longer keeping track of the height. If this is to be resolved they have to do in the software. It is not a hardware problem.

I have tried this without success. Even when I initiate homing with the nozzle nearly against the plate, at the very bottom, it fails to calibrate. It starts fine by homing x and y, but then has an unusually long pause (when it should be slowly lowering to touch the nozzle and home the z) before it fails calibration.

had same problem on my a1
tried to home, the x axis would rise a bit, lower a bit the rise a bit more then throw out the infamous 0300400 error
submitted a ticket and ended up replacing the extruder unit, due to a possibly faulty eddy current sensor.
worked perfectly after that

1 Like

I think forums of A1 mini and A1 should be separated. If we will look into A1’s issues we will not go anywhere.

1 Like

This would make complete sense. After reading up on this issue it seems like the most plausible cause. Still waiting on support, thanks for the info.

Yeah it’s rather unfortunate. Though, in this case, I think the problem is common between models.

Hello, I put the second A1 Mini into operation at our school today and it also shows the problem with the error message “Homing of Z-axis failed”, therefore no calibration is possible. Moving the Z-axis manually does not solve the problem either, as homing cannot be completed successfully. My question is therefore whether you have already received a solution from the support team. Many thanks in advance!

Support got back to me, but it’s still in progress. According to support, Ian was right - the problem is with the Eddy current sensor in my case. Something support suggested I try, which might help you, is switching the connections of the Eddy sensor to the extra connectors, as in the image. My printer somehow didn’t have the extra ports (looks like the PCB points where they should be were manually soldered over). Otherwise, check for any breaks in the wires. Support is sending me a new toolhead board, hopefully this fixes the issue. It’s been exactly three weeks since receiving my printer, and only got one week of use out of it.

1 Like

Probably the eddy sensor, sounds about right.

Right you were. Support sent me a new TH board and extruder and now it works great. Upon closer inspection after removing the old extruder, noticed this tiny break in the wires running into the eddy sensor. For anyone who may encounter this issue in the future, this is the likely culprit. Might have to take out the extruder unit to see it properly.

2 Likes

what does this have to do with the firmware??? the old firmware was working tooooootally fine but the new firmware almost ripped off my print bed! THE ISSUE IS I THE NEW 01.02 FIRMWARE BLINDINGLY MOVING THE AXIS UP AND DOWN ! apart from the 0300400 error the firmware moves z axis over the printer limits (fail does not exist in old firmware)