After manually loading filament, temp does not set to 0

Something I’ve noticed recently.

After I manually load filament (when not mid print) using the menu on the built in screen, the hotend temp does not set itself to 0C after loading is completed, it sits at 250C. I have to manually set the temp immediately after, so I don’t get filament oozing.

When I unload however, the hotend temp automatically adjusts to 0C after completion.

It would be very convenient if the temp reset to 0C after manually loading a filament when not currently printing. Has anybody else had the same occur?


That is a know issue. If you are going to print right away you can manually change the temp. Or you can wait for the 15 minute default timeout that the printer uses to turn off the fans and heaters.

Not anymore with latest firmware

I’ve just seen it released. Will give it a try!

I just loaded filament before updating the firmware, so I’ve not tried it myself, but I notice that the P1P release note states that after loading, it’ll be set to the “filament’s temperature”, so… not 0º but instead 220℃ for PLA?

I just tried this.

I had no active print and loaded a new filament with the printers screen. Temp went to 250C to load and after loading/purging completed it went back to 0C.

Maybe the note means it reverts to the hotend temp that was active before the load started?

1 Like

Maybe the note means it reverts to the hotend temp that was active before the load started?

Yeah, that’s a reasonable/logical interpretation. Honestly, anything under 160℃ is a good start for me.

I just loaded PLA and it set itself to 190℃. A bit hotter than I’d have preferred if it’s not going to use 0. It looks like they may be setting it to the minimum temperature for that filament.

Generic PLA min temp is 190c. Maybe thats why it was set at 190c.

1 Like

This is not expecting a reply, but I did want to note that the filament I had loaded was PETG which has a minimum temperature of 220℃, but the printer didn’t know what filament I was loading, of course. In my opinion, choosing a value based on the prior print when one is loading new filament seems to be a questionable choice. If it had been the reverse, then loading PLA might have it sitting there at 220℃ instead.

I’m still seeing this bug. P1P, latest firmware as of Nov 16, 2023.
No idea why it doesn’t drop back to 0 degrees anymore.

Curious if everyone switched to 0.6mm hardened hotend nozzle? I just switched last week and noticed after loading filament the temperature didn’t set to 0. Quite annoying.