AMS Auto Refill wrong spool being used

I have loaded two black support spools and two PLA White spools.

  • Black Support, one of the spools is low and will run out.
  • PLA White, one of the spools is low and will run out.

When I set up the print I choose the spools that are lowest because I want to use up the material before going to a full spool.

When it prints it chooses the spools that are fullest first, no matter what I setup in the print.
I have trick it into using the right spools during the print by quickly changing the slots they are in.

Why is it doing this?

1 Like

Are they in order…??
1 & 2 Black
3 & 4 White

Not 1 black 2 white

Yes
1&2 are Black or support
3&4 are White

1 is low and 3 is low.
I choose 1 as my support material Black
I choose 3 as my primary color White

I verified that the auto refill would switch between the correct spools 1 to 2 and 3 to 4. What auto refill does not tell you is the order in which it will use the filament.

When I sent the print it used spools 2 and 4 first.
It should have used spools 1 and 3 first.
Hence I switched the spools during the print to trick it into using the correct spools.

I think I have the same issue. I have the same exact material in slot 1 and slot 4. Slot 1 is mostly empty and the AMS has that data. Slot 4 was a full spool meant to pick up when slot 1 ran out. AMS has the data that slot 4 is full. AMS filament backup is enabled. AMS was synced before the plate was sliced.

The printer consistently uses slot 4 instead of slot 1. I expected it to use slot 1 since that was what was selected in the slicer. I also would like it to use slot 1 so I can empty the roll.

When you send the print from Studio you can pick what slot is being used. Here mine defaulted to A4 (The full spool) but you can pick A2 to start the print from.

AMS Slot

You can also verify what slot is set for backup by clicking on the “Auto Refill”

Auto Fill

2 Likes

Thanks for the rely JonRaymond, however I did exactly what you said and it still picked the wrong spool.
I’m going to try to disable the “Update remaining capacity” to see if it has some wacko code that tells it to use the fullest spool first.

1 Like