AMS not recognizing Bambu filament type

I have a new roll of Bambu PLA tough filament. The AMS will load it but does not recognize the filament type. I have placed another Bambu filament in the slot and the AMS does recognize it.


Thank you.

It will take a firmware and/or Studio update to recognize new filament types.

1 Like

OK. So this morning I updated firmware after recommendation on my X1C. My AMS is now acting just absolutely strange. The biggest is that I received two new rolls of PLA, one just basic PLA, the other PLA-Silk.

The AMS failed to recognize either and just popped up a dialog that said “I don’t recognize, would you like to enter information” and for the first time since I’ve bought the X1C, the screen was very laggy to respond.

I finally got the information entered, but I had to virtually manual feed the filament in as it didn’t in any way “autoload”

Have you tried power cycling the printer after the firmware update given the behavior?

I had 1 roll of Bambu filament (the sample pla it came with) where the rfid tag was simply a dud.

It’s just odd to me that I have two rolls of brand new Bambu PLA, and the RFID tag on both of them are no-go. I just wondered if it was after the firmware change or what… I tried unloading, resetting, and powering off… primarily because the AMS detected them as exactly what was in those slots before one time (PETG) on one… but I just ended up manually putting in

Mine won’t recognize rolls at random. Like, before the update yesterday it knew what the CF-PLA was, this morning it thinks it’s ABS and I cont print it.

I’m not using it currently so I figure BL will fix it or I’ll stop buying RFID filament. I mean in my opinion of the RFID stuff is gonna cause issues that make the printer refuse to print the materials… I can buy filament from so many places…

To me, it’s becoming a real issue.

I had similar issues with my AMS. I had two rolls it was trying to detect and kept failing. I did a couple of power cycles and still nothing. I took both rolls out, powered everything on and then inserted one roll. The AMS detected it fine that time so I put the second one in and it detected that one as well. I didn’t do any additional testing but it made me wonder if the AMS had issues detecting the RFID tags when multiple rolls are already installed and not yet registered with the AMS.

1 Like

Having the same issues here. Added a 2nd AMS and sometimes the old one recognizes the spool sometimes it doesn’t. When it doesn’t it is almost always with one it recognized before. Bambu how about you guys let us know what is going on with this issue? Makes it senseless to spend the money on theirs for the convenience, wife is already to move on to a different filament if she has to enter it manually.

I have been having this issue lately. Many Bambu filament rolls that should support RFID are not recognized. It’s not a big deal, because I just hit the edit button on the X1C display, and enter the filament type and color manually. It is an extra step, but a quick one. After than I can “resync” Bambu Studio from my PC, and it correctly reads all filament types from the printer/AMS, regardless of whether those filament types were set by RFID or by manual entry.

It does seem strange that spools that worked before aren’t recognized when I remove them from the AMS and then put them back in later. Oh well, for now I will just type it in manually when needed. I did add some desiccant packs to the AMS and to some spools, I wondered if those are somehow blocking something. I don’t see how they would, but that’s the only thing I have done to modify anything.

Have you guys checked the gray part that feeds the filament into the AMS’s motors? I have a similar problem and the gray part is worn an angles the filament in at a of center angel.
When I leave it alone it can’t register the filament, but when I use my finger to keep it aligned it does. Wondering if this applies to you guys too?

I think there might be two different issues, unrelated:

  1. I thought this filament recognition was done by reading an RFID tag in the spool. This was the error I was posting about. Once I type in the filament type, I can use it as normal. The feeding into the AMS is fine, it’s just the reading of the RFID that doesn’t work.

  2. However, I did have a separate problem one time where the filament got fed forward then retracted over and over without end. Normally it should go back and forth a few times and stop (at which point the AMS either knows the filament type, or doesn’t know the time, but in either case it finishes movement). But one time for me the AMS kept looping, like 10 straight minutes of back and forth with the white LEDs (next to each filament entry hole) blinking. I pulled it out and re-cut the end (it had been a little kinked at the end), and then it worked. I assumed that this was some kind of misfeed caused by that kink at the end of the filament.

To me, it seems plausible that getting stuck (and looping) due to feeding error could very well be influenced by how it enters the little grey part. At least it isn’t completely unrelated. Failure or success at reading RFID seems completely unrelated.

I recently got my X1 with AMS and when I first installed my “Bambu” filament the AMS automatically detected the type and color. Now if I try to change the filament to a different color or type, again using different rolls of “Bambu” filament, my AMS doesn’t detect what type or color. I have to manually enter the info.

The only solution I’ve found to correct this issue is by powering down the system. This is a pain to do just to get my AMS to auto detect my “Bambu” filament… I haven’t even used a full roll yet so age or wear shouldn’t be an issue. Anyway, is this some sort of user error? Running the latest firmware fyi.

I have certainly had isolated incidents where the AMS stops trying to update filament info that is fixed by rebooting. Nothing consistent though to make a connection on what causes it to get in that funk.

Also, I have had 2 different rolls of Bambu filament have a bad rfid tag. Something to keep in mind. One of them was a trial roll that came with the X1CC.

You might also verify that the AMS has both of the below checkbox’s selected.

AMS settings


I’ve verified these settings myself and they have no effect. Whatever is causing my issue the only solution is powering off the printer and AMS. So far with my setup, anytime I pull a Bambu roll out of my AMS it won’t recognize it again until I power off/on again. Very frustrating. So far all of my RFID chips work, only as long as I power off/on again. I’m pretty sure it’s not the RFID chips in my case. I’m suspecting a firmware issue but don’t have enough experience to confirm.

What process are you using to load filament into the AMS?


I have this issue since recently. Loading a new filament and the AMS also starts moving the spool in the adjacent slot but in the end fails to recognize the filament. All white lights flash during the process. After a power cycle it works again. I suspect a firmware issue.

When I want to change color on a new print, while the printer is idle, I simply pull the filament out of the feeder and insert the new color roll.

I don’t normally use the load/unload buttons as the filament is already unloaded from the print head. As I see it, if I use the load/unload buttons it heats the extruder and cycles the filament through the print head. Hopefully this isn’t my issue as that makes changing colors a pain in the rear if required.

Agreed, my AMS also doesn’t like to read new spools until after a power cycle. If I’m in a hurry I just key the info in manually otherwise I just power cycle the printer and it reads like it should. I expect this will be fixed some point in the near future.