AMS Port 3 gets Stuck when changing Filament

Which part? There are a few in this thread, so just want to see which one you went with.

1 Like

Ah - thanks. That didn’t work for me.

It could be related to the length of the PTFE tubes inside.

I installed that. Indeed it worked a couple of times but now is throwing the error again. That solution is probably close to a solution but still not enough to fix it fully. I have big problems with my sunlu matte filament.

The AMS is really just a not fully tested product with still some defects.

I have the exact same problem. 1 Week old unit making this problems with Sunlu spools and sometimes bambu aswell…

Changing the AMS buffer for the AMS HUB solves all the problems I encountered. Some AMS supports you can find on Makerworld makes it even worse instead of better.

Have had my AMS (Bought Direct from Bambu) for one week … SAME issue Slot 3 Failed to Retract!!! (90% of the time).

What are they doing to fix this and make their customers happy? … $400 for a half baked product?

Here is also the problem with port 3
a new AMS with the new roll of original bambu lab filamet
and withdrawing from port 3 keeps getting stuck

I would like to know something:

If you have so many problems with #3, the problem should be reproducible if the filament is simply loaded manually from #3 (i.e. select #3 on the display and then click on “load”).when the filament is loaded from #3, then unload the filament manually via the display. This must not work in 9 out of 10 cases, but at least not in 5 out of 10 cases, so that this error occurs here.

Can anyone try and confirm this?

Thank you very much!

I added this to my Printer

Ams Bowden Guide Clip by iretreiver - MakerWorld Bambu AMS PTFE Buffer Block by K2_Kevin - MakerWorld

Solved IT for 95%

This is what i was thinking of.

When slot 3 retracts, i hold the tube of the buffer and everything is fine.

If i do not the tube gets pulled into the buffer and it gets stuck.

How can i change or modify the buffer?

Regards

You can find several AMS bowden tube helpers on Makerworld like this one Ams Bowden Guide Clip by iretreiver - MakerWorld.
In mine case, none of them helped. I changed the AMS buffer to the AMS HUB and had zero problems afterwards. I’m planning to buy a second AMS, so I need the HUB.

2 Likes

After a few days of printing with port 3 without any problems, I had another crash. Then I took the AMS apart and took the internal HUB apart and cleaned it completely. There was filament fabric in it. I also came across a piece of plastic that didn’t belong in it. The ptfe hose was not cut at right angles, I adjusted this.

For now, the problem has been solved. The tests were promising.

1 Like

I just got a P1S with the AMS out of the box 2 days ago and on my first time using the slot #3 , guess what, it got stuck at 99% when it was trying to cut/retract the filament back to the AMS. I was running a brand new spool of PLA (1kg). Is there any fix/improvement for this issue that seems to be affecting so many users, mostly when ruining filaments on slot #3? Cheers

Exactly the same for me. PS1 Mega Combo. Since the printer arrived I haven’t been able to complete a single multicolor print with the AMS

Always the same error when pulling out the filament in slot 3. If I take the AMS from my X1C, no error.

I think BambuLab currently has a big problem with the AMS.

Also having issues with slot 3, have tried several AMS fixes without luck.

Having the same issue on port 3 with my P1S and AMS. Fails to retract at 99% print status. Resuming print immediately after closing the error throws the same error again and the spool is pulled off the rollers. My temporary solution is to stop the print (because retracting the filament was the last step anyway), turn off the printer, then try again after 5 minutes or so when the hot-end has cooled. I had assumed that there was a mechanical issue in the extruder due to melted filament, but seeing how it’s been port 3 for everybody here is very strange.

I was using Sunlu PLA. I’ll try and recreate with Bambu PLA.

Same here. A3 with AMS. Tracking this thread

1 Like