AMS Port 3 gets Stuck when changing Filament

I Recently got my new Bambulab X1C,

i now got Problems with my Sunlu Pla+ Filament in Port 3 of my AMS. Sometimes not everytime, when the AMS trys to retract the Filament when a colour change starts, it gets stuck. And the display says that the AMS is jammed. When i then go to “try again”, and slightly push the filament roll backwards when the nozzle heats up to 230 degrees, it suddenly gets free and rewinds normally.

I got these problems only with the Port three of the AMS. The Rest works perfectly. I want to test today if maybe the Filament ist the Problem (wet, etc …) And i will put in an original Bambulab PLA Filament for testing.

But did anyone here got similar Problems and got a solution for this? Do i have maybe a particially clogged nozzle? Prints a pretty fine, and the other AMS Slots work normal.

1 Like

I had the same filament and same problem. It turned out the roller by the retractor gears and up slightly. I had to snap it back into place. It is difficult to see if it is up or not. I posted a thread about it here in the forum with a picture showing it.

I have the same problem with the 3erd Slot aldo a filament that works in the second now doesn´t work in the third and viceversa the ona who get stuck in the third, works fine in the second.

Now I read this and I pull out the rollers and put it again in the other way and I´m trying it now…I hope it works!!!


So this is happening A LOT. Always the third slot. I have participated in at least 3 threads on Reddit. Here is one: Reddit - Dive into anything

Someone in support or manufacturing should be looking at this. I checked the rollers, they are fine.

Same here, got stuck towards the end of a 16 hour print while I was at work, by the time I could retry (wasn’t stuck) the part had cooled enough to make an ugly layer shift, ruining the print

My number 3 also doesn’t feed correctly most times either. It will fail on retraction, and I will have to move spool a tiny bit backwards to trip sensor, and when feeding back into machine, it will often need a boost to start the feed. Not at all usefull when trying a multi color.
Support tickets are a pain in the ass, so I was gonna buy a new feeder assembly and replace, to try and troubleshoot.
Anyone got an insight?

I had the same problem in slot 3 only with Bambu PLA-CF black. Moved it to slot 4 and no problem.

Dried it thoroughly in filament dryer, RH down to 15%, and no longer a problem in slot 3!

Prior to that, pulling the P tube from left side of hub seemed to temporarily fix the problem; retraction commenced as expected and then I simply reconnected the P-tube.

There’s a YouTube vid that describes the problem as well as some work-arounds that don’t required dismantling the entire AMS.



This does seem to be a recurring problem with slot 3 as I just had a jam with a brand new printer on its fourth print. I had printed with Bambu PLA in slot 1 and printed the Benchy fine, I also printed the extraction tool and that was fine too. I then printed the Benchy with eSun Silk in slot 4 and had no issues. Finally I printed a set of jaws for a PCB tool using Bambu PLA-CF in slot 3 and while it printed them ok, when it did the final retraction it jammed up with the red flashing led. I had to remove the Bowden cable from the buffer at the back and then pull the filament back through by hand.

I also had this problem in slot 3.
When I took the front wheels out I noticed that the bearing near to the gear did not sit properly on the axle.
There was a significant resistance when turning it.

I pushed it around and to the middle, it snapped a little and then rolled freely. No problems in slot 3 since.

I’ve had this in Slot 3 and 4 with multiple filaments. Filed a support ticket with Bambu. It happens at the end of the print job and the spool gets yanked up off the rollers and it stops.

I have a video but I guess we can’t post links or videos here :expressionless:

Yall are terrible at troubleshooting, test sampling, & pattern recognition. Station 3 is identical to every other station and this problem is equally likely to occur at each station.

Had it today with my 3rd slot. Just look at rolled and it look a bit up on right side. I reseated by sides of roller and it looks flush now.

The incorrect roll sizes may have something to do with this issue as well.

So it appears this isn’t a spool issue. I hadthos happen with their own spools. One thing I noticed is if I pull the PTFE tube out of the left side of the block on the machine (if staring at backside) and pull the filament out of machine the AMS is able to unload.

+1 here on slot 3 with the pla-cf sample. In this case it’s jammed hard, I have around a cm or so give in either direction but it’s not coming out.

Looks like I’ll have to disassemble the AMS to get it out. :person_shrugging::sweat_smile:

Have Bambulab spools in mine. There are obvious skid marks on it.

Use the external spool holder for CF. Also, raise your glass up if you can and use the ShortStack from printables. These both will help with the Slot 3 issue. You might even print a couple extra chain clips to put before the one that is already on the chain.

Same here.

It is stuck on the back of the printer where this spring is.

If have to disconnect the tube or i try to pull and push the other side. And then it retract again.

I’ve been having this issue for ages. It’s spool slot number 3 in the AMS. I’ve replaced the feeder head twice, moved to the hydra mod, tried everything mentioned in these posts and still no go. The yellow gear from the first stage feeder uncouples from the active support shaft assembly when the AMS tries to retract the filament. Sounds like gears are grinding when it happens. Sometimes it sorts itself out, sometimes it doesn’t. This is with official Bambu filament on the original spools.