AMS skip auto refill

Hi there,

two times in a row the AMS skip the auto refill even if is checked inside the AMS settings of the bambu app.
I have set 2 identical filament in slot 1 and 3 black on the AMS tab of the slicer ( orca), I put for both in black color and Bambu PLA Basic with the same K factor , then in the slicer’s preparetab I put the same profile into the AMS for the 1 and 3 filament roll.
I started with the 3 roll and as soon is finished he doesn’t start with the 1 roll and ask me to put the filament inside, so I have to open the AMS take out the empty roll, move the other roll from lot 1 to 3 and then continue the print…
Any guess ?

There is a ‘auto refill button’ in both Bambu Studio and Bambu Handy that will display which spools will auto refill.

Hi, where ?
I have only this button in the AMS tab and show me only an explanation, the same windows exit even if the filament are exactly the same

You need two slots to have the same setup for that to work, including the color

Two slots have to have the EXACT filament definition, and one CANNOT be the external slot. AMS slots only.

If you’re trying to use up some ends, give the both give both slots the same Generic PLA and pick a color, like white. If they’re not Bambu spools, the AMS only knows what you tell it.

The color was exactly the same black, filament was exactly the same Bambu PLA Basic and also the k factor was the same. Of course the spool was not external… Slot 1 and 3

I’m not sure what in a "Bambu spool spec’ could be different. I haven’t tried Auto Refill on two Bambu type spools. Try setting them both ‘to generic PLA’.

Now I put two identical generic pla spool into the ams setting but I can’t see the message like your, how did you manage to make the auto refill showing the filament order ?

You just click on that button that you already found. Then you get that rotary-looking dialog that I posted. If you do get the ‘auto refill’, when you submit a job, it may not show the correct spool as the startup one. There is a down arrow that will let you change which spool to start with. I think it’s dumb and shows the ‘last loaded’ spool. Just use the pulldown and switch spools.

I don’t see 2 spools the same in picture you posted above. Slot 1 is empty and 3 is black. Or am i missing something?

A1 & A3 are both white PLA. A1 is almost empty, but it usually selects A3, even though the color in the slicer was for A1. In that case, at the job start, you can select the spool you prefer. In this case I prefer A1 to be used up.

sorry I replied to the wrong post was meant for OP

No way, also in Bambu studio.
I doubled check all is the same, how you can see in the pictures.
I have no idea

First spool in slot 1

Second spool in slot 3

Button pressed

Filament in the slicer


More info:

Orca ver 1.8.1
Bambu studio ver


I think is firmware bug…

Go to settings in Bambu Studio and make sure you have ‘AMS Filament Backup’ checked.


1 Like

It works for me. I didn`t know this feature existed either

1 Like

Can you tell me the model and the firmware of printer and ams ?

Yes! It’s an X1C with the latest firmware( The two AMSs are also with the latest firmware(

I am using firmware provided polymaker presets.

I also made changes from Bambu Studio and from the printer UI also.

All performed as expected .

I made all slots the same material. It then showed me the sequence of events to which order each roll was used if each went empty.

1 Like

X1C I wonder if this problem is with the P1S, maybe some P1S can give me some feedback

1 Like