Bambu Studio Bug Reporting Thread

I’ve filed them through MacOS, but almost every time that I quit Bambu Studio I get a Kernel Exception error. Hopefully Apple is passing them along to you, but there is nothing in the local Logs to indicate the exception, it seems it happens after the app closes.

Mac Studio - M1 Max
MacOS Ventura 13.3.1

Sorry, BambuStudio v

Some settings maybe not accessible in other languages than english!

Please note that some translation are longer than in native english and therefore kicking buttons out of scope.

Here is one example where the plus button for the height range settings got lost:



Using V1.6.2.4 with Win11

Problem: Changing filament during pause at layer height hangs at “Confirm whether the filament has been extruded”
Studio Version:
Platform: Windows 11
Steps to reproduce:

Open Bambu Studio
Slice a model and insert pause at desired layer height and send model to print.
Printer pauses at desired layer height
Click ‘Unload’ button via Bambu Studio and swap filament
Click ‘Load’
‘Heat the nozzle’ works
‘Feed new filament from external spool’ works
Bambu Studio is now stuck at ‘Confirm whether the filament has been extruded’ and the temp goes down to 142 degrees. Unable to raise temperature. No notification box popups.
Unable to raise temperature via P1P Control panel.
Unable to resume print.

Cancelling the print will then only display the message 'Please observe the nozzle. IF the filament has been extruded, click “Done”; if it is not, please push the filament forward slightly and then click “Retry”.[07FF 8007 121829]

“Spiral Vase” option gives ridiculous error.

When it is selected after object was cut in to two, but sill has assigned same material for both parts.
Error message reads:
“Sprial (vase) does not work when object contains more than one material.”

This is ridiculous as object only contain one material.

Problem: Slicer messes up with spheres
Studio version:
Platform: Linux

I’m having problems with spheres in step files. I’m attaching a sample that has a vertical cylinder with a sphere fused on top and a rectangular keyway on the side. Here is how it looks in “prepare”, note the sphere at the top:

Here is what happens when I slice it, notice that the sphere is missing:

I have the slice slider at the top and all layers selected:

Step file:
3MF file:

Problem - 3mf file loading failed to open in Bambu Slicer. - “The file does not contian any geometry data”

Studio Version
Platform Windows 10

Steps to reproduce

1 open Bambu Studio
2 open project Caleb Board.3mf
3 get The file does not contain any geometry data. error

Not a bug, but an unwanted “feature”!
Since Bambu Studio steal focus. For me, who is using virtual screens, it is a very annoying function which make Bambu Studio shows up in the screen I’m working in!
Please remove it or make it selectable.

1 Like

Problem: Bambu studio cannot send files over LAN/WIFI to device.
Studio Version:
Platform: Windows 10 pro
Steps to reproduce:

  1. Open bambu studio
  2. Slice file
  3. Choose send instead of print file

And then you get following error

And that is very much an incorrect error message as the device sits on the same VLAN as my computer just using the WIFI instead.

Anyone else have an issue when trying to send a print from studio to the printer with Flow Dynamics enabled AND using a 0.6mm nozzle? I know the printer currently does not allow for flow calibration with a 0.6mm nozzle since I’ve tried to.

However, the printer nor studio prompt an error message when trying to send a print with flow dynamics enabled. It just goes to an idle state.

Problem: (Non-critical issue) Bambu Studio camera monitoring looks “glitched out” when switching resolution from 720p to 1080p on Mac OS
Studio Version:
Platform: MacOS
Steps to reproduce:

  1. Open Bambu Studio
  2. Slice a model and send print to device
  3. In the Device tab, start monitoring with the :arrow_forward:︎ button. Notice the streaming video looks good.
  4. Open gear icon in top right of camera view and change resolution from 720p to 1080p
  5. Notice the streaming video looks “glitched out” – like there’s a network transcoding issue
  6. (To resolve issue) Restart stream to refresh. Stop video streaming with :black_medium_square:, switch to Preview tab, then switch back to Device tab. Restart video stream with :arrow_forward:︎. Notice stream is now displaying correctly and is in 1080p as expected.

Log file: No log files generated. Software is still running. Last log files generated 2 days ago. There was no crash, this is a non-urgent UI-visual-only issue.
Other information: Mac OS 13.4.1, MacBook Pro 16 2019, Bambu X1-Carbon

Thank you for all you do, dev team. This entire Bambu ecosystem is incredible and feels natural to use. Amazing work!

Problem: X1C filament sensor doesn’t detect filament end after a power recovery
Studio Version:
Platform: Win11
Steps to reproduce:
**Firmware version : latest at this date


  1. Run a print with not enough filament (was a 1.2Kg print)
  1. Switch off power then switch on again ( = have a micro power shortage at home)
  1. Wait for the printer to finish the current spool
  1. Printer will continue to print nothing, won’t detect anymore the end of filament, probably because of the power shortage. Print won’t be stopped and AMS won’t switch to another roll.

Log file: not needed
Other information: no

Problem: Slicer counts wrong from layer number greater than 733
Studio Version:
Platform: Win10 Pro 64
Steps to reproduce: slicing an object larger than 733 layers (Z axis)

The error looks like the hundreds digit is lost at 733 and the tens digits then slide forward. The problem continues with the next hundreds turns.

I can’t reproduce this using a tall primitive shape.

@ElNino, after the initial layer, what is your layer height?

An initial layer of .20mm and 9.60 mm height after 730 layers would be about 0.013 mm per layer, and I don’t think that is possible on a Bambu printer. What do you see with 0.12mm layers?

Blockzitat @ElNino, after the initial layer, what is your layer height?

The object start direct on the plate and the high is 133,16mm or 1109 @ 0.2mm.

For explanation: The two screenshots i attached are one layer diffrence (one click on the up key). For me it seems there is much more buggy, this counting makes no sence to me, it gets really confusing when the support structures are activated.

I have just identified the cause. I am using a 4K display with a resolution of 3840 x 2180 pixels. The system font is set to 250% scaling.

The scrolling digits on the scrollbar are hidden by the surrounding frame element, because it does not scale (enough).

screenshot with 100% font scale:

I see. I use a similar screen (a 50" TV), but I’ve never actually used it with scaling set that high. 100% or 125% is all I ever use - I want to see more, not bigger.

No, you don’t. I use a 17" Laptop Workstation and the 250% is the default setting there. If the settings are much smaller, you will not be able to read anything. See my last screenshot.

Yes, at 4k on a 17" monitor, I would not even be able to find the text, and certainly could not read it. It already takes a bit of a squint for me to use 4k at 100% scaling. I suppose it would be a nuisance to switch to 1080p just for a single program.

Problem: Bambu Studio not synchronizing Presets, Filaments and configuration. Impossible to print
Studio Version:
Platform: MacOS 13.5.2
Steps to reproduce:

  1. Open Bambu Studio
  2. Click Prepare
  3. All previously defined presets are gone. No Process/Printer/Filament presets are sync’d

Note: All was working OK this morning. Not sure what happened. Tried uninstalling / reinstalling but issue persists

Log file: uploaded log file following this guide :
Other information: Mac OS 13.5.2, MacBook Air M2, 2022