Bambu Studio Bug Reporting Thread

Hello, I´ve the newest Version of BambuStudio. I don´t know, if this was former, but I recognice a very low transferspeed to the Printer. There is maybe around 0,1 to 0,2 mb per sek. to Cloud and backwards to the Printer.
I´ve a Gigabit Network at Home and from Vodafone.

Problem: Bambu Studio won’t open if I’m using multiple monitors attached to my laptop. I have to unplug the USB cable to my docking station and only use the laptop monitor. If I have Bambu Studio open and plug into the docking station, it will freeze up and become unusable.
Studio Version:
Platform: Windows 11
Steps to reproduce: A: Using multiple monitors attached via USB cable to docking station, open Bambu Studio. It won’t open. B: Open Bambu Studio on laptop and, once open, connect to docking station via USB and additional monitors. Bambu Studio will freeze and become unresponsive. If you close and try to reopen, it won’t open. (Same thing happens with Orca Slicer).

Problem: Bambu Studio printer P1S preset “machine code” section is corrupted in cloud save and is automatically downloaded overwriting the actual defaults.
Studio Version:
Platform: Win 11
Steps to reproduce:

  1. Open Bambu Studio
  2. Change printer in ‘prepare’ tab away from P1S default to observe that Studio thinks it has been modified.
  3. See following message:
  4. If attempt to print anyway, receive this message:

Solution: Allow cloud profiles to be reset. Bambu Studio automatically downloads a corrupted preset from the cloud for the P1P labeled as the P1S which gives an error associated with the machine code and “wrong printer” when using the default P1S profile.

Other information: Windows 11, Desktop

Problem: When an AMS is connected and you have a bambulab white spool in it then you can’t see the remaining capacity because the background is white.
Studio Version: 1.03
Platform: Windows
Steps to reproduce:

  1. Load a bambulab white filament into the AMS
  2. Go to the device tab
  3. Enable update remaining capacity
  4. Notice that you can’t see the level

Other information: Windows 11

I updated to this morning, and it is crashing when I send a print. Tried to reinstall, and it is still doing it.

I have installed Bambu studio and can’t print any more when I send to printer can’t select witch rol in AMS. On hole studio it see my filaments in which AMS slot they are but when in click on send to printer he doesn’t now we’re they are and i can’t select them also I can only choose the slots who have no roll.

If you look good in the slots I can’t select you see my filament is there.

I installed a older version and all work again so it must be something in this new software

Printer is up to date als AMS with latest firmware

It is a Bambu Lab X1 Carbon with 2 AMS

My black roll is in A2 and the Yellow in B3

Greetings Ed

Installed new BL Studio All of my AMS slots were showing the same material. Reset the slots and put in the color and type again and still displayed the original material. Couldn’t get it to respond and unable to print since i can’t choose the “correct” material. Uninstalled this version and moved back to the previous. everything works fine in the previous version.

I’m not sure this is actually a bug or just something I need to change with my work flow.
Problem: if you want to print another model using the same settings and import it into BS, the original print file name stays the same, which makes it difficult to find again if you want to reprint. To avoid this, you have to create a new project every time you want to slice a new model, which for me at least resets the slicer settings.
Studio Version: latest
Platform: Windows
Steps to reproduce:

Load a model into BS and print. Load a second model into BS and delete the first one, slice and print. The sliced file name will be the first one you printed.

OS: Windows 11
Issue: Studio complains about too high bed temperature after starting the print. Even after just switching on the printer and actual bed temperature is in normal range. Printing is normal after ignoring the error message.

Problem: wrong slicing with Arachne
Studio Version:
Platform Windows 10
i created a box
in one section the outer wall crosses the inner wall and the filling

slicing with classic wall generator: ok
slicing with orca arachne: ok

used this .3mf Box

Bambu Studio v1.07.07.89
Plattform: Windows 11

After successful printing, I cannot rate the object in Bambu Studio with 4 or 5 stars.
But it works via the website.

Got same error when added two colors. Both Generic PLA.

layer count under device tab does not match layer count on preview pane

Wrong spool used from AMS.

I selected A2 from AMS to print from, After I clicked on Print I saw it had A1 Selected, I chose A2 from the print window and the printer started printing from A2. The print failed, I cleaned the print surface and selected the option to print again from the printer screen and the printer switched to spool A1 rather than printing from A2 as I had selected. Bambu Studio is Version on Windows 10. Printer is Bambu Labs X1 Carbon Combo While this time I had White ASA in Both A1 and A2 slots, they were different Brands and I wanted to print from A2 because slot A1 was almost empty and the print was small and I was concerned that after the print there would be insufficient filament for the filament rewind to work. I don’t think there is a way for me to select a different spool when doing a print again. If there printer is going to change spools like that a warning message should be given but a better solution would be to use the spool that was requested rather than switching spools. I have had similar issues in the past where I had a spool of PLA in one slot and PLA Silk in another slot that were the same color the printer kept selecting the PLA silk spool after I specified the PLA spool, took me a while to figure out why I was getting prints with the wrong filament. I ended up switching Spools so the spool that I wanted to print from was in a lower numbered slot to get the correct spool when printing from the PLA Spool.

Problem: Wrong spool used from AMS.
Studio Version:
Platform: Windows 10
Steps to reproduce:

    Place Similar Filament spools in two of the AMS slots (Say Slot A1 has PLA Silk in Gray and Slot A2 has PLA in Gray) 
    On the prepare tab of Bambu Studio load the part to be printed and press the 2 key to select the filament in slot A2 
    Slice the plate
    Select Print Plate
    Notice that Slot A1 is now selected (A2 should be selected since it was selected in the prepare tab)
    Select Slot A2
    Start Print
    Stop Print
    Select Print Again
    Notice that the printer changed spools and is now printing from spool A1 and not A2

Log file: Upload was not authorized
Other information: Printer is Bambu Labs X1 Carbon Combo

Problem: Bambu Studio sees the “Bambu PLA Matte” profile correctly when importing from AMS, but AMS things the filament type is ABS. So when I try and print, I cannot select that spool, because it is of a different filament type (even though it is not)… This started after upgrading to
Studio Version:
Platform: Windows 10
Steps to reproduce:

  1. load any non Bambu filament into AMS
  2. Define the filament and select the Bambu PLA Matte profile
  3. Click Save (notice the AMS thinks you set it to ABS)
  4. Go back to model and resync filament (here it says it is matte PLA)
  5. Set model to use that matte filament
  6. Slice plate
  7. Try to print
    Issue: system wont let me select that filament (even though it is what I sliced with) with a message stating “Note: Only the AMS slots loaded with the same material type can be selected” I go back to look at the filament defined in the AMS and it says ABS, not PLA. Rinse and repeat, it will happen every time.

There doesn’t seem to be a way to create a post…
Only a reply to the OP.
Is that what you mean?

I don’t have a bug in my slicer in the sense that it isn’t doing what it’s told. I was encouraged to submit a bug about the docs being very limiting in certain areas. I can only try to explain my case, to see if the point gets across.

I was printing something to the edged of my plate. There are, what I learned after about 2 hours of frustrated research, Flow Calibration lines printed by default on my bed that the slicer shows, but otherwise ignores. No conflict warnings, nothing. And then the printer just prints over them without any warning. It’s not like it’s compensating for them, no. It just prints like they are not there.

Without knowing the EXACT TERM for them, it took hours to get some help to find out what they were, what they were called, why they were there and when they were important or not. Once I had the term, your docs have a few things about them. not much, but not nothing. But before I knew what they were called, I was finding people saying that you could not turn them off, people saying we had to pause the print after printing them and scrape them off to resume printing. how dumb is that requirement? lol. I believed this could not be the case from a company who does printing so well. ( I love my X1 ) I searched the forums, the community, reddit, etc. and nothing led me to the place I should have found in the Bamboo docs easily.
So, I’m here to just ask you guys to amp up your docs to the level of your printers. get some AI in there or something. It’s a mess in there unless you already know exactly what you’re looking for and what it’s called.

    {if (bed_temperature[initial_extruder] >45)||(bed_temperature_initial_layer[initial_extruder] >45)}
    M106 P3 S180
    {elsif (bed_temperature[initial_extruder] >50)||(bed_temperature_initial_layer[initial_extruder] >50)}
    M106 P3 S255
    {endif};Prevent PLA from jamming

P1S Machine start G-code,
It first checks if the temperature is above 45 and only if that is not the case it will check if the temperature is above 50, with this gcode the printer will never use the if statement for 50 because if it was higher than 50 it will not come acros it because everything higher than 50 was already higher than 45.

Fix: Swap the two statements like this:

    {if (bed_temperature[initial_extruder] >50)||(bed_temperature_initial_layer[initial_extruder] >50)}
    M106 P3 S255
    {elsif (bed_temperature[initial_extruder] >45)||(bed_temperature_initial_layer[initial_extruder] >45)}
    M106 P3 S180
    {endif};Prevent PLA from jamming
1 Like

Im having similar issue: when camera is set to 1080 the image is bad and pixilated.

Problem: Bambu Studio PA profiles unavailable on Mac after a short period of time
Studio Version:
Platform: MacOS
Steps to reproduce:

  1. Open Bambu Studio
  2. Look at the PA profile from the device (it works right now)
  3. Switch Devices
  4. Look at the PA profile, they’re no longer showing, open and try to edit the profile/filament (the drop down no longer works)

If you start the computer, seems to work fine again for a little. I’ve tried this on 2 other machines and same thing. Maybe a memory issue? or something?

Other information: Mac OS 14.3.1, MacBook Pro 16, Apple M1 Max, 64GB

I’ve encountered several bugs.

  1. The app resolution is low, the window is much lower resolution than other apps.

  2. In the device tab of the app, the filament box doesn’t fit (the right side of the box is cut off but will resize correctly only while holding the left mouse button in a resize attempt and snaps back once released to being cut off.)

  3. If I click on the fan icon while in the device tab, the app just crashes.

IMac 5K OS:10.15.7 Bambu Lab