Bambu Studio - Minimum layer time setting

Moved over from Cura and trying to find where I can specify “minimum layer time”. Thanks

This will do for now: filament profile → cooling → minimum print speed

There is a layer time on the max fan speed threshold field. If the calculated layer time is lower than this value then the print will slow down if the “Slow down for better layer cooling” box is checked. Defaults to 4 seconds, but you could raise it.


I just printed a calibration cube with these settings and it definitely printed the layers much faster than 4 seconds. Where is that min layer time being overridden?

You may need to set the minimum print speed down. If the time is faster than 4 seconds at 20mm/s, then it prints at 20mm/s regardless of the layer time setting. Try 10mm/s.