Camera feed won't show in the Bambu Handy anymore

I’ve been running my P1S for about 2 months now and love it.

But since a couple of days, I cannot get the camera feed to show in my the Bambu Handy app anymore (I use an IPhone).

All the other app functions work (progress, temp etc.), but when I click on the arrow to start the feed, I just get a turning wheel for a few seconds and the screen stays black.

The video feed in Bambu studio works as well.

I’ve restarted the app, restarted the printer. No change. The only idea I have that it might be related to the recent IPhone firmware update to 17.1.2.

Can anyone help me out?

4 Likes

I was having issues this morning, but I’m on android. Seemed to resolve itself a few hours ago. Wonder if its that plus an iOS issue.

1 Like

I had the same issue yesterday on my iPhone, but today it works fine remotely, maybe their proxy server had issues?

I submitted a ticket a few weeks ago. Bambu acknowledged there was an issue especially if you were doing any video recording. I did so get an email saying the issue was resolved and to reinstall the handy app and rebind the printer.

See if that resolves the issue.

Well it worked again for some time last night, then wasn’t working this morning. And when it worked, the connection took forever to establish.

1 Like

Sounds exactly like what was happening with me before I submitted the ticket. Also had connection warnings or just one frame of video showed up. I’m not printing anything at the moment, but I can load the video via the Handy app fine remotely.

Did you uninstall the app, delete device, and rebind?

i reinstalled app reinstalled printer came on once now wont work again! did you get it working

It just started working again

It was an bug in the iOS version of Bambu Handy app. It should be resoved alredy.

I also have not been able to view any video on Handy since I updated the software a few days ago (Android version 2.4.0)

I am now having this issue on my Android Phone with my X1C. i’ve reloaded the software and rebound the printer. All functionality is there except the video which times out every time i try. I can use the video connect via the bambu studio on my laptop.

FYI in Android the workaround is to open app overview and swipe the app away to close it. Then, open it again and press play. If you navigate away from the camera view for a while and come back it won’t load anymore. You must close and reopen the app. It’s so annoying.

I’ve been having this problem for a week and cant get it to work again. Reinstalled and rebind and everything.

I’ve had this issue too, sometimes it works again when I close the app on the pc. But doesn’t always work.

I’m on android 14. It never worked.
On PC it’s fine but since the printer is behind my back I don’t need it.

Here are some troubleshooting steps you can try to get it working again:

  1. Close and Reopen the App: This seems to be a common fix. On iPhone, swipe the app completely away from the app switcher and then reopen it.
  2. Check Camera Permissions: Make sure the Bambu Handy app has permission to access your iPhone’s camera. You can usually check this in your iPhone Settings > Privacy > Camera.
  3. Update the App: There might be a fix in a recent update for the Bambu Handy app. Check the App Store for any available updates.
  4. Reinstall the App: If the above steps don’t work, try reinstalling the Bambu Handy app. This will clear any temporary data that might be causing the issue.

If none of these steps work, it might be a good idea to reach out to Bambu Lab support directly. They may have further insights or potential solutions specific to your situation.

I have had an issue with my app doing that as well. Sometimes just a force close and reopening the program fixed it, sometimes a restart of the phone would fix it. I would say that if neither of those fix the issue, you may try uninstalling and reinstalling the app and seeing if that helps. I have had apps in the past stop working and a fresh install of it resolves my issues.