Cannot print from Studio because filaments in AMS are not recognized

Bambu Studio (latest version) can connect to the printer, because I can see that it reads the current filament definitions from my AMS. When I PRINT the plate to the printer, however, the PRINT dialog asks me to match the filament I selected with the printer slots. I REFRESH the printer and it does the same.

When I try to match the filament in the AMS with the filament selected on Bambu Studio, it doesn’t let me select any of the slots, and tells me that “Only the AMS slots loaded with the same material type can be selected”. They are grayed out.

Surprisingly, the grayed out filament slots say “PETG+”, while the AMS slots (both in the printer and on Studio) correctly identify them as “Generic PETG”.

The result is that I can’t print anything from Bambu Studio.

On the other hand, if I SEND the plate to the printer, when I try to print it from the SD card it gives a weird dialog about temperature of vitrification on the filament being below the plate temperature. What gives?

All of this happened after updating to the latest Studio version, but when I go back to a previous version it still happens.

Please help, thanks

1 Like

Have you done a factory reset yet? After updating the firmware a power cycle and a factory reset are something I would suggest doing.

5 Likes

Thanks, @JonRaymond : YES, I have done a factory reset. No change.
It looks to me like very poor logic (configuration management?) when in the same application (Studio) I can see different filament settings when I look at the left panel of the Preview section vs. those shown in the Decide section.

Left hand - right hand kind of schizophrenia… :confused:

Dumb question, have you tried rebooting your computer? Typical IT response I know “Have you turned it off and then on again” but surprisingly how often it fixes things.

5 Likes

:slight_smile: there are no dumb questions when you are trying to help.
I just did, as you suggested, and no change
Thanks again

So, I tried to create a ticket. The web page asks for a log file. So I create it on the SD card, and try to upload it… The web app doesn’t recognize the .tar file. So, no way to create a ticket?

This level of clumsiness on apps and support pages is beyond irritating :frowning:

1 Like

I have had the same issue with the AMS. It seem to be an issue when you mix types of filaments in the AMS (I had 3 rolls of Bambu PLA and 1 PETG). I got the same error message and the software wouldn’t let me choose to use the PETG and it also kept giving me an error when I tried to use the hot plate to print on. This forum is kind of hit and miss when it comes to help. What helped but it is a pain is to try to keep all the same type of filament and re-sync the AMS to the printer

There is also a setting on the printer itself to make the printer re-check what kind of filament is loaded in the AMS when you turn the power switch back on. It has been my experience so for that if you swap a roll out the AMS will not recognize that on its own until you force it to by turning it off and then making it boot up again. It is not very intuitive and the help on here not very good for the most part

2 Likes

Thanks, @wardtp, appreciate the empathy. After a while, I was able to send the ticket (apparently, there is such thing as STUDIO logs and PRINTER logs :slight_smile: )

I don’t expect to hear a response to the ticket any time soon; the page immediately warned me on submission that they are ‘running short in resources’. I read the defensive response as “Hey, we are all about the mini at this point, so tough luck”.

I had a window open with the purchase of the Mini bundle ready to order (card and everything)… but then reflected about my support experience and canceled it. :confused:

Thanks again, be well

If anyone reading this has knowledge about this issue, would you mind chipping in?

My intuition tells me that it is a matter of deleting some junk in the Bambu Studio Configuration, left over from before the last Bambu Studio upgrade, but before I do I would like to know a little more (don’t even know where to find those files).

This is a worrisome episode for anybody concerned about Bambu Lab’s support; It’s been 48 hours from submitting the ticket, and except for the automated defensive response (“we are busy”), Bambu Support is AWOL (All hands on deck promoting and selling new Minis, and they already got my money for the X1C :frowning: )

OK, solved the problem by myself (Bambu Lab Support is still AWOL)

Deleting the app and reinstalling had not helped before. But this time I found the Configuration folder (Bambu Studio has a “Show Configuration Folder” under the Help menu), deleted the folder and then deleted the app. Reinstalled, configured the printer from zero, forced it to synchronize filaments from AMS (otherwise the app would not “see” that I had AMS ???), and that was it.

Thanks to the couple of people who reached out (not to Bambu Lab Support, who ignored my ticket).

1 Like

A folder delete and re-install plus power cycle of the printer did not help.
I was able to get it to work by doing a re-sync of the filament list from the AMS, followed by selecting on the Process line “Objects” then clicking 3 times on the filament list for the object I was printing - this let me change the filament to AMS slot 2 which contained PETG. When I went to print the plate, it had the proper slot already selected and I was able to continue printing. I should mention that my printer had a firmware update today and I hadn’t seen this problem before.

3 Likes

Yes, @vincemiccio, after I closed this issue, I realized that the synch buttons are precisely for that. Further, now that I have the A1 as well, it is indispensable for printing on both printers from the same Studio. If anything, it’s still kind of clumsy (because you need to select. the printer on the front tab, then on the “Device” tab, and finally do the Sync, but it works.

I guess that, ideally, you would just select a printer in the front screen and it will automatically switch all filament and device pointers.

2 Likes

I ran into this same issue. I simply just changed the other three filaments to PETG (even with PLA loaded) just so I could select the actual PETG filament for a single print. It worked for me.

I ran into this issue today. Had the following loading from slot 1-4, PETG/PLA/PLA/PLA. Wouldn’t let me switch from slot 1 to slot 2. I tried “Load Filament” function on slot 2. It performed this function correctly but still didn’t allow the switch. I tried manually unloading slot 1 (pull filament from AMS feeder) and it work!
Don’t know what’s going to happen when I need to switch back to slot 1 (PETG). Seems like a bug.

I had this problem again today and spent an hour fiddling around. I had just loaded some PETG in slot 4, where previously it had PLA. I had some PETG in slot 2 and studio insisted on using that. Could not convince studio that slot 4 had PETG. Finally went over to the printer and changed the filament type manually for slot 4 and now studio finally lets me select it. Theory is that you have to tell the AMS what filament is in what slot manually and then studio will accept it.

Running into the same thing currently. AMS #1 has PLA slots 1-4 in it. I unloaded slot 4 to try my hand at some new PA6.

Load it via the AMS, and select PA6-CF from the dropdown. When I go to print, I’m getting the same error “Only the AMS slots loaded with the same material type can be selected”.

I walked downstairs and manually selected Generic PA6 for the AMS, walked back upstairs, and it will allow me to continue, but as soon as I select my PA6-Polymaker profile, I get the same error again.

Seems like this is a bug, as the AMS shouldn’t care what is really loaded, the printer should be the final source, and override. Would easily solve this issue.

Simple solution to a sticky problem:

TLDR;
Step 1: Resync filaments from AMS
Step 2: Right click (or your system equivalent of right click) on your model (which should be showing on your plate in Bambu Studio).
Step 3: This should bring up the context menu. Then select Change Filament.
Step 4: Wait for your print to finish :wink:

Detailed explanation:

I am not sure but this is what seem to be happening. There is some sort of caching in software, where it ties the part to a filament. That cache is not getting reset in some circumstances. For example you if switch filaments and alternate printing parts with different filaments and then go back to printing an older model etc…

Perfect, this worked for me. Thanks.

Came here for this issue, but needed a different answer. The filament section on the Prepare tab had different Filaments to those picked up in the AMS section on the Device tab. I edited the incorrect filament on the Prepare Tab and it fixed it.

This helped! Thank you so much - you described what was happening to me.