Can't bind p1p to handy or pc app

Sorry, then you have to wait for support for answer.
At the beginning I had trouble to bind, too. After some attemps finaly it did bind.

2 Likes

Any suggestions on what you tried when you first had trouble that ended up working?

1 Like

After taking off the foam on your AP board:
Install a “find my BT” app on your phone. Try to use an app that shows receive BT power. Even though the phone showed the printer could be pared the power received was “too low”. When I messed with the antenna connection and the two momentary switches on that AP board the BT started to work.

2 Likes

having the same problem no response from support ticket or general support email. tried 4 networks it gets on the network fine i can see ip’s my computer can see it but try to mind get the same no valid device error.

1 Like

Probably its regional lock https://forum.bambulab.com/t/bambu-lab-region-lock-china/6602/4

2 Likes

I have not been able to bind since changing to lan only mode. I have multiple emails from support, but the manly say the same advice which I have tried.
Tried 3 different phones 3 different routers
I move to another location in case its my network Nothing works.
When pressing pair on the phone and then on the P1P it does absolutly nothing my phone goes around and around.
I have sent support plenty of the log files and videos.
I ask for a replacement. The told me if they did replace the P1P the problem wont get solved!
I am totaly pissed off with the sugestions coming from support.
Theres nothing else I can do its up to Bambu but nothing happing.
I have spent days trying I am STUCK
Anyone got a solution.

2 Likes

I have resolved the issue with the help of support.
I was pressing the cancel button instaed of the pair selection. I have apolagised to support for giving them a hard time when it was my fault!

1 Like

Just received my P1P and initially couldn’t bind, etc, etc. Then noticed my ipad was on 5G wifi router so switched to 2.4ghz forgot the old wifi defintion, did bind again and it worked right away. I’m going to guess that the P1P doesn’t support 5G and only 2.4ghz like most 3D printers these days.

Clean.all: Take this with a grain of salt, from memory, I think I tried to Bind from LAN only mode. I switch it back to the cloud and then it did bind. I could then go back to LAN only mode.

you know what .that was me with all them problems a couple of months ago.even that i had a new AP BOARD sent out .first thing make sure when bambu asks for your location you say yes to everything .you can turn all that off after everything is working.even if you have to go into your mobile settings and make sure bambu handy bambu has all the permissions turned on.now try again connecting seeing if it detects the printer with out the bucktooth turned on and if nothing try with Bluetooth switched on.i also downloaded 3 apps off the play store .blue tooth apps to try and so called jump start the connection by paring and detecting the printer download them if part 1 still don’t work.but after playing around with the apps try the binding of the printer again.the apps are called …find my Bluetooth…Bluetooth pair …and Bluetooth scanner …i was were you was and and a lot of people are …i had to sort it out myself… so good luck

I had the same issue just now. What solved my problem was completely uninstalling the app on my phone and then installing it again, from then the pairing worked.

While I have no experience with the P1P or with this specific issue I can attempt to offer my insight:

When I first setup my X1C I was having a bit of networking revamp on the network the printer was using.
When trying to bind on my phone using Handy it would time out while trying to bind.

I instantly knew this was due to the fact that my phone was currently only connected to the local network and not the WIFI, I had downloaded Handy via Mobile Data prior to connecting to the WIFI’s internet connection(DNS) to follow the installation instructions.

Rearranging my DNS etc I had hard coded the values on my phone and had not updated the params of statics yet. I also had several certificates disabled at the time that Bambu probably utilizes.

So to summarize, if your network configurations are not well understood or maintained at the time, you could end up with very odd results working with Handy even though your mobile device has internet but not from the WIFI. The printer had clear internet from the WIFI due to not having hard coded statics in it’s params.

I doubt this will help this specific issue but I hope you can get it sorted out! These printers are really nice.

bump I just had the same issue. It seems to be related to change in network.

I updated the firmware on my router, which of course bounced the network. in Bambu studio my printer disappeared from my account.

Reset the printer. no change.

The printer is connecting to my wifi and getting an IP address. my router see it on the network (I can open my routers management app and see the printer and IP address)

In the bambu handy app I log in, I have no devices listed.
I go to add a device, no devices listed.
I turn on bluetooth on my phone, then pair to my P1P.
I accept the T&C and click on bind. The handy app get’s stuck “binding”

Over in bambu studio, in devices I see a printer listed with a code I kinda recognize, I click “bind” the status bar jumps to 45% and then bambu studio “hangs”. bambu studio stops responding, I have to “quit” via the taskbar icon.

rant A network change caused My printer dropped off my account!!! it’s like just because some server somewhere on the internet can’t connect to my firewalled off and service provider managed network does not mean the printer I paid for should drop off my account.

1 Like

UPDATE: I got it to work again!
of course I tried it again, because I’m crazy right?
(by “it” I opened the handy app)
This time when I opend the handy app my printer appeared as a WIFI device. as well as bluetooth.
I clicked “bind” on the wifi listing and it successfully bound immediately.
back in bambu studio, by default my printer was not in my devices list. but it was listed BY NAME this time as a device I could print to.

I used to be a software engineer for a consumer electronics manufacturer. We learned all sorts of lessons. The Internet is not a magic system that persists any information. The end user has NO control over IP addresses, routing, none of the metadata associated with a device on their network. the ONLY information you can rely on is info you (as the manufacturer) put on the device (either read only or checksumed). Consumer devices get hacked. Your own registration database can get corrupted.

Bambu: Hire an engineer that has worked on console games infrastructure, or MMO infrastructure. These kind of issues are core in persistant game services, and have been solved in ways that are very robust and inexpensive to implement.

Straight up head***k.

Just some advice for anyone scratching their head:

  1. Make sure your device is connected to your Wifi. If it’s not, start again. Delete the app and reinstall.
  2. Make sure both your device and the printer are connected to 4G. I was getting this “they’re on different LANs” error message. I had to start again.

I had to fiddle around for hours to get it to work. The Bambulab documentation needs to be a bit better.

I got my P1S last night and I spent 7 hours trying to get the thing to connect to wifi, to no avail. I must’ve typed my password about 50 times, and it would timeout and go back to the beginning. I look online and I see hundreds of people dealing with the same thing, and yet never ANY resolution. Does everyone succumb to using the SD card? There is no work around, no way to move forward. How is this acceptable? At best if I do get this thing connected on the 100th try - what happens then it loses its signal in 6 months and I need to bind again? The whole idea of the printer having to connect via bluetooth to your phone, so the phone can set up the wifi setting, so the printer can contact the cloud, and the cloud can contact your computer - it is mental… who thought this would be a good idea? I learned the X1C does not need a phone to set up; you can type the wifi password in directly. Why can’t we do this with the P1S? I have NEVER had this level of trouble on all my other devices (combined). I asked for a full refund, and I am waiting for a reply. I’m not paying $1000 for a hunk of garbage. If it is this hard just trying to connect to my network, what happens when there is a real problem? So disappointed and deflated after the sky-high expectations.

2 Likes

@raderyuh Does your Wifi name or password have any special characters? This can cause issues. Also make sure you are connecting to a 2.4 ghz network. If you also have a 5 ghz network they need to be different names.

3 Likes

any response to help others out?

Just had this problem today. Could not connect printer on my phone or pc after factory reset. Realized I had never gotten Bambu Handy on my iPad, so I figured it was worth a shot. Downloaded the app on my iPad, signed in and added a “new printer” and it worked. When I got back on my phone and pc it showed up.

This is a really good point. I’ve forgotten such a step, but it works 100%. Thanks for that :wave: