Change Filament at specific layer?

I have a P1S (converted P1P) without AMS and initiated the filament change feature at two points during the print. Assuming it was going to work I waited to see if I would get a notification or something telling me to change filament. Came back after 30 minutes and it was just printing along as if I didn’t have that request.

Am I missing something or does this not work?

Change filament does not work without AMS.
You can put a pause at the layer when you want to change. Then change the filament and play/resume.

1 Like

Thank you, I tried out the pause command and it worked. The only issue is because there was no purge tower it took some filament it was trying to purge and attached it to the print :man_facepalming:t4: is there a way to bring back the purge tower it was creating for the filament changes? Maybe that would help instead of dragging purged filament to the print.

If you use the normal load and unload filament commands during the pause it will do normal purging and there is no need for a purge tower.

I used normal load and unload and each time it dragged a small piece of filament to the print sadly after the wipe. Which is weird because that doesn’t happen at the beginning of any of my prints, but it did on the filament changes. lol oh well another reason I need to get an AMS. :grin:

I just did the same exact thing… added filament changes assuming that it would pause and without AMS it didn’t do anything…

Since it knows if you have an AMS or not… maybe they could make it automatically convert to a pause at filament changes without an AMS??

Oh, if you want the purge tower also, for now, just add a filament change somewhere knowing it won’t do anything except create the purge tower without the AMS

1 Like

but it DOES do something!!
filament changes will swap the filament profiles properly (extrusion temp, flow rate, etc)

i swear to baby zeus i added a feature request topic some weeks back asking for a non-AMS multimaterial workflow. something like the ‘pause’ or ‘change filament’ features currently available, but more complete so we could ‘pause AND change filament’. would be great if it could automatically unload/load too, but that’s icing on the cake.

that feature request topic is missing though - was it silently moderated away or something? i’m sure i posted it, but i can’t find it.

similar issue posted in github (but still can’t find my post darnit!): Modify Bambu Studio for easier manual filament color change · Issue #2778 · bambulab/BambuStudio (

1 Like

Did you ever end up finding a solution to this? I’m having the same issue. I’m printing with TPU so AMS isnt an option and the filament dragging is a bit of an issue

It really is unbelievable they haven’t added the ability to do filament changes without an AMS. That should have been there day one. Totally feels like they’re trying to force you into buying an AMS. I have multiple AMS units and multiple printers, but maybe I want to use just one without an AMS.

I don’t know if this method (from this post) works on a P1x, but it does with my non-AMS X1:
First, slice the model. Then, on the right-hand side of the screen when viewing the sliced model, there is a slider that you can slide down and watch the layers of the print disappear. Once you get down to the layer immediately preceding the filament change, you right-click on the + of the slider and say “Add Pause” then you re-slice and send to the printer. (I imagine if you have multiple changes, you can add multiple pauses, but I have not tested).

I found that after pausing, the X1C screen would not let me do anything but resume the print, but I could use the Device tab controls in Studio to manually unload/load the filament.

I also found that I occasionally had a small layer shift after changing filament, which was cured by inserting this g-code at the correct layer, instead of the pause.

M400 U1 ;pause
G28 X ;home

There have been multiple upgrades to Studio and firmware since I did last did this, so I’m not sure if the g-code is still necessary