DO NOT trust your AMS

Woke up this morning to an entire night print wasted. The AMS glitched and pulled the wrong filament slot. Come ON guys. How does it do this? You select slot 3 and it grabbs slot 1??? Slot 3 LED inside the AMS is even blinking!!! The screen shows a white box around slot 3!!! and the filament path to slot 1. SO IT KNOWS IT’S WRONG!

AMS had ONE job

1 Like

The outline just means that’s the slot that’ll be selected if you do a Load/Unload. It doesn’t mean that it’s the slot that should be in use for that part of the print.

Was the print completed or aborted, or did it stall out because of some other error and you aborted it?

1 Like

Don’t know what you are trying to do but your issue seems unique to you. Start from the beginning and describe what you are attempting and what you did if you are looking for help from the community.

Did you select slot 3 in the slicer before you sliced the file?

it sounds like you manually loaded a filament in the ams then printed assuming it would use that one. that isn’t how it works. you have to select the filament in the slicer then it will select the right slot when it prints.

1 Like

I selected slot 3 from the drop down menu on the “Send Print Job” screen. And it pulled in slot 1

The only thing I did differently was untangle the filament and push the filament in a little extra to make sure I had not pulled it out. If that little detail confuses the AMS to the point of pulling in the wrong spool then all I can say is I am disappointed.

1 Like

You don’t have to. I have 2 filaments in slicer and I tell it to pull slot 3 filament on the send print job screen.

Sorry about the fan boys. Its usually the same people too.

Make sure under preparethat you also tell it there what is where.

If you load a print and don’t tell it anything there it will go with the first slot.

Let’s say like my AMS. I have white pla in 1 CF pla in 2 and red petg in 3 and 4

In the prepare screen if I import a part it will automatically assume it is PLA since that is in slot 1.

So before I slice it right click the part and say change filament. Then I select petg

Then part on screen turns red (since that is what I have in the ams).

I then slice check my setting and print plate. Once it loads to the printer the ams knows what slot since I selected it back in prepare. I don’t even have to load it will load it by itself.

1 Like

you dont need to do any of whatever over complicated gibberish that is. Just make sure the slicer and AMS material types jive. Which I did. On the “send to print screen” you select which slot to use. The AMS did not pull from slot 3 as I commanded.

My AMS also doesn’t always follow the filament I chose in the slicer. I sometimes have to correct the program in the ‘send print’ dialogue box. This is super annoying. It usually happens when I print in a single color.

1 Like

Did it for me a few times too during calibration I manually started. I thought I was tripping.


I’ve always done it the way @danmcm suggested above and not tried the way the OP has suggested.
I’ve never had an issue with the AMS picking the wrong filament this way.

1 Like

Same! And I have two AMSs.

1 Like

Same here, Possible Bug - AMS Filament Descriptions - #5 by duane777

Same exact thing happened to me. I have a car part I’ve printed hundred of times, always on the first spool (black asa). The other night, it printed the whole thing from spool #3 (blue abs). I know for sure #1 was selected in Studio. It happened once before and I thought I was crazy, but this time no question in my mind it printed from #3 despite slicing it with #1 selected in Bambu. It was still on the screen when I woke up to blue parts.

I have had this happen, too, but not consistently. I generally run pairs of filaments so that I can run each roll to the end. I try to make sure that every job starts on the partially used roll so I don’t end up with two partials and end up having to be there to manually load a new roll during a job.

The system does what I tell it to most of the time, but there have definitely been more than a couple of times where it did not.

I think we’ll notch this one up to user error. Check twice, print once.

You can check the gcode to see exactly what slot it was told to use.

How do you do this? …