Error message HMS_WARN_07ff_2000_0002

This has something to do with the newest update for sure, I’m not worried about it. If it was a serious/real HMS code it would pop up in the Bambu Handy app under Machine Assistant. Now that I have remote viewing off my LAN I’m not down grading the firmware, I will put up with it.

Same here. HMS_WARN_07ff_2000_0002_0002

This error is not listed. Also, since the update, I have terrible bed adhesion. Was printing yesterday, everything was fine. Updated today, now I get holes and everything. Terrible. K Value is still at 0.020, so that’s not it…

As far as I can tell the warning is shown after filament is loaded using the load command on the printer.
It does not cause any printing issues.

After any update I do the machine calibration, I don’t know if this is needed but did you try that? If so and still have a problem I would try down grading back to you’re previous firmware version and seeing if the issue is gone. Also make sure there is no pieces of filament or debris on the z rod screws and rails, I believe this was the cause of a bed leveling issue leading to bed adhesion I had one time, or I could have been a fluke, but worth checking…only takes a moment, I had a piece of filament right at the very top of the front left lead screw that after removed it was fine. But like I said it could have been a coincidence.

Just figured I’d chime in with a +1. Also getting same error, unmodified machine with latest firmware. Error upon unloading/loading filament. Working fine otherwise.

This is crazy. There are so many error codes that are not documented. Even the ones that are are not always discoverable on the wiki. I have had to resort to google many times to find a code not in the wiki list, but buried on some other page.

If you want this to change

1 Like

If you look in:-
C:\User\USERNAME\AppData\Roaming\BambuStudio\hms
There’s a file “hms_en.json”, in there are the fault codes and descriptions
ie.
{

  •            "ecode": "07FF200000020001",*
    
  •            "intro": "External filament has run out; please load a new filament."*
    
  •        },*
    
  •        {*
    
  •            "ecode": "07FF200000020002",*
    
  •            "intro": "External filament is missing; please load a new filament."*
    
  •        },*
    
  •        {*
    
  •            "ecode": "07FF200000020004",*
    
  •            "intro": "Please pull the external filament from the extruder."*
    
  •        },*
    

These are some I saw higher up in the thread.

4 Likes

I connected my AMS today and it has done about 270 filament changes thus far. I have been looking for the warning message that I have been receiving every time I have been changing the filament on the Ex holder but no error using the AMS, my guess is it’s only when using the external spool, I will try to replicate with the external spool tomorrow. I will only be using the external holder for TPU witch is very rare at this point, I use my Ender 5 s1 for TPU so its safe to say I will not have to look at that error message for while. The message does not effect anything other then my head. Side note After playing around with the AMS I learned I need to buy 3 more…

The capacitance (uF) and voltage (V) both matter. And keep track of which side the + and - were on – hooking it up backwards will fry it (and maybe something else).

You want:

  • electrolytic capacitor, a good brand (Panasonic, Murata, lots of others)
  • around the same or a bit higher capacitance.
  • at least the same voltage rating.
  • check the size against the available volume; needs to fit.

Seeing it too.

My guess is that the driver for the AMS is complaining that the AMS isn’t responding. Because you and I don’t currently have an AMS.

The only significance (for a no-AMS printer) is that they ought to fix the software to only complain when there IS an AMS and it’s not reaponding.

1 Like

This is a great tip for finding the messages that are not documented!

Seeing the definition makes even stranger that I see the message after loading the new filament during a switch on my P1P. By then the filament is no longer missing.

1 Like

So, I do get my same error message when loading filament from the external spool still. I do plan on running PA,PC glass and carbon fiber from my filament dryer to the machine so I do hope to see the bug fixed because I hate to see error messages on anything, if there is one dummy light on in my car it bothers me and I’m a auto tech that knows better that some lights are not as serious as others but still if its there it is annoying.

So glad I found this thread and the consensus is that it is a harmless bug. I get the same HMS_WARN_07ff_2000_0002_0002 error every time I’m loading the filament. It comes and goes like 10 times until the print is started. After that it is gone until I try to load another filament again.

Nothing pops up on the app or in the slicer.

Same happening with my P1P. New machine. Seeing the error when changing filament.

Same here but printing without any issues.

HMS_WARN_07ff_2000_0002_0002

after changing filament and nozzle-cooldown

Just got this error myself, but looking up the earlier mentioned hms_en.json file lists these two errors as follows which make sense to me as they occurred after I unloaded the filament and didn’t immediately put more in.

        {
            "ecode": "07FF200000020002",
            "intro": "External filament is missing; please load a new filament."
        },
        {
            "ecode": "07FF200000020004",
            "intro": "Please pull the external filament from the extruder."
        },

Same problem with my P1P which is 4 days old and the latest firmware that I installed during startup.
HMS_WARN_7ff_2000_XXXX appears during a manual filament change and when the nozzle cools down…
No impact on the impressions but it’s a bit heavy for a new machine.
I will see what Bambu Lab will answer me about this error

I have come to the conclusion it is a firmware bug, I ignore it…as duana777 sated he seen in the json files of bambu studio its for filament runout that I belive it happens when your are between filaments and when you go back to the main screen its a old message…I dont see it at all when using AMS units.

Same error here.
I have it always! while unload / load Filament.
Can print further if I ignore the message.
But by now I tried to print a two-colour-stl. One colour at the bottom, pause and filament change, print the rest with different colour. This failed showing this error again and again. Printer tries loading filament, shows the error and tries reload…
So I have to stop the print, load filament manually and restart it at the already reached high.
That’s not as funny as it sounds…

by the way, no AMS installed…