Feature Request - Option to keep filament loaded in AMS

First off: I have an AMS. I do like to use it not only for cool colored prints, but also as a filament storage and just as a good looking spool holder.

When you print with the AMS, it ALWAYS unloads after the print.
Give us an option to have it act more as it does with when using the spool holder.

As long as the same slot filament is used, the printer would just start printing instead of:

  1. Load, Purge, Purge, Purge, Poop
  2. Print
  3. Cut
  4. Unload

You can currently uncomment the unload command from the End-Gcode which almost does it for me.
When starting the print it does not try to re-load the filament if it stays the same.
However, I could not yet find a way to make the big purge a conditional on IF the filament changed or not.


Actually this would be a useful feature because if you have an end of reel that has slipped past the hub extruder when the hot end extruder ejects, the piece of short filament is stuck in the system and this happened to me after an end of print unload.

When I came to do another print the AMS was in limbo mode, and kept coming up with errors.

Eventually I got around it by forcing a load filament after heating the nozzle and pushed the stuck short length with the new filament.


Thanks for the suggestion. An internal requirement (BBL001-4910) is created, this feature will be evaluated and planned.


Would be very usefull and time saving for those jobs that dont need a reel swap to a different filament. Just keep it in the machine untill it needs to be changed.

I’d also love to see this option.

is there any way we can follow up on this request?

Is there any progress? This will be useful feature.

Good suggestion, a shame that Bambu seems to have gone silent on this.

When you uncomment the AMS unloading from the G-gode, which commands are you actually taking out? Orca currently generates this block for unloading:

; pull back filament to AMS
M620 S255
G1 X20 Y50 F12000
G1 Y-3
G1 X65 F12000
G1 Y265
G1 X100 F12000 ; wipe
M621 S255
M104 S0 ; turn off hotend

Do you uncomment all of this (perhaps not the M104), or just some of it?

Found this post looking for the same thing. When doing iterative prints to test fitment, I want to leave a filament loaded and ready to go. Now it appears that even the option the OP noted has been removed from the AMS settings?

1 Like

Throwing my hat into the ring here… I’ve been conducting consecutive test prints and was optimistic about finding a solution on this platform. However, it appears that the feature I was looking for is no longer available. @Tanklet, do you have any thoughts on this matter?

All my filaments are stored within the AMS. Yet, while making iterative adjustments to models for testing purposes, I prefer to avoid the filament being cut and “put away” each time and instead keep it loaded for rerunning test prints.

i second this. 95% of my prints are using the filament on Slot 1, so there’s no need to cut away and store after every print.

1 Like

I have transfered this to the Bambu Studio team.
It would be more effective to post feature request on github, they will handle these tickets periodically.
Issues · bambulab/BambuStudio (github.com)


Thank for the response, I had no idea that’s what was recommended but good to know for next time. It would be nice if it saved the Bed Level information and kept the filament loaded, heck even keep the machine hot ready for the next print to be sent through.

But I will look into GitHub for future requests. Thank you again! Glad to see you’re back.

have you sent a request on github already?

I didn’t no, Tanklet stated they were going to send it to the team on my behalf this time around.

hi tanklet. i would like to add my desire for this feature. it would be a great way to reduce both wasted plastics, print startup time and user experience !

This feature was accepted and added to the printer firmware’s plan list.


Hoping this will hit the P1S combo firmware too

Any update on this feature?
Its super annoying loading/ unloading just to try a different setting.

The annoyance will shift to the excessive purge on the next print, it needs to set the purge/flush volume to zero as well.