Filament Buffer Jammed

Got a failed to retract filament error. Did all the normal trouble shooting. Problem was the filament buffer. It moved back and forth just fine, spring in place, but it wouldn’t let go of the filament. Couldn’t pull it through from either side. Failed when trying to unload BBL PLA-CF, but I started the print with generic PLA and that unloaded fine, the PLA-CF loaded and printed fine.

I removed the buffer from the back of the printer to get a better look at it, but once I did I didn’t want to disassemble it. Instead, I just pulled the filament harder and it started to move and I was able to get it out. The buffer appears to be working correctly again, I just put it through a few load/unload cycles without a problem…

Anyone seen this behavior before, and if so, do you have any hints as to the cause and future avoidance?

Doesn’t look like there’s a similar thing in the forum, though I didn’t do an exhaustive search. Most hits were about busted filament or a jam in the AMS itself.

1 Like

I just got my X1 Carbon and am having a similar error. Often with the PLA-CF gray filament, it gets jammed in the filament buffer. Disconnecting the filament tube between the buffer and the AMS releases it and it works fine, but in multicolor prints I have to disconnect it several times during the color changes.

I’m wondering if the relatively rough PLA-CF is putting some friction on the inside of the tube, pulling it too far into the connector, which then squishes the end of the tube, pinching the filament and jamming it? Not entirely sure, but would love to hear if someone has a more permanent fix?

I’d love a mechanical drawing of the buffer, so I could see how it worked without having to take mine apart. Maybe I will have to order a spare and I can take that apart and still be able to use my printer…


Exact same problem here right now and I’m glad to see this. It’s a bummer because I was so hopeful for hands-off multicolor prints but that doesn’t seem to be a guarantee at this point.

To get the PTFE tube out, do you just pull it?

This was a birthday present for my wife, and so I did not assemble it, she did, but I’m really not surprised at the not super great documentation. If this was the team that worked on the DJI drones, that was par for the course. Great engineering, brilliant marketing, really rough documentation.

Here’s a link to the wiki page that I found thanks to this thread:

My filament didn’t break, it just got stuck in the buffer. After looking it over, I couldn’t see anything I’d harm by just pulling. So I did. I actually pushed the filament back and forth a bit hoping to “unlatch” whatever was caught in the buffer. But to no avail. So I just applied force. Done a bunch of prints since, no problem, issue has not recurred.

I live by the age old adage that:

  1. If it doesn’t work, force it
  2. If it still doesn’t work, get a bigger hammer
  3. If it breaks, it needed replacing anyway



Haha ya, I can relate. Nowdays I try to observe, poke and prod, carefully disassemble, check what other people have done, and then act. When that doesn’t work, your 3 steps are a core loop of an ultimately effective way of fixing things.

For ours, I figured out that nothing was stuck or jammed.

The filament was actually getting rammed into something inside the Filament buffer which wasn’t filament. It happens with any filament that is cut off flat, instead of at an angle.

We’re working on a custom solution for this.

Thank you for the thread and feedback!

Same issue here. My multi color prints have to be monitored, sometimes the filament looks stuck and I have to shove it just a little and it runs again fine untill…
This is very frustrating

any progress on this? I have the same problem. PLA-CF always gets stuck at the filament buffer.

Nope. But I am an engineer specializing in failure analysis (well, I’m a manager now, but I was an engineer specializing in failure analysis before I became a manager of the same thing).

So if mine gets stuck again, I’m going to take it apart and figure out why and fix it… if/when I get to that point I’ll post any findings.

I’m guessing there’s a spring loaded pawl (or two) that are forced closed to grab the filament when the filament is being pulled from the output side of the buffer, and the pawls release when filament is pushed from the input side by the AMS, and it’s possible for the pawls to get stuck either because there’s not enough mechanical clearance, or because debris is building up, or because the pawls can “bite” the filament hard enough they don’t release as they’re supposed to.


Great. Thanks. Me being a computer science student took the classical IT approach, turn it off and on again, and took the whole thing apart, put it back together and for now it seems work again.

Buddy Id love to talk to you more about this. Most people are terrible at describing problems & troubleshooting in general but so confidently incorrect. Im having the same issue on all 3 of my X1c’s and Ive tried numerous mods to improve. Gotten the failure to extract rate down to 50% occurrence, but if its not perfectly reliable to me then its perfectly garbage.

Haven’t mustered the motivation for further investigation. Happily, the issue hasn’t happened again. If it does start to happen more, you can bet I’ll be taking my buffer apart to figure out why. Failure Analysis is what I do for my real job…


I’m having this issue too with the Bambu pla-cf. The hub is the only thing I haven’t taken apart trying to figure this out. I guess that’s next on the list to try.

Not your issue but for others, whenever ive had a failure to extract filament error, its been from using a thin spool like sunlu that gets stuck next to the drive wheel when using the ams hydra

1 Like

I have had that issue also I found if you move your spool over a little it works.

I had this issue a while back when using some mat filament. A build up of tiny fibers had occurred in the filament buffer causing too much friction on the filament trying to pass through. It took me a while to figure out, was very frustrating.

Actually having an issue with this myself right now.

Bambu Labs PLA-CF stuck hard and fast.

“Could you see the filament buffer spring?
Does it stuck or
Could you try to activate the slider of this filament buffer?”

I assume support means the little black thing on the left side of the spring?

There’s a “pawl” in the hub that lets the filament move in one direction while clamping down on the filament when it moves in the other direction. It rides on a spring. I think it’s that pawl that gets jammed. The spring will be compressed when it jams. That’s what they’re asking you to check. If you don’t see the spring, it’s compressed behind the jammed pawl. If you do see the spring, the hub probably isn’t where the filament is getting stuck.


Should you be able to push it back up towards the AMS reverse through the buffer ( self answer - yes or the AMS wouldn’t be able to retract and swap )

Now it’s the matter of freeing it from in there and from the tight grip of the AMS.