Firmware 1.08 problem

Hi to everybody,
I have X1C AMS combo and I have updated firmware to 1.08 but after update touch screen became useless, only I could have controlled my printer via Bambu Studio or Handy. So I decided to down grade to 1.07.02 and touch screen became operational, but after this downgrade printer started shaking more like some metal parts are loose. I still continue to use like this. So does anybody have any ideas what might have happened.

1 Like

Perhaps the “quiet” parameters were reset. You might try rerunning the Calibrate routines.

On printer screen–Filament > Utilities > Calibrate, then press the green bar. If I recall the last time I ran it, it took about 15-20 minutes to run all of them.

3 Likes

Thanks I will try and update

1 Like

@Ken-N-Texas thank you for your advice, it worked, very less noise now

2 Likes

@ipi3D The question I really would raise is what is going on with your display. I’m on 1.08 as well - and don’t experience any issues with the touchscreen, so this is not a general issue of this release.

2 Likes

@CDS_GER actually I have no idea but for now I have more problems like wrapping and spagetti :smiley: so I will try to solve them first and then I will try firmware update later on

Hello, yesterday I did a firmware update 01.08.00.00 without problem but now slot 2 of AMS no longer loads the filament until it comes out of the AMS. The filament remains stuck after insertion of 27cm.
I checked the hub and nothing wrong inside. The Bambulab filament spool works correctly on the other slots. I was using slot 2 without problem before this update.

Welcome to the forum.

First try a full factory reset and calibration. If the problem remains try downgrading to the previous version of the firmware. That will tell you if it is firmware or hardware related.

1 Like

@JonRaymond actually that problem is solved. As you said I downgrade previous and used like that. And I upgrade again and no problem occured until now. Thanks for advice

Hi, I’ve done factory reset and calibration without success.
How to downgrade the firmware please and where find it ?

Thx

ok, I’ve found the downgrade in the app and try now…

ok, I’ve found the downgrade in the app and try now…

@Alain I am having same problem do you have any updates about this AMS slot 2 issue

After a dongrade with the app and all calibration done, the problem is the same with the slot 2. Do you have an idea where to check ? I suspect the sensor in the hub
I’ve created a ticket

Thanks for info. I also had problems with other slots. I tried mono color with 4 slots I got print, but when I tried to use AMS second color didn’t came out from nozzle.

I have the display issue ever since the upgrade as well. As soon as this print finishes ill downgrade, thanks for the info!

Could you describe the display issue a bit more? I see it’s mentioned above but I don’t see any more details about it.

I attempted to install firmware 1.08 after my printer would not let me ignore it. It installs to 32% stops then gives an error code on LCD telling me to restart and try again. Multipe attempts, same result. Troubleshot everything I could think of (WIFI connection, cable connections, cycled power, unplugged printer overnight, etc…). Initiated ticket with Bambu support. Not much help so far. It’s been 5 days no progress. Cannot print from SD card. Can’t go back to previous versions. Machine is useless at this point. Anyone else having this level of issues? Printer working flawlessly prior to attempting firmware install.

has anyone had any issues with the camera after the upgrade mine is now purple and blurry. I’m going to downgrade in the morning and see if that fixes it.

And you are unable to downgrade from the app?

One thing you can try that may work is downloading the firmware directly from Bambu and placing it on the root of your SD card. I haven’t done this in quite a while so but if I remember correctly you just need to reboot to get the updater to start. If you have any issues with this let me know and I can confirm that there’s not an extra step or MQTT command I’m leaving out