Layershift after Pause - Change Filament - Resume

Hi there,

I tried to switch colour after some layers printed without AMS.
Have set a “Pause” in Slicer righthand at the preview-slider.

Pause works fine, then I change filament with the onboard “unload-load” tools.
After resuming (press play 1x) the print resumes but about 1mm moved beckwards on the printplate.

How can I fix this issue?

Have seen many others with the same problems after Pause → Resume

1 Like

Hi, I‘ve the same problem after the firmware update on my P1P. Instead of “add Pause” try to insert “Custom Code / Command” and insert the following:

M400 U1
G28 X Y

This had worked for me.

6 Likes

Thank you. I will try this.
The filament unload/ load is still available then?

1 Like

Yes, I have done this for testing. But I had sometimes problems with “load”-ing filament. Unload works like a charm, but “load” has some bugs. But You can do the “load” also via Extrude manually. Some users have reported, that the layer shift not occurred if they load the filament manually via extrude.

I think also that the layer shift is a problem of the “load” function, because if you “add pause” to the print order and if the printer paused the print simply press “resume”, then no layer shift exists.

2 Likes

community is great! thank you. I try both and report here!
you´re right: pause (to clean stringing or sth else) does not cause a shift

Thanks print.in.3d! That custom code did the trick perfectly. I was also getting the layer shift on a color change even with manual Extrude to load the new filament. With the new command, it homes after the new color and is spot on with the next layer. (I have not tried with the Load function, so can’t speak to that). Hopefully, we can get this routine permanently added to the pause to avoid this issue for others.

Thanks again!

1 Like

@AboveAverageFlamingo, nice to read, that it worked for you. :slight_smile:

I red this here https://www.reddit.com/r/BambuLab/comments/109m2sr/layer_shift_after_pause_every_time_the_next_layer/ some weeks ago. It may not the solution for all. But for me it worked too. :slight_smile:

I hope, that the guys from Bambu Lap will fix it with a new firmware version.

1 Like

It worked! The Custom-G-Code is the solution - thank you all!

2 Likes

there are so many posts about layer shifting.
It shouldn’t be so hard. There are gcode commands to save the position and restore the position.
Color change, filament running out, pause, etc should all just save the position before any head motion.
A layer shift means the firmware is trying to calculate all the position changes and use some kind of relative positioning to get back to the correct spot. And, it is miscalculating.

1 Like

Worked for me! Thanks!

This doesn’t help with filament run out thought does it. Sucks that this is broken.

If filament runs out, try this: Simply insert the new filament and press “extrude” until the new filament runs through the nozzle.

On my P1P I had this issue as well when I experienced filament runouts and used the Unload/Load functions, it would slightly layer shift upon resume.

Yesterday I updated to the latest firmware 01.03.00.00, and today, went through the same filament runout process and voila, no layer shift! I can’t say for sure if it is the firmware that resolved it, but nothing else in my environment has changed, so here’s hoping.

I can confirm, this problem also exists with the X1 Carbon (firmware version: 01.06.01.00). This macro was the solution. Hopefully bambu lab finally fixes this, since the problem long exists.

I just did a filament runout sensor yesterday. No layershift for me. It was a 120mm long sword handle. All oem profile and presets.

1 Like

Still an issue on the X1C with AMS! @BambuLab

Still seems to be an issue on the p1s and with all the current firmware available installed.

I have the same issue, is it still not fixed ?

Note I was able to fix this by fixing the belt tention. After doing this properly (takes about 5 minutes) everything has printed perfectly again.