Need help continuing print after filament jam

Need help with failed print due to jammed filament.

Need help. Using a spool of PETG in drier with rim rollers. The filament actually knotted up inside the drier not allowing the filament to advance. This has happened before with spools that made from cardboard stock! Is anything I can do to back things up and complete the print, which was going well until it seized up. I’m also not sure what to do with the rest of this PETG because I clearly can’t use them on these spools, at least not in a drier with rim rollers.

Is there any way I can salvage this print?

Update Note: I came across some advice on youtube that cautions not to turn off the bed temperature and then measure the height of the print where it hung. That came to 135.2 mm, but although the layer height is .2mm using that metric doesn’t yield the correct layer. The full height of the print would be 183.8 mm but it’s 1527 layers so that works out to a layer height of .12 mm, so I don’t know what’s going on.

Update Note 2: The layer heights vary in the gcode I managed to export but was able to identify Z_HEIGHT: 135.2 in the gcode. Still not sure how to restart the print since the actual gcode is in the cloud. Do I end that print and start another? How do I do that, exactly?

Update Note 3: Tried several times to post this on the Reddit forum but Reddit filter kept removing it.

The AI I consulted says that there is a “Resume Print” option in Bambu Studio and you can manually set the Z_HEIGHT, but I can’t find the option anywhere. I have a P1P printer with the latest firmware and software.

I may miss the problem, but why don’t you pause the print, cut the filament, fix it (at least enough for printing), and manually feed it?
Continue the print, and manually push the filament to follow the cut one. When the extruder catches it, you can leave it unattended.

The necessity of memorising the z height and keeping the bed heat is related to the standard procedure for any printer without power shortage recovery. From my errant experience, it isn’t as simple as stated in the YouTube video… many minor steps need to be done in a particular order, increasing the chance of ruining the print.

EDIT: whatever you choose, don’t wait to long. At this stage, you probably get an artifact at the current layer.

1 Like

I’ve done all of that but can’t resume at the layer where the printer stopped (1262) because the last layer that actually printed was layer 1136. The printer didn’t detect that the filament wasn’t feeding so I had to manually pause it above the last layer. It was a mindless robot. Make sense now?

I’ve been waiting now for six hours because Reddit kept deleting my question. (Reddit sucks.)

The AI says that there is an “option” under “Device” to resume at a manually entered layer. But I can’t find any such option. I clearly can’t modify the g-code because the one that’s being used is IN THE CLOUD.

There seems to be a mix of solutions, which is confusing.

  1. Did you have a power loss? If not, a recovery on the power loss process doesn’t apply.
  2. If your printer went to pause because the filament is stuck, restarting is just pressing the play. Do it if the issue is solved. Also, you don’t need to keep the bed warm and other stuff, as it is part of the protocol
  3. Or did you manually shut down the printer?

All other AI or not procedures aren’t (at least I don’t know how) possible to implement in BL printers.

1 Like

There isn’t an option to resume at a specified layer height that I know of. If you stopped the print will not be able to resume.

If this is the case, reslice the part with the part dropped into the bed the correct amount. Clear the bed and print the top part of the model. Glue the two pieces together. It’s not an optimal solution but it will work as I’ve done it before when I had a filament clog.

I told you what happened. The filament jammed but the printer went on printing… air. I had to pause it manually. I measured the height and wanted to know how to resume at a particular Z-Height. I never got an answer and it’s now academic because I tried to home the device and it knocked over the print, so there’s no way I can restart it now. I waited 8 hours for a reply that made sense and never got it.

Ultimately the culprit is that crappy filament drier which somehow got the flilament in a knot even though it’s coiled up perfectly. It’s junk but I can’t share the manufacturer because I’d probably be breaking some community rule or something but the initials would be S-L and the missing letters are un-u.

All I needed was a way to back the print progress to that specific Z-Height and resume. Why isn’t this possible? This kind of malfunction is fairly typical as I understand it, so there should be a way to recover. Yes, I know the printer is supposed to detect when the filament stops, but that’s only if it gets cut off. It doesn’t detect a jam so “resume” isn’t an option because it will resume and just drop the filament into empty space.

What a nightmare.

1 Like

If this is the case, reslice the part with the part dropped into the bed the correct amount. Clear the bed and print the top part of the model. Glue the two pieces together. It’s not an optimal solution but it will work as I’ve done it before when I had a filament clog.

Thanks. That’s what I was trying to avoid. There should be an easy way to resume a print at a specific height. I’m surprised that hasn’t ever been implemented for Bambulab. The AI thinks it has, so it must be kind of an obvious thing… because I don’t think the AI is all that smart. But it might have been pulling my leg, even though it’s not supposed to have a sense of humor.

All you’d really need is something like a rewind button.

It’s not currently possible with a Bambu printer.

It’s not and I wouldn’t suggest consulting it.

I would be nice if it was that easy. Unfortunately it’s not. It’s just the nature of 3d printing currently. Prints fail. Move on and use it as a learning experience.

Thanks. When the print head kicked the print off it unleveled the bed so I’m preparing to manually tram it. But I can’t tell from the picture whether I’m supposed to leave the plate on or take it off and just tram the bed. (I think “tram” might be Chinglish for “trim” or something.)

Tram is the correct term. There must have been a pretty decent crash with the head to knock the bed out of level enough that the auto bed leveling doesn’t work. Is the bed visually out of tram?

I don’t even know what that means. I’ve tried several times to run the tramming program, but again they don’t even say whether to do it with or without a plate. Without it drops into those depressions for what they’re calling the bed levelling knobs and they don’t even say which way is raising and which is lowering. It also says to start by setting the right tension on the knobs but the one on the left can’t be tightened enough to get the bolt flush. The one on the right is looser. I’m also almost 80 so expecting me to be able to see well enough to get the right setting is a bit much. And I get down on the floor low enough to actually see the underside of the bed and I can’t get back up.

All I needed was a rewind button. The bed is so far off now I don’t even know there to start. Any suggestions?

Do I have to erase the bed tramming file and start over. The unit doesn’t seem like it wants to get into that program again. It just keeps quitting.

Again, it would help if I knew whether I’m supposed to use a plate. The instructions seem to leave out a lot of things one would want to know before tackling such a process.

OK apparently the instructions for tramming the gadget are all wrong and just made the problem worse. The method suggested here says to use a .04 (I initially typed .4 which seemed thick as a brick, actually) feeler gauge. My tools were stolen so I don’t have one, but I ordered one and will use that method instead. I’m still not quite sure how to do it. I’d think you’d use a smooth plate and adjust with the feeler gauge, but do you still need to use the tramming program (which I can’t get to run at the moment for some reason).

  1. Should I use some kind of smooth plate to do the tramming procedure, or just do it on the bed?
  2. If I have to use the tramming g-code, how do I get it to run now?


Keeping all the same settings without shutting anything down you could just rewind to that layer or Z-Height and resume. It really is that easy, or would be. It’s exactly the same as the auto-resume except you could choose the layer.

1 Like

Do not use that ■■■■, it just tries to answer your question. Well not really, it does not uderstand your question. It tries to find a shape that symbolically matches different shape extracted from your text input. (Simplifying the math “a bit”, but yeah.)

It has no bearing on reality.

You may try to export gcode and make new gcode that skips all basic steps like calibration and just makes sure that z is dialed in and starts.

But… it will likely not work, just do new print.

Exactly, the problem is that the printer requires a home reference and to get it the bed has to move to the top which as the OP found out can cause a crash if there is a part already on the bed.

OK, that kind of makes sense. In the case of auto-renew it already has a reference, so won’t need to “home.” but it does seem like there might be a way around that, operationally.

I intend to use the feeler gauge method to get the bed back in trim, but there are several things not mentioned in any of the procedures:

  1. For bed tramming, do you use a plate or just do it relative to the flat bed.
  2. How many bed adjustment knobs are there under the bed. I thought there must be either 2 or 4 but there aren’t any on the back corners and there might be one at the back center which would be pretty hard to deal with. So, is that correct that there are 3?
    (I haven’t ever touched the back one, so assume you just leave that where it is and level against it with the front two. Is that right?)

I also moved the unit to a higher table so I could see things more clearly without trying to sit on a low stool, which nearly broke my neck.

There are also some mods that I could apply to the SunLu S2 dryer that would make it less prone to fouling the filament. I will probably apply those before trying to complete this current project again. I did manage to get a good food dryer that I’ve successfully modified to dry PETG filament. It desiccates like a champ!