P1P Update Failed (please restart printer...)

Hello, when I try to update the Printer there always occures this error (Update Failed, please restart printer and try to update again). I reseted the printer even put it back to factory state but I always got the same issue that I can not update from V01.01.00.00 to V01.01.01.00… -.-
thanks for helping :v:

1 Like

Same issue here, from>
Tried via printer display, phone and Bambu Studio. Always fails.

After 3 months same issue…
Have you got any solution?

Same here, offline firmware update from SD-Card would be nice.

By chance are you running PiHole?

I tried over several days and it started working on day 3.
@e.amounce I am using a DNS-blocker, which I will turn off if it ever happens again. Good idea!

I have the same issue. It says “restart and try again”. But then it immediately says “update failed”. So, printer is essentially bricked unless I can find a way around this. But since the message appears as soon as I turn the printer on…not sure how to get around it.

1 Like

OK now I realize this thread is about P1 not X1C (mine is X1C), but since I posted the problem I thought I should post the solution I found. Every “update” initiated from the touchscreen was failing for me. But when I went to Bambu Studio on my PC, and initiated the update from there, it worked. I also did a factory reset during my attempts to solve the update issue, and I have no idea if that was necessary or superfluous.

1 Like

I have the same problem in A1 mini when this morning I tried to update to new firmware, any idea that can I test? What do you mean with the DNS blocker? Thanks! :slight_smile: