P1S Bricked

So far not really impressed with this printer. Just got it delivered and hooked everything up. Started going through the setup process and it asked to do a firmware update. I allowed it to do so. After about 30 mins of being at 99% the screen went blank, shut down and never restarted. It now appears that the printer is bricked itself and due to not being able to downgrade the firmware i now have an expensive desk weight. I have opened a ticket but with my luck they are on holiday. It also shows that the SD card is not found as well. I’ve also tried different SD cards with no luck either. Anyone have any thoughts?

1 Like

@TheSituAsian Yep. You just got the printer, and sometimes things happen during a firmware upgrade. Wait for support to respond.


SD cards need to be formatted as Fat32 and under 2TB in size. With the SD card removed does the printer do anything when you turn it on?


Yep it is FAT32 formatted and 32 gigs and the printer does the same thing with the card out.

Just for clarity, the display remains blank when you turn it on? If so what indication are you getting that it can’t find the SD card?


Seems like a lemon. Did you try unplugging it for a while?

Yep I unplugged it over night.

Others that have had this happen the connector was loose on either end of the screen cable or the pins mounted in either connector weren’t popped in all the way.

I checked the back of the screen and the area by the usb but the screen worked fine while setting it up it was after the firmware upload errored out the screen failed

1 Like

That is interesting indeed. If you are getting that message in Bambu Studio, it means that the MPU in the controller board is alive and well. That screen is only possible if the operating system has initialized and presented itself to the network and has an assigned IP address. Otherwise you would be getting a very different message from Bambu Studio stating that it could not find the printer.

So just for the sake of troubleshooting, have you traced the wire that connects the control board in the back of the unit and the other end at the panel? I wouldn’t normally recommend this but it beats waiting for the Chinese New Year and the Bambu folks returning.

Assuming that the front panel is still operational but has become disconnected somehow from the MC, it might be a simple matter of a connector coming loose.

Depending on your level of patience waiting for an answer versus your appetite for tinkering, you could try to re-seat the connectors between the AP and MC card.


Here’s the procedure to replace the AP board. You can use this process to find the location of the AP connector cable to the MC board and simple re-seat the connector.

Hint: Be careful as you peel off the fabric tape if you want to keep it intact. It really only serves as a dust shield so if you tear it, no gig deal, you can simply repair it with another piece of tape, it will not affect the electrical properties of the system. If you’re unsure about it coming off easily, you can use a hair dryer to soften the glue of the tape and make it easier to remove. Pull of all of the tape and set it aside for reapplication. One trick is to have a sheet of wax paper handy to lay the glue side of tape on top of it for easy retrieval later. It will later act just like peeling a label off of a release liner when you go to put it back on.

Safe removal Tip #1: The other thing to be careful of is the tiny little nub of the WiFi antenna. A tiny screw driver will pop it off by prying under the wire side of the connector. You want to pull it off much like a bottle cap. In fact, it looks like a bottle cap when it’s off. here’s a 20s video on how that’s done.

Safe removal Tip #2: The ribbon cable is for the camera. It simply unclips. Here’s a video of how such connectors work.

Use a pair of needle nose pliers to pull the connector off. You will have to pinch the lock of the connector to get it to release. Don’t force it. It should wiggle loose.

After you’ve checked the AP side of the cable, reassemble and test out the printer before moving onto the MC side. If the display lights up and you can access the SD card. If it lights up then the data is coming across, if the SD card is still not accessible then try an air duster to spray out any potential contaminants. If it doesn’t light up then check the MC side of the cable via the instructions below.

Checking the MC side of the AP cable.

If that doesn’t work, here is a link to the procedure to replacing the MC board. You won’t need to take the board out but you will need some long needle nose pliers to re-seat the connector. I recommend something like these pair of 7" pliers. Don’t try to fit your hand using a small set of pliers, you’re more than likely cause more damage.

The connector in position #9 is noted as the AP they mean Access Panel.


Thank you for the info. I went through and tore it apart and checked all the connectors and they all seem to be pinned correctly and there doesn’t seem to be an issue with any of them visually.

It should be noted that a visual check will not reveal a faulty contact. if there is some kind of foreign object debris(FOD) or corrosion or just misalignment of pins, that can only be verified by a continuity test or more simply unplugging and reconnecting the cable.

As I stated at the start, if you’re not comfortable doing that, it’s best then to wait for tech support to get back to you. From what you’ve described so far, my money is on a faulty AP board or cable. I say that simply because you are getting Bambu Studio to connect. If it were a faulty MC board one would expect to get “Printer Not Found” error. Your display shows that your printer named “Friday” was clearly found and has a viable connection to the Studio app.

Now why does this distinction between a faulty AP board and a faulty MC board matter? It means your unit is not bricked, or at least, it is recoverable if Bambu offers to send you a cable and AP board. For me, if it were a brand new printer, I’d send it back but if it were one I’d had for a while and I was comfortable with troubleshooting, I would rather try to attempt my own repair. But this is all down to personal preference, not a hard rule.

Yeah its just wild. Just got the printer and opened the box hooked it up, set it all up, everything worked fine, did the calibration, did the firmware update and at 99% failed and everything went dark. I did unplug all the cables and repluged them in but yeah i think I’m just going to have to wait for support.

If it connects to the network, had you set up Handy? I’ve read a few times but i could have missed it, you could try to downgrade the firmware.

This looks similar to what I went through when I borked the sd reader on the AP board. Tell support you need the printer up ASAP, I got my replacement in a few days. They may have support running from outside of China, stuffs still shipping, so someone is working.

Yep I have it but it doesn’t give me an option to downgrade firmware. I do have a ticket open just waiting for a response.

Did they send you a whole new printer or just the parts to fix?

In my case the SD card reader started bricking the SD cards. Bambu gave me the option to replace the main display which fixed the issue . fingers crossed.

if it doesnt show nothing how can it show no sd card… lol