PLA top surface defects (pillowing)?

I keep getting these little defects on the top surface of prints. Almost like pimples. Using 15% infill. Doesn’t matter on the infill pattern. Have tried many.

Using PLA Matte Ivory

Went to 20% and top layers from 5 to 7 which still made no difference.

Lowered temp from 220 to 215.

Now the issue only happens when printing slopes. If I print anything where the top layers don’t slope and are perfectly level, these defects never happen.

Additional info. X1C. Stock steel 0.4 nozzle with about 100 hours and no abrasive filaments. Bambu PLA Matte Ivory. Stock settings. No modified g-code or anything. PEI textured plate. Printing with door open made a slight improvement which is why I tried lowering the temp from 220 to 215 but that by itself made no difference.

Checking older prints, see the same thing with smooth plate and door closed (the smooth plate runs at lower temperature with PLA).

Printed objects weigh to the gram what the slicer says so overall extruded mass is precisely on target.

AMS is kept about 10% RHD. Could the Bambu PLA be too dry?

Looks like over-extrusion to me. Have you ever calibrated your flow rate?

The sloping you mentioned could be a factor as well. Thinner layer heights would help with that.

Isn’t that what the flow dynamics calibration does before each print? So the answer is yes, on every print.

As I mentioned, the actual weight of the printed objects matches exactly the slicer calculated weight so I really don’t think it’s over extrusion.

Can I go smaller than 0.12mm with a 0.4 nozzle? That’s what I’m at now. I know I can select 0.08mm but have read that is not such a good idea with a 0.4mm nozzle.

Again, the top surface layer is flat, then I get perfectly smooth (not even those lines) prints.

I’ll run a manual calibration and see what the lines look like for each k value.

In that case, I take it back: presumably it’s not overextruding after all then, even if it looks like it is the other times.

If it were me, I’d try for a thinner layer height. However, rather than run the experiment on your entire spaceship, simply cut off some pieces of your model in the slicer and print just those. Then you’ll get faster answers an can iterate more quickly.

For counteracting the observed effect, I haven’t myself yet experimented with narrower line widths, but you may want to look into that as well.

Good idea. I already have a smaller piece I’m iterating over now. Note that from any kind of distance, it doesn’t look bad. These pictures are literally a few inches away. Each of those lines is 0.12 mm.

Will post examples of before and after I spend a while messing with calibration.
Also going try try variable layer heights which will essentially be 0.08 for all of the these slopes. Found a few other prints I did that way and they actually look much better, but after looking at tons of pictures, I think the calibration could be off. Also, if the slicer knows about the calibration values, then having the actual weight equal the slicer calculated weight means nothing.

After looking at tons of other pictures of over extrusion, it does appear to be that way.

Yes, please do. I’m interested.

No real cause yet but I have been able to mask it by printing at 0.08mm and adding more top layers.

0.12 to the left and 0.08 to the right:

1 Like

Much nicer! Dramatically so I’d say…

You can take it quite a bit even further if you want by changing over to a 0.2mm nozzle. If you do, then I’m guessing that the resulting prints will not longer have perceptible print artifacts, unless you were to put your printed model under a microscope.


There are some threads regarding this problem. Found this one helpful:

At first I thought those lines on the surface are a feature…
But with the pic at full size I realised it is the top layer itself.

I had similar issues at some stage where the top surfaces were simply not acceptable.
Especially if I required a lot of top layers for stability this problem was really bad.
I calibrated the flow rate in two ways:

  1. Using the case mode.
  2. Using just the solid infill as the judgement base.
    The difference was massive!
    With the SOLID infill and top layers coming out perfect the rest suffered from under extrusion.
    While with a perfect vase mode calibration the infills come out with increasing blobs, especially towards the end of the lines.
    Quite a pain if the infill direction then builds them up in a corner.

It was only after these tests that I remembered how I started with 3D printing and a triangle frame prusa…
Bambu makes it VERY easy to get printing, maybe too easy…
During fire training we learn about the fire triangle - heat, fuel, oxygen.
All must match in order to cause a fire.
Same story for print results.
Temperature and speed MUST be within acceptable regions.
E.g.: If most parts of a pint are fine because they run fast but delicate areas where the printer slows down get wrecked it is advisable to LOWER the overall printing speed so a lower extrusion temperature can be used.
And on top of this most basic requirement comes the issue of pressure in the hotend, how much time the nozzle has to transfer the heat to the surface AND this funny K-factor …

Like it or not but this k-factor can break your neck with delicate prints and surfaces.
In some slicers you find settings for ‘pressure advance’ or ‘cornering’ - same thing really.
Bambu’s interpretation of the system goes like this:
During an extrusion the filament is pushed through at a fixed speed.
But when the movement slows down, especially if this happens quickly the k-factor defines or affects the pressure build up in the melting chamber.
So it REDUCES the filament transport when reaching the end of the line to then speed it up initially when the reverse direction starts.
The two tests Studio provides are a bit misleading with the supplied help section.
For the card like one, which is far easier to get off the plate, you have to take a VERY close look at the corner of the lines.
Don’t pick the line that looks best, pick the number for the BEST LOOKING and LEAST rounded corner :wink:
I prefer to print a quick cube with solid infill and only a few layers to confirm.
I then go up or down in the k-factor value in tiny increments until those blobs at the end of the line disappear.
This usually provides a perfectly smooth surface without any need for gimmicks like ironing and a blob free surface.
Good luck!

From the other thread.
Could you take screenshots of the slicer preview from the last few layers before the top layer that “pimples?” Also I can’t tell but is the “top” surface sliced at 10-20 degrees?

[edit - apologies, I did not fully read your first message. it makes perfect sense that this only happens on slopes. I am more certain than before that you will need to use OrcaSlicer, but please post the layers if possible anyway. Pick a pimple and take screenshots of the layers below the pimple]

There are actually a few different bugs/causes that created the scenario I posted about in the other thread, but given that increasing top layers does not improve the situation, I think the one related to incorrect internal bridging generation.

Sometimes, especially for “angled” top surfaces (especially shallow, around 10-20 degrees), the bridges required to transition from the hollow infill to a top surface is inadvertently “filtered out” by the slicer. OrcaSlicer 2.0.0-beta has the fix implemented, and you will need to use the new “don’t filter out small internal bridges (beta)” feature. If you are lucky the pimples will go away with no increase in top layers or infill.

Also as a side note, I spent a ton of time chasing down this “bug,” and it turns out it also happens on other 3D printers and PrusaSlicer. It’s just that I’ve been expecting so much higher quality since getting the Bambu that all these uncommon failures are actually very obvious.

Do you mean like this?

The before/after photo I posted a few days ago that shows the massive improvement was using more layers.

Also, if I change to rectilinear instead of gyroid or triangles, it doesn’t require as many additional layers to fix it. The gyroid and triangle infills both leave very large gaps to bridge and if you watch the actual printing when this is happening, the several of the first solid layers have partial collapses that doesn’t happen with the tighter rectilinear infill. All infills being compared at 15%.

Here’s layer 80 from the previous example with infill changed to rectilinear and even without extra layers it prints almost perfect.

Thanks! I was hoping to get two sequential layers (hard to do by mouse, think you can use arrow keys in the preview), but what you should look for is a blue “bridge” layer whenever the print is transitioning from the red infill lines to the purple internal solid infill. The printer is supposed to go much more slowly when “bridging” large gaps, but the slicer fails identify some areas where that needs to happen for shallow slopes.

I know they weren’t really sequential layers, but I drew a circle for the type of problem areas I would often see on the older version of the slicer. Purple internal solid infill (usually 250mm/s for PLA) is printed on top of thin air with no blue bridges, or at extreme overhang angles, which usually require slowing down to 10-50mm/s. Sounds like you’ve also seen the print live so you have probably seen how that goes poorly.

Any chance this is a public model I can try for myself? I’ve been keeping a library of parts I’ve designed that have this problem to try to get some devs to help fix this problem.

Apologies again, I saw my other post got quoted and got really interested in what was going on, I should have read the whole thread earlier.

Totally agree! I was noticing the same thing.

Good to know! You’re definitely right that the shorter bridge distance helps with this problem. The slicer is basically printing bridges or overhangs internally at the completely wrong speed due to bugs / “features.”

So some background for why I’m so interested in this - quite a few projects I’m working on need weight to be minimized (and less filament is always nice). This problem shows up pretty often when you reduce infill density. To give you an idea, I have been trying to print most of my parts at 8% or less support cubic infill. The problem is that these defects start showing up, and increasing top layers ends up increasing a lot of weight, negating any benefits. As of the latest OrcaSlicer update, I was able to get quite a few of my parts printing at 8% support cubic with nearly no defects and as low as 1.0-1.2mm top layer with the right filament (some PLA formulations bridge much better than others)

1 Like

CNCKitchen did some experiments using a kind of “gradient” infill. Seems like that might be just the ticket for what you’re looking for. Maybe “Lightning” infill might also work? Not quite the same, but it does appear to put tighter coverage near the upper layers while keeping the overall amount of infill pretty lean.

In contrast to that, though, Sorka95032 never indicated a need to keep weight down. In his case, why not just use a higher infill percentage? No need to get elaborate. Right?

1 Like

Weight is a little important. The model as it is will take 10 1kg rolls.