Running Diamondback Nozzle in P1S

now i wait for the bambu lab DiamondBack hotend for release. i hope it will be not too long to wait for

Well I got stuff over a year ago and it’s still not released so it could be a while lol. And that stuff was full retail ready to go

Maybe you can ask them when? or say they should do it :stuck_out_tongue:

I bought a cheap-ish hotend that I am modifying for the V6 .4 DB nozzle I bought.
I should be able to finish it up tonight, hopefully.

It’s not hard. There’s a jig someone made that improved on my mod and I tested that and it works great and something anyone can do with no tools. Mine required a drill and an end mill lol. But then again I have access to a full machine shop. You are going to like the setup. When you assemble put some thermal grease on the heartbreak when you put it into the heatsink.

As for when the hotend will be released. No idea. I got this a long time ago ready for retail and it’s still not out. And I got 3 other versions that are different but still not out lol. And yes thats not brass.

Maybe you can help me understand what is going wrong.

I put the ceramic heater on the hotend and put the thermistor in the hole (they were new with the hotend), both with ample amounts of thermal goo. Pulled the retaining clip over the whole hot end.
Put the fan on it, put in the tool head of the P1P, attached the cables and set the temp to 220.
It climbs to 116 and starts dropping temp.
Set it to 220 again, same thing… 116 and drops.
Reboot the printer with the same results.
I replaced the ceramic heater and thermistor (thinking they were just no good) with the stock Bambu one that came with the printer (the same one I stole the fan from), using lots more goo.
With the stock heater on the aftermarket hotend it climbs to 126 and drops.

What am I doing wrong here?
The hotend fan is running, the temp is registering. It just won’t climb very high.

I did notice that once it gets above the 100 degree mark the heating starts slowing down.

Are you using aftermarket thermistor and heater or the original ones? Did you try reseeding all the connectors?

For faster reply you can message me.

I have tried both.
The first one was the aftermarket that came with the aftermarket hotend. It would heat up to 116.
Then I tried the stock thermistor and heater that shipped with the printer. (the .4mm stainless). It was working up until I replaced with the hardened nozzle. I never had an issue with the original.
When I put that thermistor and heater on the aftermarket v6 hotend it will heat up to 126 and then immediately drop back down to the cool temp.
I put thermal paste between the heat sink and heat brake, between the DB nozzle and the hot end, between the ceramic heater and the hotend and in the little hole that the thermistor goes into.
I tried reseating the connectors several times.
I have a BL .4 hardened nozzle and .6 BL hardened nozzle that I have swapped many times. Sometimes when the connector is not fully pushed in, the temp will read “0”, but I’ve never seen it only heat up half way and drop.

What firmware version are you running?

Any damage to the thermistor cables?

FW: 1.5.2
No damage evident to either thermistor wires or insulation.

Does the same thermistor and heater work on the stock hot then? Can you swap it back?

Just trying to zero in on it. Also depends inside the connectors those look good?

The stock H/T worked up until I replaced it with the BL OEM hardened hotend assembly. It’s just been sitting in a box since.
I am beginning to suspect maybe the thermal grease the aftermarket hotend shipped with my be junk. IDK

It’s available. About $100 shipped to US. Not really terrible. I paid a little more for the BTT revo.

I saw that yesterday.
Now hopefully someone will put out an official v6 nozzle.
Until then, we’ll have to experiment with moding the cheap knock-offs.

I bought some Thermal Grizzly Kryonaut grease, since it is actually rated for temperatures above 300 c. And I also bought a different aftermarket hotend that isn’t a V2 but actually has the heatbreak drilled correctly.
I think I’ll also order some replacement heater/thermistors from BL and try again.

Interesting, the link is down already. Says the page doesn’t exist

peep the link under assembly guide here High Flow ObXidian™ HotEnd for Bambu Lab Assembly Guide – E3D ( , if it also says 404 not found then it is 100% deleted by e3d for some reason. You can get them from elsewhere also, I got mine from 3dprima website (E3D High Flow ObXidian™ HotEnd for Bambu Lab X1/P1 Series | 3D Prima - Top 3D-Drucker, 3D-Scanner, Filament, Resin & Zubehör günstig kaufen) but they only have 0.6 in stock currently

not anymore… I was planning on buying one but now it is not possible anymore?