So sick of this $3,000 X1C it's ridiculous

Brand new out of the box the first thing it does is send t he build plate into the head and sit there grinding on it until I switched it off.

Refused to connect to the network until I disabled the entire system’s 5ghz network so this stupid thing that in 2023 is still on 2.4 and can’t cohabitate with a 5ghz network. IDIOTIC.

AMS bay #2 is totally dead, the rest of it is flakey at best, sometimes works, other times no go.

Found out after it arrived that it can NOT do TPU in the AMS which was the whole reason I bought it in the first place.

Now it can’t send a file. Says the IP address and access code don’t match. THEY DO MATCH!!! It was sending files for a while, but today it refuses. I’ve done all the logging in and out, rebooting, restarting, it refuses to work.

I’m really getting sick of this thing. I wish support was something better than a response every 3 days.

Kicking myself for not buying the PrusaXL.


I’m sure there are some PrusaXL owners that would trade with you.


Don’t share SSIDs between 2.4 and 5. I know some wifi routers allow that, but don’t. Even in 2023.

I don’t remember the initial setup steps, but part of the printing startup steps is to clean the nozzle by grinding on the back edge of the plate, where that extra floppy extension is at the center. I think that’s also may be it’s default zero. Was that what you were seeing?

In your router, make sure your DHCP server is assigning a static IP to the mac address that belongs to the X1C. Then do the LAN access code binding again.


As an owner of both let me tell you:
a) Your X1C is messed up, talk to support.
b) The Prusa XL (I have a 5 TH unit) is NOT a panacea - I have my problems with it, including messed up parts out of the box and other ongoing issues.


There are indeed many older 2.4G WiFi adapters out there that don’t handle the presence of 5.8G with the same SSID. The X1C isn’t one of them. It’s on my home WiFi, a 2.4/5.8 mesh setup using the same SSID for both, connected to a separate router/firewall. Works fine, and has since the day I took it from the box.

But. I do have other devices that are 2.4G only that will not successfully connect to the mesh. For those devices, I run a separate SSID using the WiFi in my router that only has the 2.4G radio enabled.


you have 15 days to return it…that’s it 15 days if you don’t want it, this your opportunity.

Just making sure…which region did you chose for the device and you didn’t buy it from anywhere but BambuLabs right?


It’s been at least 3 days too long.


Weird, 'cause I’ve got 40 other devices that play nice, some of which are very old. Bambu is the only one with a problem.

When it prints it’s a thing of beauty, but when it doesn’t it’s a pain in the backside.

Support has still not responded, though, it’s only been 30hrs since I messaged them, they still have 2 more days before I expect a response.

support would be your best bet, too bad they aren’t a little quicker.

1 Like

While some of the issue you have outlined are indeed problems and you need to open a support ticket, some of your complaints are from not properly researching/understanding how the machine works.

The head and the build plate is normal and the self cleaning process. Even before I bought mine it was clear in many places that the AMS does not support TPU. You can only use the manual feed for that. Did you read/research anything before purchasing?

It is unfortunate about the AMS and the dead bay. They should be able to replace what is broken for ya. My printer works just fine on an access point with the same 2.4 and 5 network ssids. I know its not ideal, but unfortunately on that AP i have to do it that way. All unsecure devices are on that and not on my main network.

I have seen in the past when codes dont match, factory resets can help with that. printer / app reset. Seen it happen after firmware updates at times when they are not properly synced.

Please keep in mind, all 3d printers have their ups and downs. Its a hobby and it will not be perfect. Bambu is not perfect by any means but i have see issue with Prusa, Creality etc… Its just what you are willing to work with/tolerate.

1 Like

Lol. Where did you get ripped off to spend $3,000 on an X1C? Also, enjoy the Prusa XL… I hear all sorts of problems.

On my second X1C and best printer I have owned.

Stop putting 5ghz on same SSID, cannot blame printer for user error.

1 Like

Same SSID on 2.4GHz and 5GHz is perfectly valid configuration. Not always desired (it’s easier to have some form of control with dumb APs by separating SSIDs/bands) but sometimes very useful (for example if you are out of range for 5GHz while 2.4 GHz still works; without having to use two separate wifi networks).

So stop blaming user for broken devices that don’t handle that as standard intended.

But X1C isn’t one of these devices - works fine in such configuration here.

Edit: and “it’s not” below probably means “many devices are broken, so avoid that” or something similar because there is nothing in standards forbidding or conflicting with such usage of few bands with the same SSID.

1 Like

It’s not and as a systems engineer stop telling people that

My X1C has worked just fine using one SSID for both 2.4 and 5 GHz wi-fi. Started out with an old Linksys WRT1900ACS, recently added a TP-Link Deco mesh for wi-fi. No issues with either system, did not change a thing on the X1C when I made the switch. NO issues, cloud or LAN-only.

IF you paid $3000 for an X1C, even with AMS, you got ripped off - SEND it back! That’s double the price in USD, and even in Australia it’s less than $2275 AUD, with shipping.

Maybe you will be happier with the Prusa XL. It’s only $4336.37, “fully assembled”, and then takes only five hours to set up. I’ve not yet seen an XL review that did not report problems.

1 Like

Bambu support says you are wrong and for 0 issues, needs to be on a dedicated 2.4 non switching channel. Unlike 99% of devices made in the last 5 years.

Got the combo, BL filament and spare parts directly from Bambu

Support is replacing the AMS at MY expense, which they’ll credit when I return the defective one.

I got it on the network, but honestly, I don’t know what I did to fix it. Nothing really. ???
Network is UniFI which is some of the best Pro level stuff you can get.

Printer is printing now and the new AMS should ship in a few days. Sorry for the rant.


The NW connection issue could be UniFi AP firmware version dependent if you are running one of the EA firmware versions. I just had to rollback recently the latest 6.6.51 EA release due to some 2.4 connection issues with some of my IOT devices.


Well, if everyone says that it is the best printer, everyone praises the thing to the 7th heaven (because it makes a lot of things easier as before) and then the weaknesses become apparent - Bambulab X1C is good but far from perfect. Then you know what you are buying and everyone will be happy.

When you are in love you often no longer see the happenings around. And never contradict people in love. There is definitely a life without 3D printing, so there is always an alternative to a purchasing decision…

I’ll answer in 8 months whether it’s still worth it now. 6 months ago for 1259.66 Euro incl. AMS, yes but not one single cent more. Now - I wouldn’t be so sure about that anymore.

EU store but exported from the EU to Switzerland, so without VAT:

For the following unpleasant things you have to look at the individual sales of the AMS only (since MonsterMaxx notes the TPU matter as well). This is not addressed on the combo sales page… Is it really necessary to hide it so well? What will by hide when it comes to the next printer? Whats the reason to hide it well and truly in believing that it will never catch you up?

Well, I can’t explain it then. I swear to god my X1C is working perfectly. I haven’t had a single network problem with it after months of ownership. Connected on the first try during setup and has just worked ever since. And it’s connected to my mesh which uses the same SSID for 2.4 and 5.8.

But I have a couple of other ESP32 devices that do not successfully connect to my mesh.


Same for me @RocketSled. I have a Cox cable Panoramic wifi router. Worked perfect since the first day and every update. :man_shrugging: