Support for PLA not detected in AMS by X1C with new firmware 1.07

Yesterday my X1 Carbon with AMS notified me of the availability of a new firmware ( and so I installed it. Subsequently, having selected an object to print via the printer display that requires Bambu Lab’s “Support for PLA” filament, the printer did not detect that this filament was already present in the AMS and therefore asked me to insert it. Even though I had manually selected the slot on the display where the “Support for PLA” filament was present, the printer did not accept the selection and therefore I was unable to print that object.

Next, I tried to start printing that object using Bambu Studio and in this case I succeeded, as Bambu Studio correctly detected the presence of the “PLA Support” filament in the AMS. However, when during printing the time came to change filament to load the “PLA Support”, the printer showed an error message (see attached screenshot) which, despite multiple attempts, I was unable to resolve.

I would like to point out that there was no problem of clogging or obstruction of the filament in the AMS when this error message was shown, but I believe that in this circumstance the printer once again had that anomalous behavior of not recognizing the PLA filament support in the AMS.

Is Bambu Lab aware of this issue? Are there other users with the same problem?

1 Like

Have you tried removing power to the printer itself? I had a similar behavior where spools weren’t detected properly after 1.07. I physically power cycled the printer (mine is connected to a smart plug) and it picked them back up fine after that.

Yes, I turned the printer off and on several times but nothing changed.
Furthermore, I am also having the same problem with my second X1 Carbon with AMS after updating the firmware to

I also want to highlight that I tried to create a support ticket but it was not possible to do so because now the X1C printer log file is exported to the microSD in the “.tar.gz” format instead of “.tar” and the ticket request form by Bambu Lab does not accept this format…

However, I have no doubt that this is a bug introduced by the new X1C firmware version, in fact after downgrading to the previous version of the firmware ( via the Bambu Handy app everything returned to normal.

I therefore await a decisive intervention from Bambu Lab which I hope is investigating the problem in the meantime.

I’m having the same issue, please keep us posted if Bambu or you find a solution.

In the meantime, if you have PETG lying around you can use it as the interface layer (it doesn’t work as well, but still works).

Bambu Lab has fixed the reported issue with the just released new firmware v
Thank you Bambu Lab for your support.