The printer is busy with another print job

Since a few days I get the message “The printer is busy with another print job.” although the x1c is idle. The previous print job is finished but in Bambu Studio (and Handy) the previous job stands at a differing percentage number. I am allowed to cancel the (finished!) print but nothing happens.

I normally don’t want to restart the Slicer because I have already prepared the next print. So I always have to restart the printer.

Does anyone else have the same problems?

Has happened to me one day a few weeks ago. Never managed to find what the cause was. I restarted the printer a few times and it stopped doing it.

1 Like

Go over to the printer and swap screens or in the slicer go to the “Device” tab and click the video option. It will clear it then.

I don’t know what’s causing it, I don’t really care, I want it to stop as I’ve had to take 5-20 min to clear.

I know I chose a cloud based printer so I am willing to deal with cloud issues. I think this has nothing to do with the printer itself, I think it’s like a forgive me for not being a techie… But it’s like you have to wait for the cache to clear.


I tried all that and it helps normally when I have AMS sync problems. But not in this case.
But since yesterday the problem seems to be gone. So it was probably a cloud problem.

This seems to happen about once in every 10 jobs for me.
I have tried the suggestions above, but it will not clear until I restart the Bambu Studio.
It has just happened again on version (Mac platform).
The only thing that allows me to get printing again is to restart Bambu Studio.

When this happens, the printer shows a different message at the end of the print onscreen. Rather than stating that the ‘print completed’, it has a ‘printing stopped!’ message (although the print did succeed correctly).

1 Like

Same issue here. A combination of the solution mentioned above (device tab) and restarting Bambu Studio solved it. But for me this also happened when a job finished with “Printing Stopped”. This looks like a bug to me.

1 Like

I am getting this problem too. Had to power up the printer and to restart Bambu Studio to get rid of it :frowning:

Bump. Still a problem. Studio thinks printer is printing. Printer obviously not printing. Need a force refresh button.

Resetting the printer sometimes works but seems silly to have to do that all the time.

Same here, problem for me using a Mac

Same issue for me… seems like if I just wait a few minutes it does clear itself and the ‘Send’ button lights up.

I’m using a Mac (2022 MacBook Pro, 16" w/32GB Ram). It does it to me but only if the last print was from the printer’s cache. If the last print was sent from Studio, it doesn’t happen. It also does it after I run a calibration from the printer, not the Studio. The only way to “clear it” is to turn the printer off, wait a few seconds, and turn it back on.

I have the same issue. I have to power off the printer and back on again between every print.

Only work around that i have found useful for this is to disconnect the printer from the internet for a couple minutes then it clears the issue

I have the same issue on my Mac and it’s super annoying, please fix that!
Mostly it happens when the print finishes while the Mac is in standby mode. When starting the Mac again, the print progress is still where the Mac went into standby, it’s not getting properly updated.
What helps for me is to log out on the Mac and then log in on the app on my iPhone.

Same exact really annoying issue for me, just amazing that it’s still not fixed after months.

Have had the problem for months even through several updates. I do put my computer to sleep until the print is done, so maybe the studio is just waiting for an update which never comes and doesn’t have a reset mechanism.

This has just started for me since I updated everything for my X1C yesterday. After loading filament and preparing a print job in Studio I get “The printer is busy with another print job.” Turned everything off and on again but it still came up then eventually went away while I got a coffee. Wish I knew what caused it.

Same issue here. Restarting Bambu Studio works for me. Hope they fix this…

I am having the same problem except no number of power downs (including overnight) on both the computer and the printer resolve the issue. My printer is now a very expensive door stop. Total POS.