Unable to connect to wifi

I have searched google for this, but am not having any luck in connecting to the wifi. I’m unable to submit a support ticket because I don’t have an SD card reader on my PC (I didn’t know I would need one) and you have to have a log file of some kind.

I have gone through as much of the manual setup as I can, but when I try to connect to the wifi it always says “Wifi not found” without any indication of why. It sees the network, and if I enter an incorrect password it tells me “Invalid password”. That tells me that it’s seeing it just fine but when I enter the correct password it’s just “Wifi not found.”

I do not have 5ghz available at all. It’s disabled in the AP, and even the disabled part has a different SSID, so that isn’t the problem. The blue tooth pairing works just fine.

I was able to setup a hot spot on my phone and update the firmware, but that made no difference. I’ve tried resetting to factory, but again no change.

The printer is 15 feet from the AP, and I’ve tried moving it closer without any change.

Anyone have any suggestions on where to go next? Right now it’s pretty much a $600 paper weight :slight_smile:

Make sure your wifi name and password don’t have any special characters and are a reasonable length.

No special characters? Would that mean punctuation as well?

Possibly. The safest is to stick with numbers/letters. Once connected you can play with what works and what doesn’t.

Wow, networking like it’s 1999. Yeah, it doesn’t support punctuation, so now I have to change every device in the house :smiley:

Some routers offer the option of having a “guest” network that you could setup for just the printer.

I just spent a whole day trying to fix my printer with WiFi issue. Went through all sorts of posts and troubleshooting. Finally one small tweak on the router made things work. Gonna make a dedicated post about it but TL;DR

  1. Make sure you have a 2.4GHz WiFi available for the printer (I have both 2.4 and 5 and it works fine)
  2. Make sure your 2.4GHz WiFi’s authentication method is WPA/WPA2-Personal.

My mistake was somehow my 2.4GHz WiFi is set to only WPA2-Personal and that broke the printer’s connection to the WiFi.

FYI, I have seen other people mention about special characters in names / passwords too. But my WiFi has underscores in the name and spaces in the passwords. The printer worked fine with all that as long as the auth method is set correctly.

1 Like

Same issue here. I am just about to start pulling my hair out. Everything worked just fine for a couple of weeks. Sitting at home with my laptop on my lap I finish a design and upload it to the printer in my remote workshop.

Then all of a sudden last night I could not connect to the printer. I went to my workshop today and … (copy-paste the first post). Laptops (2), phones, hotspots, wifi nothing works.

One difference. Because I didn’t want to let my printer sit idle I put the printjob on the SD card. When I click on the job the printer only shows a defiant blinking start triangle (with a Stop square nex to it) and that is it. Nothing …

I’ll try Nickolas’ suggestion this afternoon to see if that provides any solace.

Update regarding working with the printer on a 2.4GHz WiFi. Some new learnings I have made recently.

After I have made the changes I mentioned above for my printer, it still quite often get stuck on 0.0.0.0 for its IP address when starting the machine.

I have since made one more change to my WiFi router’s settings and things have been smooth since then. My P1S can quickly get an IP address and a stable connection to my 2.4GHz WiFi.

Make sure your 2.4GHz WiFi’s mode says “legacy” (or “b/g modes”), I assume that means it only runs b/g mode (better for compatibility) and not n mode.

One more thing: tldr you DO need to turn off the 5GHz WiFi of your router if your router can do both 2.4GHz and 5GHz…

Longer version is that through all the troubleshooting i forgot i had it turned off and if i do turn it back on, my P1S gets stuck with 0.0.0.0 as its IP address. If i turn it off again leaving only 2.4GHz WiFi, it gets its assigned IP a few minutes within its startup time…

I am planning to buy a cheap wireless router and just have that runs a 2.4GHz network for the P1S.

So yesterday I went to my workshop and first thing I tried to connect to the internet again. And … wait for it … the printer connected first try. And I just did the same thing I did before.

I could print again Hurray!!! So no solutions other than just keep doing the same thing over and over expecting a different outcome and sometimes it works.

Anyway let’s print … or not.

Follow this saga in my new thread “How not to fix a blob”.

1 Like

A device which recognizes only 2.4G does not see 5G. So there is no need to switch of 5G. If it behaves as you described than there is something wrong with your router. Maybe it can support only 2.4G or 5G alternatively.
I am using a mesh wlan network with both 2.4G and 5G an even the same SSID. No problem at all. As expected.
To buy a new router is a good idea, but I would recomend you to buy one wich supports wlan 6 and also 5G.

1 Like

My P1S is now intermittently connecting (obtaining an IP address) since I updated to the latest firmware. It’s super frustrating. All my 2.4Ghz wifi settings are correct and I’ve tried it on various channels. The fault is in the P1S.

I would suggest entering your wifi credentials on the SD Card to force connection

And assign a fixed IP address in the router for your printer mac address

1 Like

This workes for me, all my other stuff workes with WPA2, but bambulab needs WPA.
Well finaly found the problem.
Thanks Nicholas.

Workes stable with both 2,4 and 5 GHz on.

Just his week, my A1 Mini worked Monday night but was not able to reconnect Tuesday morning. I could connect it to my mobile phone hot spot; also could connect to a newly setup guest network on my wifi.

When that worked, I deleted the original bind to the main wifi network and re-bind’ed to the guest network. Within a couple minutes, the Mini automatically updated its firmware. I was then able to reconnect to the original network, delete the guest bind and re-bind’ed to the original network. No other changes needed.

1 Like