Updated: Local Printing - Now failing with FTP Access Denied Errors

Ive been printing via the Local Network fine for about 5 months. Today for some odd reason I am no longer able to upload my files to the printer via BambuStudio. I get the following response in BambuStudio;

Error code : -4020 (Failed to upload file to FTP)

FTP code: 9 (Access denied to remote resource: server denied change to given directory)

As I have not changed either the firmware or BambStudio in the past month I’m not sure what is going on other then this might be related to the last MacOS security update. I can control the printer and ams via BambuStudio, I just cannot upload my prints. Checked the SD card and it appears fine with lots of space so I’m at a loss as to why it quit printing.

Update: After a bit of testing I determined the BambuStudio “Send” function works ok, its just the “Print Plate” function that fails.

1 Like

Did you try power cycling your printer so that it will reattached to the network? This can be done through the menu too but power cycling is quicker if your not familiar with the Network menus.

Yep. Also restarted bambustudio with no change in symptoms.

I am also having this issue today, where as yesterday the print plate button worked with no issues. This is my first time working with a multi plate file, but still.

Ran in to this issue today. For now I’ve turned off LAN Only mode and was able to print. After my current print, I’ll turn on LAN Only mode and report again.

I am able to work in LAN Only mode again after temporarily switching off LAN Only mode
This time, I was asked to provide an Access Code. Bambu Studio showed me a screen shot of how to get the access code from the printer.
I am now able to print in LAN Only mode again after providing access code.

Same issue over here, but the LAN Only Mode off and on, didn’t work… I always used it in LAN only mode, and just suddenly between plates, it doesn’t work anymore… Anybody got a solution?

Not sure what the ultimate solution was as mine started working after a day with no indication as to why it failed. As an interim you can try using the send function which is located under the “print plate” pulldown (which worked for me) and then launch the print job from the printer. Granted is only marginally better then sneaker net but its better then nothing.


Thanks tried that indeed, but then when using an AMS and wanting to print from a external spool is kinda an issue, that doesnt work for whatever reason, now I’m trying to do one short print with sneakernet, and then close it all down again… but the thing keeps in my head … WHY, out of the blue…

1 Like

Having this issue today on my P1S out of nowhere. Just printed from LAN only mode last night like I have since I owned the printer a few months now. Can connect to FTP from WinSCP.

Tried from Orcaslicer and from Bambu Studio same error… Turned off LAN Only mode then back on, changed Access Code… same issue. Still FTP over TLS from WinSCP works, SD card is not full… not sure what’s going on.

Edit: Same thing… Send to printer works not Print, which is what I always use. With the P1S not sure how I can make AMS use the right slot directly from the printer.

Update. So, the original 3MF came from a Makerworld (P1S Bezel). I exported the object as a STL, then created a new project and imported the STL and was able to send to printer. So it must be a problem with the 3MF files. Export the models from it, and create a new project and see if that works for you.


I had the same problem as you - starting a new project in Bambu studio and loading in the models there worked fine, but using a downloaded 3MF didn’t work.
This was with LAN-only mode on.

if you have this if again i have found a fast way to correct the issue

go into device completely log out and re input the access code this will correct the issue you are having this worked for me.

Im getting this error too. Ive tried logging out and in again but still doesnt work. I can send the file to the printer but I am at a loss why its doing this all of a sudden.

I have the same right now on my A1 mini.
If I download from MakerWorld and open it in Bambu Studio, then I get stucked as above. ( MakerWorld: cute snoopy keychain )
So far there was no problem downloading projects.

If I create a new project or load my older projects then it working fine.

“Logout-login” and “LAN mode Off-On” did not helped.

I have the same error. Brand new P1S. Put it in LAN only mode. Can’t print anything with the same ftp error.

I’ve run into this three times so far. All three times have been with a .3mf download from MakerWorld.
Only two ways I’ve found to deal with it.

  1. Use “Send” instead of “Print Plate”, then choose the job on the printer’s screen.
  2. Export the object from the project as an STL, then start a new project and import the STL.

It’s pretty obvious that something is embedded in these .3mf files that’s causing the issue.


Although i agree with the workaround i disagree that this is related to just downloaded 3MF files. In my case it was with designs i had created in Fusion and was seen in both 3MF and STL files. During trouble shooting i went back to 12 month old STL files and i still had the issue.

I wish i could say what solved the problem but it mysteriously disappeared as spontaneously as it appeared.

1 Like

I can also confirm that the issue can be caused by something within the 3MF file. exporting it as STL, creating a new workspace and importing the STL fixed the issue for me

I also encounter this, as say before its happend after import .3mf file to fix it there is a need to close the project then when imprt stl file it will work without the comunication FTP fail
I guss this is becose some .3mf file define project with location and Bambulab block trensmiting them to the printer creating error 4020