WLAN connection breaks down

Hello, I’ve had the problem for a few days now that I have Bambo Studio under Devices and it interrupts the connection to the printer every few seconds. Always on and then off again.
What I tested:
1.I deleted the connection to the router from the printer and logged in again.
2. Firewall turned off.
3.Run network test from printer.
4. Checked settings in the Fritz box. But everything looks normal.
Now I don’t know what else I could test. The printer is 3 meters away from the router. That shouldn’t be a problem, especially since the neighbor’s router is also shown to me. Otherwise there have been no changes. Maybe you know what else I can do?

I too have been experiencing similar connectivity issues in what was a rather stable connection. The culprit lies inside the BambuSource.DLL library which Bambu will not publish despite the fact that it is based on open source code and the licenses they use require this. BL claims that since they are using the ESP32 dev environment, they are exempt. That my be true to some extent of the firmware but not the host software side.

My troubles appeared when I upgraded the firmware two weeks ago from 1.02 which was “relatively” stable outside of the all too frequent crashes, which only happened when I had two or more BL Studio or Orca session open. Ever since then, I’ve had frequent connection issues where the target device just randomly disconnects making unattended operation a challenge. I now have to confirm the the print started before going on to my next task.

The second problem occurred when I upgraded to the latest BambuSource.dll library at the invitation of a popup in BL Studio. Normally I wouldn’t upgrade but it "promised’ that the new library would fix the “occasional” crash… yeah right!!! Now a new problem manifests itself in that the printer would start the homing process and fail to execute the print. Again, I’d have to baby sit the print until I confirmed it started.

I’m afraid only BL will be able to solve this one although some of your countrymen may be able to answer the question regarding the Fritz box if you post this in the German section.

Yes, exactly, that was also reported to me and I installed it.

The problem is still there. When I access the printer via my phone it works. Just not on the PC.
Is there a way to undo the BambuSource.dll library update since I didn’t have any problems before?

Technically yes. But it may require some trial and error.

I have not tested this yet. That’s because I am not quite ready to give up before I contact Tech support on this issue but truth be told, I have other priorities I am working on so I may not get to this for a while if I do at all.

But when I do, here are the steps I will take and you can try this yourself but please report back as to your success.

1 Simply reinstall an earlier version of Studio.

This is quick and dirty and it should overwrite the newer .DLL with the older one from the previous version. “Should” being the operative word if Bambu has set up the installation software correctly. Scroll to the bottom of the Github page and download your OS install version.

2 If that doesn’t work. Complete uninstall.

Search your system for BambuSource.dll first. It should be in the same folder as where the program is installed but to be safe, find any copies and delete those too. Make sure you note where all the copies are after because after uninstall, you’re going to want to verify that the file has been eradicated from your system.

If the BambuSource.dll is still present anywhere on your system, delete the file manually. Then reinstall using the 1.7 release to ensure you’re using the correct file.

I tried the easiest solution today which was to simply reinstall version 1.7 to no avail. I still have the same issues but I did dig a little deeper. The issue appears to be surrounding SSL and FTP. The problem is that I have no issues with FTP directly. So I am throwing Bambu under the bus on this and point the finger at whatever network changes they’ve made since launching makerworld.

I am going to try plan B and eradicated everything Bambu related on my system and see if that helps. Alternatively, I can move it to another machine but those are my lab systems and I hate to much with them.

That’s exactly what I tried too. Bambu Studio deleted and reinstalled, but without success. The same behavior again.

Later this week, I will try to downrev the firmware to a previous level.

I had the same connection issue as described by @Schoko in accessing the BambuLab X1C from my PC. Accessing the printer from my smartphone, no connection issues occurred. Solution for me was to completely shutdown my network/W-LAN (two FritzBoxes) for some minutes. After the re-start, I had no further connection issues accessing the BambuLab from my PC. Very strange, but it worked for me.

I just restarted the router, but that doesn’t help either.

Having issues here too. Reset router, updated my DD-WRT firmware… The part I don’t understand, is the MAC Address of the printer shows on the router. I can see that it is “online” in my DHCP Client list…

But both BambuStudio and Bambu Handy show my printer as offline.

Really bugs me, I paid a lot of money for this printer because it is supposed to be top notch and not have stupid issues like this. It’s supposed to be plug and play, but I haven’t even had it 45 days and now I’m dealing with this ■■■■.

I would’ve bought another Creality if I wanted problems, but whats the point of sheling out this type of money if I can’t even use it?

Turns out all I had to do was complain online to find the culprit…

In my BambuLab app, I had changed my settings from
Langauge - System
Theme - System
Home Page - Devices

To - English-English
Theme - Dark
Home Page - Devices.

Not sure why this caused the issue, but changing them back to

Langauge - System
Theme - System
Home Page - Devices

Seems to have fixed all my problems. 3 hours of fighting with my network later…

I rolled back my firmware to 1.04 and this helped but the stability issues remain. I did find the location where Bambu stores the previous versions of BambuSource.DLL

I’ll be running experiments over the weekend to see if some combination of earlier DLLs will provide greater stability.


Bambu has cut off rollback prior to 1.04 which was my last stable firmware. What makes me angry is that 1.03 coincides not only with the last known stable LAN-only firmware release but it is also the last release to NOT support Makerworld. Anyone see a pattern here? This feels like Bambu is walking back their support of LAN-only in forcing those of us who have rejected their cloud. I can say that with some level of confidence because none of the stability issues appear to affect the product when routed through the cloud. So why is that?

The sad part here is that the new firmware had two features I really liked, the first being SD card support for the P1 and the second being quieter servo algorithms. I’d give up both though just for a sound experiences.

As of now, I am relegated to babysit every print startup. For all intents and purposes, I no longer have LAN-only and unattended printing capability. I have to send the G-code to the printer manually(FTP still works), then I have to walk over to the printer and then select the file and print it from the LCD display menu.

What’s really bad about that is that when one prints from the SD card folder from the LCD panel on the P1, you are forced to endure the bed leveling routine which adds 6 minutes to the print.

Does anyone know the G-Code to insert to bypass bed-leveling? It was posted here once but I can’t find it now. Bed Leveling gets too many hits.

I tested a few more things:
The firewall turned off.
After Bambu Wiki deleted the plugin folder and reinstalled the plugin.
Permissions controlled.
Nothing helped. I think if no one knows anything anymore then I’ll have to open a ticket.
What I also wanted to say is that I use Windows 11 and only have the problem with the connection to the X1C, it works with the A1 mini.

It looks to me like you did an exhaustive set of troubleshooting at this point and opening a ticket is your last option.

By connecting to an A1 you have ruled out the slicer as the culprit. I think is the the smoking gun here that points to firmware being the issue.

The only thing I didn’t see in your troubleshooting is have you tried using and FTP client such as Filzezilla to connect directly to the machine?

Either way, good luck and let us know what the outcome of your ticket is.

After the last update in Bambu Studio a few days ago, I no longer noticed any connection problems.

I am still having this issue.

I just went thru a couple of weeks going around and around with support on this. A while back, after working perfectly for many months, wifi just stopped working. Sent logs. Response - it’s your router, it’s disconnecting. Uh, why after being fine? And, it’s getting DHCP, it’s sending packets, router logs say it’s connected. Everything else on the network is fine. I tried 3(!) different brands of routers, used a wifi analyzer, a packet sniffer. Bambu - “Oh, it’s congestion on the wifi channel”. Ok, switched to a separate router with a separate SSID using totally different bands. Nope. Bambu - “Oh, it’s because you have ax enabled”. Nope. Finally got them to send a new AP board. Problem gone. However, I’m very suspicious that the true cause was a firmware update that happened just when it stopped working. New AP board didn’t have that. Takeaway - Bambu support is clueless when it comes to their wifi implementation.

Same thing for me, I’ve already tried them all, among other things, 2 P1S work normally, one has these problems. They sent me a Wifi antenna to replace but nothing has changed. I still have the ticket open but I think this time they will send me an AP card too

Say it isn’t so!!! They are the best, just ask them. :yum:

What’s so messed up here is that all of these issues that one reads about with respect to their network installation could easily be remedied if they simply made the printer look like a desktop printer. Think about it, how many printers don’t have either a USB or Wired Ethernet option or both? Not any I can think of.