X1-C w/ 2 x AMS Abnormal Firmware

Printer told me it had an update. it ran through the updated process and got to the end and then showed a failed message. I followed the instructions to restart the printer and retry and I get the same error almost immediately after starting the update.

I just update the New firmware and i got same problem… Even factory reset won’t solve the problem.
Have you solve the problem??

i just solve the problem,

  1. let the printer factory reset,
  2. make the connection on Wifi and connect with your mobile
  3. use your mobile to update the printer it’s works,
    (if you try to update on Printer Touch screen it will always show update fail)

I am having the same issue. Let me tell you why your solution doesn’t work… neverminded updating from mobile worked.


yup same here! updated through app and I am printing again

I had the issue too and was pretty panicked this morning. Have lots to print on a deadline for work, and then this happened. This post helped me fix it quickly, though. I did not have to factory reset. I instead just needed to turn the printer’s power off and back on, then use the mobile app to start the firmware update.

I’m affected by this issue with the latest update as well. My X1C is stuck at ‘Abnormal Firmware’. I’ve tried unplugging AMS and restart the update. Unfortunately, the Handy mobile app doesn’t work in my setting (corporate Wi-Fi). Any other ideas?

Me as well. Awaiting a fix.

How to you update from cellphone?

Using the Bambu Handy App. Settings/Firmware Version/Update. The app needs to be paired with the printer before hand.


i have the same issue but using studio or app dosn’t work anyone found another fix or are we still waiting

Anyone fix this issue? I just got a Bambu X1 Carbon and out of the box I got this Abnormal firmware message and cannot print. Firmware update gets stuck at 97%. I’ve tried everything and it still keeps failing.

Progress bars are notoriously inaccurate and non-linear. I would allow at least 20-25 minutes to pass before assuming an update was stuck.

Using the touch screen, I would try resetting the printer. Settings(hex icon)>General tab>Restore Factory Settings. Then follow the prompts to re-calibrate the printer.

If you can’t clear the problem with a reset or firmware upgrade, you will need to submit a ticket to support. Do that soon, they shut down for Chinese New Year (Feb. 10 to Feb. 24) and support is already very slow.

1 Like

I tried waiting. I have left it running on update failure screen for 2 days. Tried factory resetting already. Tried updating from mobile, desktop, and device. Nothing gets rid of the upgrade firmware failure.

I ve got same issue with X1C tried it with mobile phone and local Internet per PC and per Handy App always stuck at 97%…
Is there a Firmeware out what i can update from SD-Card??

Hello, I have the same problem with my new X1C - after unboxing and trying to update the firmware, it failed at 97%… Now I have new message - ‘Accelerometer Data Is Unavailable’. I read the whole wiki, tried disconnecting and reconnecting cables - without change. Opened a ticket 3days ago, without reply. Does anybody have any idea how to properly diagnose the problem?

…also hotend temperature is 0°C

Welcome to the forum.

Try a factory reset and make sure that your wifi connection is really stable so the firmware downloads and completes the checksum.


Same problem here with my X1C on Tod the box today.
Seems there are more person of this batch with the same issue.
Firmware upgrade issue at 97% and Nozzle Temperature at 0 Celsius. Plus the acceleration date are missing. I proceed to all the tutorials by unplugging and re plugging the cables in.
20 restarts and update tries with app and without app plus Factory reset. Nothing helps.
I made a ticket but there is no help for now.

thank you, but I tested both another wifi as well as a factory reset. I have tried seemingly everything I could find online - all without change. I suppose that it is some hardware problem because the nozzle temperature shows as 0°C and I can not even heat it or control the toolhead at all… I tried to read the log file, but it is encrypted… I have no problem with closed design, but with this customer support it is a big problem…