Xtouch installed!;)

Finally got around to printing and installing a xtouch screen on my p1s! And wow do i love it!!
Big thanks to teaching tech for the main design! Johnstylez for the stylus case and spacer remix!! Worked out great!

Printed in tri-color RGB silk pla


I really want to like xtouch, but it still seems very buggy to me. The main appeal to using it for me is the easy loading and unloading of the filament. But whenever I use the xtouch, I get errors such as there is filament stuck in the extruder, or even though I have removed the filament it still says to remove it, and I end up having to restart the printer to get the error message to go away.

When I use the LED display that came with the unit, I don’t get any of these errors. I really love the xtouch. But I am hoping these issues get resolved.

I have the P1S.


Still struggling with it. I can’t even get beyond the part where you have to go to the website to install Xtouch on the screen. So, first thing to do tomorrow is finding some guidelines on the internet.

It looks nice btw


Make sure you don’t use the USB that comes with the screen if you got it off aliexpress. I think it only powers the unit and does not have the data lines. Sometimes really cheap companies will send these super cheap cables that don’t have the data lines to save a few cents. I think this was the case for the one I got off aliexpress. If it won’t show up as a COM, try a different cable you have laying around.

This is the guide i followed allong with the github xtouch page here was a great help as sometimes the vids are fast paced as they fully understand it already and were still grabbing at it lol me included! Here the github any questions just ask

1 Like

I havent experienced anything unusual as if yet it is a bit new still but a few weeks of use and nothing yet so fingers crossed, maybe try the new updated version of the xtouch software :wink:

The one included with the screen didn’t even fit. I already ordered another one, just to be sure. That one fitted perfectly, but I found out it was just a charging one. Others that I had lying around with micro USB didn’t work either. So, now my hope is on a new cable that should arrive today or tomorrow.

btw. I had the screen from a Dutch shop, so I don’t need to pay taxes on goods from outside the EU :slight_smile:

Yes, followed that one. It’s perfect, even for me. Learning more from this than any video :slight_smile:

1 Like

This probably isn’t the issue, but I figured I would throw this out there, as it was something I came across.

Make sure to plug in the USB cable to the PC and the screen before opening the installation website in your browser. I noticed that the COM port list does not update after navigating to the website. Even if you hit the “re-connect” buttons. I had to actually close out the website and re-open it for any new COM ports to show up.

1 Like

The issue I ran into seemed to be sporadic. I stopped using xtouch to load / unload the filament and I haven’t seen the errors on the P1S since. Why does it happen, I don’t know. I speculate it has to do with xtouch trying to manually send the g-code to perform these tasks, instead of the firmware handing the loading / unloading, but even this doesn’t make sense to me because you can also use the Bambu App to do it. I am for sure no expert on this topic. But I do know I get weird errors and sometimes erratic behavior when using xtouch.

I have the touchscreen set to update over the wifi automatically. So whatever the newest firmware is, it should be on there, unless that is not working. I would have to double check.

Also, I have had xtouch lose the connection to the printer twice now. Not just a disconnect, but it loses the printer out if its memory and requests that I re-connect. It keeps asking me to “Pair Printer” but this second time, it doesn’t seem to work when I click the printer and press the “OK” button. It just keeps “refreshing” the list but never re-connects.

So I am not sure what is going on. But it has some bugs to work out. Don’t get me wrong, I love the idea of this touch screen and I am sure these things will get worked out. I am not knocking it. But it does have bugs still.

Edit: I literally tried to re-connect to the printer after typing this, and now all of a sudden it connected. So I don’t know. Could be an issue with my network in regards to the re-connecting. But I still stand by the errors I get from loading / unloading the filament.


Ordered some USB micro cables, but what the send my where USB mini, and those don’t fit. So, now waiting for the right ones to come.

Agreed. Lots of fixes needed to make this decently usable. I am about done with it until it is fixed. I dislike the following:

  • Super slow boot up. If I power on the printer, I just have to use the regular screen while the xtouch is still getting started. Reg screen up in 5 seconds, xtouch takes 35 - 40 seconds.
  • Almost always needs to be reconnected to the printer after power up. There is only one printer listed, just connect to it please! But it should just remember anyway.
  • On filament load it will say something about hitting Retry if filament was not extruded, but the options are Done and Confirm.
  • After filament load it leaves the nozzle on high.
  • Sometimes on filament load I have hit Done, then filament is purged, and it pops up again with Done and Confirm. Endless loop and printer has to be power cycled.
  • After you hit filament load, then confirm with yes, it says nothing. You have to know at this point that it is warming the nozzle and after the head moves forward and back you can feed in the filament. Same with unload.
  • After startup it sometimes says “check wifi credentials”, then “rebooting”. Might do this 3 or 4 times.

I haven’t even tried using it to move the head, bed, or to extrude. I am actually afraid it might run away and crash.

Oh wow I haven’t experienced any of those problems. It has actually been working flawless on my P1S maybe theres new firmware…??!!!

1 Like

first and second problems. None. Boots in less than 10 seconds, that includes connecting to printer. Every single time. No issues. Might be your network is doing something to the devices. I completely skipped filament loading from xtouch because of those issues. Moving the bed, head and other stuff work just fine. Just make sure you are using latest version.

Sweet i use it all the time to load and unload works good on my end??:wink:

1 Like

I a 100% agree with user_4064251085. I have had exactly the same issues he has had. I use a mesh network that has a dedicated back haul and that’s capable of Wi-Fi 6. I’m pretty sure it’s not my network.

The load up time is not a big deal for me. My printer is pretty much running 24/7. So there’s not much turning it on and off. Though I will agree it does take probably like 30 seconds or so to load. And I’ve had it twice now lose the device. So it usually seems like after a restart of the machine all of a sudden the ex-touch can connect to it. So I have no idea what’s going on there.

Exactly everything else he has said has been an issue for me also.

maybe your wifi is just too modern for old school 2.4 wifi. esp32 has pretty basic wifi integrated

1 Like

I am not sure if this is sarcasm or not in an attempt to elicit a response. No. This would not be the case. If anything it would improve performance on older hardware.

I have many devices working with the 2.4 Ghz band. The mesh uses a dedicated 2.4 Ghz antenna specifically for running up to 50 devices on a single mesh hub in the 2.4 Ghz band. I have had several “high-end” routers, none of which have shined a light to the stability of the Velop mesh. It has been a godsend.

Also, user_4064251085 is having the exact same problem. So unless he also uses a Velop mesh network, then I doubt it is related. There are multiple people reporting these issues. Just look at the issues tab on the Github repo for the project.

So no, this is not the case.

So, finally was able to find the problems. Tried with different cables and all, but in the end it was simply the iMac blocking the drivers.

Now problem… how to add the cable to internal USB port. Being left-handed it’s a crime, but one of this days I’ll get the cable plugged in

ok then it might be that it does not like mesh. I have a basic home router in my garage and every single time I power up xtouch it connects to the printer under 10 seconds. and every single time it connects.