AMS didn't switch to another spool

I had two spools of Kingroon PLA, both used the same Generic PLA profile, same color and were synced in AMS settings.

But when spool in A2 slot was empty, I got an error message that spool is empty without auto-switch to A3.

Moreover, it appears that in that case I couldn’t order to load fliament from A3 slot via bambulab and had to go to printer and add another spool of black filament to A2 slot to continue printing, which made AMS ‘backup’ feature… well useless I guess.

AMS firmware version, P1S

Any advice how to make AMS to switch to another spool without my presense near printer would be appreciated.

Can you check something please.

When you click this icon (red circled)

Is “AMS filament backup” checked like in this picture?

Yes, it’s checked there.

I think, root cause of the issue could be that rest of the A2 filament was detected as Ext Spool, in that case AMS won’t switch to A3 slot, right?

Hi all,

I’ve been experiencing the same issue of not switching to the next spool of the same material, even when the backup setting is checked.

I’m almost positive this problem started happening since the last firmware update; maybe something in the software broke?


I have the same had the same problem, and I am happy that I am not the only one :slight_smile:


Still no solution.

1 Like

I had an issue the other day with my Ams where in it wouldnt load a pla because it had petg listed on a different spool , if it helps i had to remove the petg ( A1 )

Same issue yesterday. I posted on Facebook and people tell me to check the same thing. It was working fine before the firmware update, which leads me to believe the latest update broke it.

For me the problem was present before the last firmware.

I feel a little bit better after seeing these posts.

I thought I was going crazy. The AMS isn’t detecting filament runout anymore. I used to work great. Since the last firmware update it hasn’t worked. I get errors about “failed to feed the filament outside the AMS” or errors about being unable to retract the filament (which isn’t possible because it’s run out).

1 Like

I had the same problem yesterday. It kept trying to switch to ext filament and would not detect second slot. Both rolls Bambu lam petg basic black.

Has anyone with the issue opened a support ticket so the trace logs can be reviewed?