AMS Failed to pull back filament error

I know this has been asked before, but I wanted to see if the community had any other sage advice…

I unpacked the P1P yesterday after a move to a new location, got everything setup. Calibrated the machine, loaded PLA to make sure it was all working, everything looks good.

Hooked up the AMS and immediately upon attempting to load filament, I get the 'Failed to pull back the filment from the tool head to AMS". It walks through the steps and then pulls the filament back out, but the indicator on the app shows that the print head is clear.

I know the filament sensor in the print head is working, I was able to test that. Normal loading seem fine, all the tubes are clear and there is nothing in the AMS that I can see.

I’m not sure where to go from here, you would think because the print head shows that it has no filament loaded it would not need to do the pullback and just move straight to load. So right now I have an expensive paperweight that will not load filament, I opened a ticket but apparently they are incedibly backed up and I expect the response will be to look at the Wiki’s…

Could this be a software issue, I don’t think we can roll back to previous versions?

Frustrated with the whole thing…

-Paul-


Install Something like this in the toolhead.

I’ve had mine get in a weird loop like that a few times. I just did a power cycle and everything was fine after.

I’ve also had a piece of filament break in between the sensor in the head and the extruder which causes similar behavior. In that case just remove the PTFE tube from the print head and manually insert some filament and use the printers controls to run some filament through the extruder. Kind of similar to how you do a cold pull.

So I took apart the AMS and made sure all the lines where clear, there was some in 2 and 3 but one seemed clear. Put it all back together and reset everything, I checked the head and if I insert filament the sensor shows green and white when I pull it out.

I also fed some directly into the print head and cleared it that way…

Nothing seems to make any difference, but like I stated, I can load filament manually and everything works.

I’ll keep tinkering and hope that Bambu will get back to me, I saw someone state that an override option would be good and I agree. To me this feels like a software issue…

Thanks
-Paul-

1 Like

I had exactly the same problem on brand new P1S. I contacted Bambu Lab support and they helped me to investigate, they even sent me spare part at the end.
My problem was with filament buffer. I dissembled and cleaned it, also made sure tubes are not touching the wall behind. Check that you can easily pulll one of the 2 tubes attached to the filament buffer and when you release, the spring should pull it back


I did solve this issue finally, Bambu was not much help. Turns out that a piece of filament broke off in the AMS unit. To fix that I had to disassemble the unit, turn it over and pull the 4 PTFE Tubes, then I pressed on the spring clamp and used a fresh piece of filament to force out the broken piece. Once I cleared that, everything worked perfecty.

Just in case anyone else encounters this…

4 Likes

I am glad that the issue is solved, and thanks for sharing.
That’s a typical event in the AMS (at least for me). Sometimes, the filament breaks inside, and you must disassemble and remove it.
What I didn’t understand was where your filament was broken. In the hub or the feeder?

@okokok, thanks for the picture and for sharing the experience.

2 Likes

For me, it occurred that when I made space in the AMS for a different filament and then put the old one back in (Amazon basic) after taking it out, it always had those ridges from the pull-in motor.
After cutting off the part with the ridges it worked again for me

It was in the feeder, which is why I didn’t see it. Now I know where to look :slight_smile:

Was it complicated to take apart?

Mine filament broke under the AMS had to disassemble the whole AMS top layer to get under the ptfe tube to release. and pull the filament out. first time looking under the ams, those ptfe tube on slot 4 and 1 takes quite a tight turn to get to the extrusion point of the AMS.

4 Likes

This is what I found just happened to me.

I could see the printer thought filament was loaded. I had found a piece of filament that had broken (brittle towards the end) and removed it and it still thought there was more. I did cold pulls, etc trying to clear it. Finally figured it had to be in the bottom of the AMS. It was…

Any way to tell which sensors are triggered?