AMS filament will not load

Brand new X1CC, still in setup phase. I have not yet printed anything. I went through initial X1C calibration. From viewing Youtube videos, I expected to be prompted to do AMS calibration, but I was not.

I loaded the three filament spools supplied with the X1C into the AMS. However, I cannot insert filament more than a quarter inch down the white hole on any of the four filament receivers. It is my understanding that I should be able to insert filament a couple of inches or so, and that the AMS gears would grab it and feed it through.

My understanding is that inserting filament should trigger its automatic loading and recognition of Bambu filament. It does not. Understandable, because the filament is not really inserted. The touch screen shows all four feeders to be “Empty.” Touching the feeder icons on the touch screen one by one causes the yellow gears to spin a bit, but returns a status of “Empty.”

I am a complete beginner when it comes to 3D printing. The first print I make with my X1CC will be the first print I have ever done. I’m prepared for this to be a Duh! user error, but for the life of me, I cannot figure out what’s wrong. Any guidance will be greatly appreciated.

1 Like

Try warching this youtube video.

1 Like

Thanks for responding, Barry. Unfortunately, no go.

The problem seems to be that the throats of the feeders are simply not open, and I cannot push filament more than a few millimeters down. Pressing the white tab below the throat opening has no effect. Pushing hard only bends the filament. I’ve tried inserting the hex key just to verify that the throat is open, but again, it hits whatever is blocking the throat right away.

Fwiw, my touch screen does not show active Load or Unload buttons, only greyed inactive buttons. Makes sense if the filament is not truly inserted. Also, I am unable to calibrate the AMS, because no Calibrate button is shown. Presumably, this is for the same reason. Can’t load filament, can’t calibrate AMS, I’m at a loss.

If the white LED does not come as soon as you push in the filament. I suggest that you make sure all black cable connectors are securely push in with a click from the connector. This is the power and data cable for the AMS system.

I have no other suggestions. Sorry.

You may have to try support. :roll_eyes::pensive:


So is the printer not seeing the AMS at all? Are the AMS lights blinking?

1 Like

Thanks again, Barry. I disconnected and re-connected all 4 black cable connections, both 4-pin and 6-pin, until they clicked into place. Still no go.

All 4 feed throats blink white about once a second, whether a filament is (minimally) inserted or not. Pushing filament or pushing the white tab changes nothing.

For a minute there, I thought I must have connected the cables backwards, because some of the little black plastic latches were on the inside, leaving only a small space between the latch and the body of the X1C. So, releasing the cables required my using a small flat-bladed screwdriver to release. I really don’t understand why Bambu oriented the connectors this way. It makes using one’s fingers to release the latches impossible.

I’ll try searching for blinking white AMS lights. But it’s starting to look like contacting support is the best option. Thanks again for weighing in. Cheers.

The 4 AMS lights are supposed to blink when no feeders are populated, so your AMS lights are working as intended. As a sanity check, could you please confirm this is what you’re doing when loading the filament:

  1. Insert a little bit of the filament into the feeder as far as it goes
  2. On the screen, select the slot you want to populate - the gears should start spinning
  3. While the gears are spinning, on the AMS feeder, push the white button towards the roll and push the filament in the hole until it makes contact with the spinning gears
1 Like

You do realise that you have to push the white tab toward the back of the AMS quite hard and at the same time push the filament down the hole that opens? It’s not clear from your posts that you are doing that. It’s basically a strong spring that you have to push back so that you can insert the filament.


Bingo, Organicactus and rigdoctor!

In browsing youtube for answers, I had the impression that the white button was meant as a button, to be pushed DOWN. No wonder it had no effect when pushing down. By hooking a thumb nail on the lower lip of the button, I WAS able to slide it backward, toward the spool, and load the filament. All Bambu filaments are now recognized for color and type.

Told you it would be a Duh! user error. :slight_smile: Thank you, one and all. As they say, even old dogs…


Hello Fellow Forum Members!

I recently acquired a Bambu Lab P1S printer with an AMS system. After only two days of use, during which I completed three prints (in 2 colors of ABS, 1 color of PLA, and then 2 colors of ABS again), I encountered a problem. After the last print, when I tried to switch from ABS to PLA, I couldn’t load the filament. The loading process appears, but nothing else happens. An error message is displayed: HMS_WARN_07ff_2000_0002. The filament isn’t even being transported by the AMS system to the nozzle. Interestingly, when I disconnect the AMS system and use a single spool, everything works fine. Has anyone faced a similar issue? Is contacting Bambu support the only solution?


I have this issue too - P1S. Everything worked perfect without AMS. Tried installing AMS, blinking white, see AMS icon on control panel showing firmware recognized the AMS, and the load is not triggering. I filament into AMS inlet, it pops up a couple mm as though I’m pushing some trigger button but AMS does nothing.

1 Like

Have you found a solution to this? Ive also been having this issue and it seems i am at a loss. No amount of searching online has been able to yeld a solution.

I’ve had a smilar issue: “bambu failed to load filament outside of ams”. Weirdly, when it self tests, it’s more than capable of pushing the filament down to the hot end. It just refuses to do it when i am trying to print. Very frustrating as i have only had one print with it and now it is seemingly broken!

Edit. I replaced the PTFE that is internal and it seems to now feed. Some of the tubes were pretty worn, guessing they were not feeding into the hub correctly and thus throwing an error.

You’re definately not alone. I’m struggling to get filament to load from the AMS as it keeps saying it needs to be pushed from outside spool, which I’m not using. This started Thursday or Friday. Can’t load through Studio, or using screen, esp slot 1. Sometimes it will let me feed from 2 using studio, sometimes it won’t.

1 Like

I wouldn’t mind but mine is brand new! I’ve logged a ticket and will swap out the tunes to see what happens

Mine were clearly worn on slot one. I replaced them all since I was in there. Also replaced the PTFE from buffer to my y-splitter since it seemed worn as well. I’ve had mine for maybe 4 months but have run a lot of filament through. I discovered the wear while looking for a broken piece of filament (was none).

I can’t say that’s always the problem but it seems to have fixed my issue. Good luck, hope it’s resolved soon.

This might be helpful so someone else but I also had the same issue of the filament not auto loading in the second slot. You need to make sure filament from the first slot (or a different slot) isn’t loaded to the nozzle before inserting a second roll.

Came here to say thank you for asking this question as I went through the exact experience you detailed here only to find I didn’t understand how the little button was meant to be used. Your detailed description got me to my first print! Thanks!

Just received my Bambu P1S + AMS, the Bambu filaments loads perfectly fine. ESUN PLA 1.75MM will load then is retracked and will not load for printing. ESUN is on their list of approved filaments. Why does it print with it?

I meant why doesn’t it print.