AMS keep loading and unloading

Hi, I am having trouble making my AMS feed the filament pass the tubes into the printer. The filament would reach the quick connect right outside of the printer and retract. Has anyone seen this issue? This is a new printer too

2 Likes

Have you tried reseating the Ptfe tubing on both sides of the coupler? If the tubing is not fully seated and square it can cause a small lip that the filament can catch on. You can also manually probe around yourself by disconnecting the ptfe tube leaving the filament buffer/hub headed to the printer so that the tube is still connected at the coupler on the back of the printer, then manually push filament up the tube to see if you feel any resistance or snag at that junction.

Yep, i have ran through the filament through the tube myself and there is no resistance. In fact I have swapped to a shorter tube. The AMS would extend the same length as before and then retract

1 Like

Possibly and likely a blockage

My AMS did the same thing when I had a piece of glow in the dark pla stuck ahead of the hot end

I uncoupled the ptfe tube where it joins before going to the hotend, heated the hotend up to 240°, manually feed some normal pla in until it contacted the extruder gears then manually through the touchscreen feed the normal pla through

After the normal pla was extruding through the hotend I hit the unload button, pulled out the pla from the ptfe tube, reconnected the tube into to coupler and bingo the AMS has been working ever since

I would try that before digging any deeper

1 Like

If it was grinding, the filament probably has notches in it preventing it from passing through all the connectors. I had to replace the ams hub wheel.

1 Like

I was able to print without the AMS and did the load and unload with just one filament. My AMS still behaved the same afterwards

3 Likes

Hmmmm
That’s strange

Let me think about this one as I read in your original post that it feeds up to the connection then retracts

But if you were able to print without the AMS at that exact spot theres obviously something else going on :thinking:

1 Like

I know when testing a few of the designs for a wye adapter, I found it was very picky about how the ptfe tube was seated AND the approach angle of the filament path. BBL calls out to make sure the ptfe tube from the buffer to the back coupler takes a path between the spool holder and the buffer’s data connection to make sure the filament loads smoothly. I did a lot of testing with manually pushing through pieces of filament to make sure I had no snag points at connection junctions and it felt like it was pushing smooth before I settled on the wye adapter I went with.

1 Like

Just a quick question

Is this issue regardless of which AMS slot you try or only 1 of the 4 ?

2 Likes

I have tried all 4. I even took out the tube between the buffer and the printer to see how long it will go and it always extend to the same length

I have had this happen to me before…
It was the filliment that was binding on the roll… glue on the spool for some reason
filliment would get to the same place every time… then pull back…
if it happening on every slot this sounds like it could be the same thing…

uhm, but I was able to use the filament without the ams. Should I just unrolled it myself and give it a try?

I have the same issue - when the extruder returns to home, it will pinch the tube against the back of the printer. This causes the AMS to jam because it cannot pull the filament from the pinched tube.

I need to figure out a good way to keep the tube clear of the printhead.
Any suggestions?

Did anyone work out how to resolve this as i am experiencing the same issue - thanks

1 Like

I am getting similar issue but only with spool position 4. All others print fine. Spool 4 prints for maybe 4 mins, stops, backs out the filament, then reloads the filament then prints for another couple of minutes. On some occasions it will error out but clicking retry resumes loading filament and again prints for 3 or 4 minutes…then repeats. Before this the AMS has been working flawlessly.

I am not new to 3d printers but was impressed with it and I bought it complete with AMS and now bought a second AMS which I did not yet mount because it arrived with the Perspex hood sheared and I am waiting for a solution. In the meantime I have installed the manifold which accommodates 4 AMS units.

Mind you- I am still using the original AMS only but through the Hub unit. I printed a 5 Hour print and I had to stop remotely because it said that the spool was jammed. This spool was in position 4.

The next day mounted a roll of ABS in position 3 and started a 2 hour print. The print just covers the brim and first couple of layers and that`s it lots of spaghetti.

Then I tried a print using Position 2, the print does the first couple of layers and keeps printing in air. My suspect was the hot end which I exchanged as I had a spare. The same happens!

At some point the AMS started to retract the filament then load it then retract then load… then get a retry on the screen which leads to the same situation.

Prints I tried in various position 1-2-3-4 all behave the same.

long story short, disconnected the AMS and mounted the roll on the back bracket and hey presto- I am working ok with all the filaments. Just to mention, the bambu roll supplied with the filament would not load. it kept loading, unloading, loading…

I appreciate some suggestions as this is sending me off my rocker. Mind you I work as a machinist, Designed and constructde two large sophisticated printers so I know the basics…

Did you ever get an answer-my first AMS set up is correct and everything loads BUT it gets all the way to the extruder (and loads it almost) and then the buffer will bounce back and forth 3 times and then retract the the filament all the way back and then will push it all the way to the extruder and then the buffer will bounce a few times and it restracts it again this happens about 4 times and it will tell me there may be a jam …but if i turn it off while getting this error, then turn it back on…i can heat up the head again and do the manual extrude and some on the color comes out (the part that is still loaded) so clearly the gears are working and the extruder head…something with the AMS feeding is messed up

2 Likes

Got same fault like you lady. Opened a ticket and they sending me a new ams mainboard. Its on the way

had this happen to me turned out to be a very small bit of filament stuck in the hot end feed gear stopping the filament from going all the way in had to strip the hot end gear assembly down to get it out after that it worked fine.