AMS stops feeding just short of extruder

This is the second time I’ve encountered an issue where the AMS stage 1 motor will not feed filament all the way to the extruder on my X1C. It stops about 1-inch short of the extruder, retracts, tries again, and keeps stopping at the same point (until it gives up). Even if I disconnect the PTFE tube running to the extruder, the AMS stops feeding at the exact same point…almost as if it’s hitting an invisible wall (or calculated distance) and retreating.

Other key things to know:

  • This is only happening on AMS Slot #1 (of a Kickstarter AMS). Other slots in the same AMS can successfully feed filament to the extruder.
  • This is not filament specific. If I move the filament in Slot #1 to another slot, it loads fine.
  • This is unrelated to the first stage motor. I replaced the Slot #1 AMS first stage with a new spare and the same problem persisted.

Obviously, I’ve rebooted the machine several times while troubleshooting and that does not clear the problem. There are no other obvious signs of friction, blockage, or jamming…so I’m at a loss.

Workaround is to avoid Slot #1 on this AMS, but that’s not long-term ideal. Anyone deal with something similar?

Have you played with the angle of the PTFE tube near the extruder? You can find a printable PTFE guide - there is a long and a short version - made by Adam L that specifically addresses this issue

I’ll take a look for that design and see if it has any effect.

If it is the PTFE tube near the extruder, I’d expect the problem to present regardless of which AMS slot is feeding the filament (instead of only happening on Slot #1), but perhaps there is some weird combination of angles/friction/resistance when feedback from that slot.

(For benefit of future readers, this is the design mentioned: ShortStack: The Tiny Little Bambu AMS loading fix that might save your sanity! by Adam L | Printables.com)

Slot 1 might have a weaker motor or something is more worn out?

I can’t offer a good resolution or root cause answer to this problem.

Putting a different filament in the failing slot and printing with it later “just worked” . ¯_(ツ)_/¯

At this point, my assumptions are:

  1. The specific filament in Slot 1 (PolyMaker PLA Silk) caused some kind of extra friction/resistance that cause the filament load to fail.
  2. The process of manually loading AMS filament (outside of an active print) from this Slot has an obscure bug/issue. Maybe more sensitive to resistance?

Either way, Slot 1 in this AMS worked fine on the next print (albeit with a different PolyTerra PLA filament).

@jayburd I eliminated the possibility of it being a worn out motor by replacing the entire AMS Slot #1 first stage feeder unit with a new spare part. Didn’t resolve the original issue.

I had exact same issue where a new spool fixed it. Turns out it’s because the fillament had worn thin from previous failed reloads.

Although I have exact same issue now and a new spool isn’t fixing it.

Did you find any other solutions?

Have you changed your PTFE tubes? Check if you used the correct length. I actually used slightly longer ones in places, but going overboard might cause a problem as the printer (AFAIK) expects the filament to enter the filament sensor at some point*. Maybe just try swapping one of them for a shorter one (the one where you have most slack)

  • it’s sad that if you disconnect the PTFE tube from the extruder while the AMS is engaged, it will happily unspool whatever filament is loaded onto the bed and there’s no stopping it, but I guess that’s a separate issue :slight_smile:

Yes. SAME ISSUE!

The filament on one slot (#2) refused to enter the extruder. The filament on the other (#3) had no issues whatsoever.

The AMS has only been used on 4 print jobs, using both slots loaded with Bambu filament on Bambu spools.

Perhaps I’m one of the unlucky ones with a lemon feeder: Ams fails to push filament to the extruder - #9 by whitefire_asp

could be a jam in one of the 4 splitter tubes that go from bottom of the ams spools into the single tube out of the AMS unit. Sometimes you might have to run a long piece of filament through the tube to get any small pieces that might be broken or stuck in there