Bambu Lab X1 Carbon did not generate QR code

I had a problem to generate the Bambu lab x1 Carbon 3D printer QR code.
The problem comes when the printer asking for the network and the wifi network connected just fine after giving the password and the user.

after the wifi is connected but the printer still not generate the qr code. Later on i tried to skip it an proceed with the calibration.

When it comes to the bind the printer to the Bambu Studio and Bambu Handy, again it will ask for QR code but since the QR code is not generated i decided to used nearby device and it found the printer. but when i choose the printer device it failed mentioning the error IOT_ERROR_REGION_LIMITED.

I did change the region numerous times and the result are still the same.

Is there anyone experiences the same problem and solve the matter. Really need the help.

is anyone encounter this problem?

Is that X1C for China market?

not sure if the product is for the China market…but the error came out when i tried to bind the printer eventhough the qr code are still not generated.

do you have any thought about this?

Bambu printers sold domestically in China are region locked and at this time will not connect outside of China.

Here are several threads for further reading.


Why can the Bambu Lab solve this issue. eventhough the product came from the china and for the china used only, but it still doesnt change the fact that this is the Bambu Lab product by the way.

i still cant use the QR Code until now…sigh

Hello, I have the same problem. I undesrtood that the problem might be connected to the firmware version that you have on your printer. I updated my X1C to the latest version It worked fine for few days than yestarday the printer got offline. Thare is a topic related to it: Update to firmware version and LAN only mode
I partially solved the problem switching to LAN connection. Now I can control the printer using bambu studio even if I can’t use the bambu handy app. In this video you can find usefull informatoin:
I think we have to wait until the next frimware update wil be produced or contacting Bambulab in order to downgrade the printer to the previous firmware in my case.

I had te same problem. It happens because i had the printer onanother device. you have to log out from the other divice

I had the same problem. Brand new X1C and the QR code was a no show. I did a factory reset and that fixed the problem.