Cannot bind P1P

Hey all,

I’ve scoured the web, Discord and have gone through multiple methods to try and get this thing to bind. No luck.

I’ve tried a myriad of combinations with my 2.4GHz wifi network, hotspot, and trying with Handy on both my iPhone and Android. Also tried binding using the QR code and from the list. Tried binding with the printer when it shows up in the list with a bluetooth icon, and with the wifi icon. Tried with and without the SD card slotted. Tried after reinstalling the Handy app. Tried reformatting the printer. Still nothing.

Some of my errors say “No valid device”, “Connection failed, please try withing 4m”, “Maybe not on the same LAN, no route to host” (both are on the same network), and sometimes the binding process just spins forever.

I have access to modify my network, which I read that someone disabled everything on their 2.4ghz network except for the wifi to get it to bind.

Any insight would be appreciated.

1 Like

Just had the same problem and fixed it by using a wifi hotspot on the phone I was using the Handy App from.

  1. Set up wifi internet sharing on the phone with it connected to an OTA service provider
  2. Connect the P1P to the phone’s internet sharing
  3. Go back to binding on both devices
  4. Once logged in and bound successfully, you can go back to normal

Hey, I have the same issue as person above but this solution doesnt work - How I’m supposed to connect the printer to my normal 2.4Ghz wi-fi after binding it with phone internet sharing? I still cannot do anything and I cant connect to my printer now because it have no access to internet (When the phone sharing is turn off). Is there any way to connect the printer to normal wi-fi after its binded to account with this method? Sadly this is the only method that work for me to bind the printers, nothing else works.

Once you’ve done the binding, there is a network setting that you can change from the printer’s display to connect to your original wifi network. Once that is done, it should all be fine. I’ve only got X1-C set up at the moment using this method, but I’d be surprised if the P1P didn’t have the same capability.

I had same issue, but the advice worked using the phones hotspot yet every time I tried to switch the Wifi on the P1P it would log out of my account as well. Ultimately was able to use my 5ghz network to login in and bind the device instead of the hotspot solution (which does work).

1 Like

May not be the same issue but I had problems connecting to my X1 and I finally worked out it was my wifi range extender causing the issue. I could see an ip address on the printer but it wasn’t in my routers list of connected devices. Turned off the extender and all was good


I’m having this issue too but can’t get it to bind using my phone hotspot either. Anyone figure out another way?

In my case the foam pad/cover over the externder/BT/Wifi board was cause a low RF power condition on my printer. My phone could see the printer but could not pair with it. I loaded a Bluetooth find app on my phone to look for the RF signal. Running the app showed no RF power present. When I removed the foam the power was present. The location of the board is on the inside of the top cross bar. I posted a image of these parts in my thread. I believe the antenna connector is located center bottom left, labeled JWX-22xx, if removing the foam cover doesn’t work you could try the momentary switches located near the antenna (wouldn’t it be great if the designer wrote a description of the board? I 'm sure a wired connection to the memory would be done through this board too)

I`ve the same problem after changing the “IO-Board” because of a missing camera clip.

the printer booted as a new printer with a other ID but I can`t connect/binding the printer.
The network infos and the password are submitted to the printer, but I cant bind it, not with Bambo handy neither bambu studio. most the time “no valid device” and at the bambu studio errror 400 no valid device.
The work-a-round with the handy hotspot, same es normal wlan “no valide device”

I beginning to think the new IO board I got from the support is some kind of defect.
With the old board, I had no problems beside the not connectable camera …

sorry for a maybe stange english, its not my mother language :slight_smile:

1 Like

Try using the Bluetooth find app on you phone (you will need to download it). If you have detected power it should work. Even if your phone see the printer if the power is low it will not pair. I was getting power values of 50 which is very strong. If you are getting good power, try the momentary switches one at a time to see if the Bluetooth will pair.

same problem here, due to a broken clip i had to change out the AP main board… not able to bind it anymore. tried all of the suggestions bu tnot working. doing a factory reset now… let’s see what happens.

I find the printer via bluetooth, the signal is strong, the wlan things are going well but allways error no valid device.
getting grey hairs of this

with the old board I had no problems, with the new one only trouble

Could you post pictures of the old board? Both sides. I think we may need to pitch in and figure this guy out.

I’m sure you could check for WiFi power too, but it is sounding more like a board firmware problem.

From what I hear the camera is not a bargain. Together with a slower memory card the board can’t handle the I/O. Do you think your memory card is part of the problem? Is the camera connected now?

here the picture of the old board

error message from bambu studio

the wifi settings are getting stored and an ip adress is being issued.

Sorry to bother you but is the second board side just traces?

2nd side

1 Like

i removed the adress at the menu and deletet all entries at the wlan router, after this the board gets a new adress from router

to give a better illustration of what happens:
we are not allowed to upload video… one moment