How to change the order of AMS units

Greetings AMS users.
My apologies if this question has already been covered in this discussion. I have just bought and installed a second AMS which is working well. My problem is that the old AMS is shown in Bambu Studio as AMS 2 and the new AMS is AMS 1. Is there any way this ordering can be changed? I have swapped the position of the 6-pin plug to no avail.

I can easily change the various filaments to my preferred order, however the original AMS (now AMS 2) is in a location the is much easier to load, etc.

Any advice will be appreciated.

Best regards,

Peter

I did this once but couldn’t just find the article in the Bambu Labs Wiki (I think that’s where it was). Anyway I think you forget all the AMS units on the front screen and attach them in the order you want.

The order of the filaments / AMSs doesn’t make a difference. You don’t have to sync the AMS with Bambu studio. The color selection happens when you start the print either from the machine or BS, the printer or BS will try to match the materials and colors that you have used on the model with what’s available in the AMS pool.
As I have calibrated profiles for all my filaments I never re-sync the AMS because then I have to re-select all of them again. Instead I have a template project which I load (this would be a nice feature to have when starting a new project, to use a template) that has all my filaments added. Then I add the models and chose the colors. Never had an issue of using the wrong color.

Could you just physically swap the positions of the two AMS’s around

2 Likes

But did you try changing which AMS is connected to the printer? IIRC, the cabling goes like:

	Printer/hub <---> AMS <---> AMS

…and it might simply be that the AMS nearest to the printer gets #1. I’m pretty sure that’s the case with mine. OTOH it could just as well be the one with lowest serial number that always gets #1 (that’s also possible in my case), or something like that.

Hi all,
Many thanks for your helpful suggestions. I had to wait for a lengthy print to complete (and for daylight - I love my sleep) before I could try them out. In the UKdavewood’s suggestion won out - simply swap the AMS units.

Because of how my system is set up, this was the hardest to achieve, so I tried all the others first to no avail.

You may ask why all the fuss when the order of the AMS units doesn’t affect the printing. The reason is that I have the No1 AMS ( the default in BS and the first in the filament listings) in the easiest to access position. Therefore I can have my most commonly used filaments (white, red, green and black) where I can most easily access them.

Once again, Many thanks.
Cheers
Peter

2 Likes

There was a documented procedure from Bambu to do exactly this and I did it once, I just couldn’t find it today when you asked.

Thanks prior,
I could’t find it ether - buried somewhere in the Wiki

https://wiki.bambulab.com/en/x1/manual/Connect-AMS-Hub-and-multi-AMS

I was going to comment this, as it’s how I remembered it. Then I tried it as they say in your pic. Only it kept the order that it originally was. I think maybe you need to factory reset first then connect them, maybe?? I didn’t want to do that.

If it isnt an x1c you have to physically swap the units. The x1c can reset the data from the hmi and then you plug them back in 1 at a time.

Yes, I eventually found the Wiki page. Mine is a P1P so that facility is not available. I have now swapped the AMS units and I am a happy man.

1 Like

Well, not so anymore. The reset screen is missing as well as the AMS tab on top of the filament page. I need to reset mine because the printer assigned the newest AMS as Number 1 or A and it totally messed up my order of spools and colors. I already had three marked externally with A, B and C. When I added the fourth, it grabbed A and slid the rest down. The printer memorizes the assignment and now there no way to reset it. The image below is what the doc says, but as I said, they don’t exist.

Bambu needs to have write up on this on their wiki. The colors in Bambu Studio don’t need to match the slots in the AMSs. I know when you sync it puts them in order, but it really doesn’t matter. Think of your AMS as pool of filaments rather than slots like older printers did. You can have as many filaments in your project as you like, the slot matching happens when you start the print. The printer matches the colors in your project to what it finds in the you AMS pool wherever they are.

Well, I finally found the filament and AMS reset. The documentation must be for earlier models of the X1 or something. Mine does not display the “AMS” tab on the initial screen. To get to it now, you have to find the little Reel at the bottom-right of that screen and press on it. That brings up the second screen which allows you to set options for the AMS. The picture above does not show it, but there’s now an option to reset the AMS mapping. Then you then need to turn off the X1 and unplug all the AMS units. Turn the X1 back on then plug each AMS in the order you want them. Worked for me. :smiling_face_with_three_hearts:

1 Like

That won’t work for me. I set the colors and type in the Prepare stage of Bambu Studio. That way it’s saved with the project. I have Red in PLA and ABS. While they may be the same color, they are not the same filament. And I have one AMS unit that I typically swap-out different filaments in. The other three AMS unit are normally set with my fixed type and colors. For me, there’s a HUGE difference between a filament in A2 and a filament in D4. No, I work by the color AND the AMS slot. Sure, I can set a color and slot at the print stage (before sending to printer) but I don’t always remember to change or set a color. I also may have the same object printed in different colors.

That’s my Project level and I can see the color in my file display. Like this:
Screenshot_20240218_074407

Correction when I said color matching, I should have said “material matching”, as it does both. If I print TPU, it won’t allow me to start a print cos it not in the filament pool.