NOT a fan of the reusable spools

Have 2 reusable spools. BOTH separated during a print causing a jam and a huge mess on the spool holder.

Why is there no positive latching mechanism on these spools? I checked when putting them together without filament and they engaged all the way with no clicking or indication of something latching them in place. So I figured ok, I guess they don’t need it.

Now I have 4 refills I’m hesitant to use. Is there a printable spool that latches? If not, I’ll have to see if I can return the unused refills and replace them with pre spooled filament.

And oh joy, now I get to wind the messed up filaments on some used spools I have.


I can feel mine clicking into it’s locked position, maybe try doing it slower and listening out for the click, as I say I can feel it


I think you’re doing it wrong? You push the two halves together and twist them to lock together. You’re likely missing the twist part?


I use a printed center weight holder to ensure my spools don’t separate. Before I found this I was going to design up a part(s) that would lock the spool halves together with a bolt. I do find the added weight helps with unloading mostly empty spools. I used to also get errors unloading cf filament as there is added friction.


they do click when they are in the locked position.

own 8 of them with no issues. maybe a bad batch?

I have eight of them spools. I have been using them for almost a year. You have to make sure you get that last 1/4" turn. You can feel it lock in.

1 Like

Did you read the part about they DON’T lock? Yes I tried to get them to lock but no clicks, nothing. As stated, I turned them until they would no longer turn and you can see when the slots are turned all the way on these spools. I even tried forcing them to see if they’d lock and nope. Tried rotating in both directions, tried seeing if there was a different alignment in the slots that would work. These two spools don’t lock.

Not using an AMS. So won’t work for me

I printed desiccant holders that go into the center of each spool. It holds them together as a bonus.

It looks like the weights @JonRaymond uses but it holds desiccant instead.

There are many spool holder designs that dont use the center hole of the spool. And they work even better.

Mine click too. Maybe you have faulty ones.

I it happened only once to me, I felt it was user error I didn’t FULLY turn and lock them. When it feels like it’s locked give it an extra strong twist. I have always felt it lock in place .

I only get inLand or eSun with complete plastic rolls. If I see a filament that is only a refill or has cardboard, I don’t bother. Compared to the rest of you guys, I am a novice and can’t spend a lot of time at this. I love the X1-C because it just prints very well, and fast, without a lot of fooling around.

Refillables look like a pain in the arss.

Just apply more torque when engaging. I made that mistake once.

If you scroll down, you will see the listing for all of the parts you get when you buy an empty spool. Among the parts are two shims. Step 4 shows where one goes ( I don’t know why you get two, shag carpet isn’t that popular these days :wink: )
I also don’t know why you don’t get one (or two) when you buy filament with a spool.

Buried in the wiki is the link to print a shim.

All that said, I’ve not had one come apart yet but have not run all that much Bambu filament through my printer. I have run a lot of Overture through it using this printable spool with this spacer since the ID of the Overture is bigger than the OD of the spool which makes it slip near the end of the roll.

I just recently got an AMS and no e of the 4 that came with it click or lock into place. I got 3 translucent spools and one light grey opaque spool and they all seem to turn very easy to a sudden and what feels like full stop. I’ve been worried about the same thing especially with non-refill filament that I respool myself.

First, there are no shims with the spools.

Second, when I looked at the inside of the spool as they were rotated, they looked fully engaged. Turns out the last little bit of the slot had flash or excess plastic from the mold that was getting in the way and made it look like they were fully engaged. That would explain why forcing them was not working. Chipped away the excess plastic at the end of the groove and now they lock.

Found a printable spool that works well and locks.

Maybe the shim is only for non Bambu refills? The BL video and wiki page say nothing about using the shim with a BL refill, even though the sales page shows it.

For clarity, the shim is used for the printable spools. It will not work with the spools from Bambu.


The store bought spools come with two shims, these shims may be different from the the ones grouped with the printed spools. I do not know, I have never purchased Bambu’s empty spool nor printed their version.