P1P Z lead screw issues

I am having major issues, the rear lead screw binds randomly. I can take it up and down with the software control and no binding occurs. When I send a file to the machine to print and the printer starts with it pre-calibration the movement is a lot quicker taking the bed up and down and this when the bed goes down most of the times I can see the bed sticking and the screw makes a knocking noise. I have check the bed is not catching onto any part of the machine as per the trouble shooting guide. Inspected the belt and the lead screws I see no debris or damage on any of the parts. I first noticed that I was getting abnormal layer lines on my prints suddenly and gradually this became worse to the extent that now when I run the pre-print calibration I get HMS warning the bed level is not correct - check the nozzle for filament build up and also indicates that there may be something under the print plate. I have checked all of this and still find no problem. If you can assist please message me or reply here.

Did you check the belt tension?

Yes I did, I used a silicon grease (Very little) to lube the screw rods, this may be the problem that the grease is to dense for the clearance between the male and female thread. Busy cleaning off what I can and re-lubricating with synthetic oil as recommended by Bambu Lab. Will advise if this resolves the issue.

Did this issue start occurring before or after you greased those rods?

After it however appeared to get progressively worse over a couple of days, now that I have cleaned the screw rods and lubed with oil, I am printing again looking better but not completely resolved yet. I believe the grease needs to work out a bit and then things will be back to normal again.
This is the print I did before clean up will post next prin shortly

Good to hear. It sounds like you found the cause of your problem.

Thank you for your suggestions, this gets you looking at things from a different perspective. Last print looks good again.

Clean and good detail. The line on the single side tube has a ring on the photo but does not show in when I look at it in normal light.

1 Like

The issue showed up again with the lead screw binding, I eventually found that the right front lead screw had pulled out of the belt pulley about 1,5mm and this was causing the bed to go out of alignment and then start binding. Now that I have this sorted out I am struggling to get the bed to pass the bed leveling pre-check. It takes up to 20 minutes and then when the print starts, the nozzle tip is to far away from the bed and the spagettie starts.

Anything you guys can think of for me to resolve this issue would be highly appreciated. The bed is reasonable flat when I check it with a steel ruler and the nozzle is free of filament or build up.

WHere is the pressure sensor located on the printing head, this may have something t do with my leveling issues. Normally when the bed levelling tales place the nozzle lightly touches the bed, I noticed the same action taking place with the bed halfway down the hight of the bed motion. It is not the vibration movement it is the same as when the nozzle taps against the bed to level the bed.

Problem solved do not follow the instructions of adjusting the bed levelling screw on the P1P the screws are shorter on the P1P and when adjusted with the screws to the bottom of the nuts so that the faces are level is not correct on this machine. Adjusted the screws manually until finger tight moved the bed to the rear screw dropped the nozzle above the bed adjusted that screw until the bed touched the nozzle, moved the nozzle to the other adjustment screws and repeated the process. No more fault messages and the printer is printing fine once again.

In closing - Also discovered the pressure sensor I assumed was on the extruder head mech was not correct there are three pressure sensors on the bed

For awareness, can you link the instructions you’re referring to?

This is where I went to to see how to manually trim the bed

1 Like

Thanks! If needed, the P1P manual can be found here:


1 Like

@Ciprian Can you confirm this one way or another? My back screw was a bit higher up into the nut than the front two. I adjusted the rear so it was the same per Bambu’s instructions in the Wiki. I have not had any issues, but I would hate for improper info to be out there.

If you are getting continues errors then the setting is not correct, if you have no issues running the calibration and bed levelling from Studio then all should be good.

Thanks. I was referring to the statement “ Problem solved do not follow the instructions of adjusting the bed levelling screw on the P1P the screws are shorter on the P1P and when adjusted with the screws to the bottom of the nuts so that the faces are level is not correct on this machine.”

I can’t see why BL would use shorter screws.

Sorry. Posted from different device. Don’t know why I created two different accounts. Obviously, operator error.

@Wunder I guess it’s worth noting here just in case others did not catch on. The instructions you’re suggesting not be followed are from the X1 manual. While all of Bambu Lab’s printers have many of the same parts/features, it would be best to only reference the manual for printer model being used since there are some differences (like in this case).

@msinger 100% agree. But I thought not all info is under the P1P manual/wiki but is under X1 info. Which I understand given the similarities. Like how to re-tension belts.

I could be wrong but remote right now and working on a small screen.

If you look at the P1P manual it refers you back to the X1 manual for the bed tramming and this is where things went south for me. The screws are definitely shorter than the ones on the X1.

Interesting and odd. Would love Bambu to answer this officially one way or another. @Ciprian ?