3D Connexion Spacemouse support

@Ciprian can you provide any feedback on how Bambu is progressing on this “bug” (as you called it) from back in January?

Thanks

1 Like

It IS cool, not necessary but once you use it you can’t live without it :wink:

There does not seem to be any progress, I am still waiting for it to as well. Bambu please fix this!

SpaceMouse for the Mac does work on the OrcaSlicer fork of Bambu Labs.

1 Like

I took some time looking in to this and it looks like the problem is caused by the code-signing of the application. The 3Dconnexion drivers is a third party library that needs to be loaded and BambuStudio doesn’t seem to have the correct entitlement set.

This is the reason why it does work in OrcaSlicer; OrcaSlicer is not signed. I checked the code in both BambuStudio and the OrcaSlicer fork and the code for the SpaceMouse is identical. So it should work for BambuStudio too, if OsX would allow it to load those third party libraries.

I tried removing the code-signing from BambuStudio but unfortunatly this leaves an app that can’t be started. Does anyone know of an unofficial, unsigned build for OsX?

I’d love to be able to use my spacemouse from 3dconnexion to manoeuvre the buildplate around! Is there any update on this yet? :slight_smile:

Looks like it might work if you build it yourself from GitHub, see this issue.

It would be great if Bambu Lab would fix this is the next release, I’m guessing that a large number of customers will not be able to compile their own software for the printer.

It looks like it’s working on the Mac in BS 1.7.2. Yeah!

1 Like

Working on PC version of BS for me, however I don’t see any configuration options. Is there a way to bring up a config/settings section? I know in PrusaSlicer there was some weird keyboard combination you had to press to get the settings pop-up window to come up.

Normally if you open the 3Dconnexion Utility (lower right taskbar) and click BS it will allow you to change settings for that particular program. Use the “Advanced Settings”. The issue I find is that BS doesn’t seem to use these settings?

In BS I find the Spacemouse support really quite slow to rotate compared to the click and drag with a mouse. I’ve max out the speed setting in the 3dconnexion utility but it doesn’t have much effect. Also more annoyingly for some reason I can only zoom via push and pull rather than up and down as I prefer. Changing the settings in the utility also doesn’t fix it.

Has anyone else experienced this? I’ve used a SpaceNavigator for well over a decade and I find this behaviour very odd and a little frustrating.

3 Likes

Exactly the same as I have experienced. The Advanced settings in the 3Dconnexion app don’t seem to have any effect on how the SpaceMouse Wireless works in the Bambu Studio app. Which is why I was wondering if the BS app worked like PrusaSlicer where there was a keyboard shortcut to bring up a “secret” menu to control the SpaceMouse settings that was inaccessible any other way in the app.

Found it, Ctrl-M as in the PrusaSlicer app worked in Bambu Studio to bring up the 3Dconnexion settings menu. From there you can adjust the speeds and fix the performance of the SpaceMouse in BS.

3 Likes

Thank you!! That was super helpful.

3 Likes

I was having the same problem with Orca Slicer. I opened the 3D connection home app in the dock of my Mac. I selected “properties”. Under configure I clicked on the up/down arrow and selected “add application” Then I selected Orca Slicer. Now it works.

Problem solved.
Many thanks :slight_smile:

I got my Spacemouse kit. I forgot about the control settings. :raised_hands::grinning:

1 Like

Been using a Mac’s for a very long time, Sketchup and Fusion for 5 years with my Space Mouse, it works in Prusa Slicer as well.

I am aware of hoe to configure my space mouse. I am on the latest version of Space Mouse firmware, OSX, and Bambu Studio.

Been printing on Creality for a couple of years, and I just got my Bambu A1 setup and printing.

My Space Mouse does not work in BS, I am new to BS and the history here is a little confusing.

Does a 3DConnexion Space Mouse on a Mac work in BS or not. If it does, how do I get it to work?

Thanks

OK, I didn’t say I was smart. My mouse battery was dead, all good now.

:smile: It happens to the best of us. Welcome to the forum!

3 Likes

Wow, you really made my day. Was very annoyed using the Spacemouse and almost gave up. Now it works perfectly! Nice quick panning, rotation and zoom.

1 Like