Ams fails to push filament to the extruder

Hi all. I have yet to get my brand new AMS system to successfully load the extruder. The Ams will attempt to push thr filament to the extruded stop at various points and then retract back to the ams. Sometimes it will push the filament all thr way to the tool head but will not engage. I have verified that there isnt any blockages in the lines. I can hand feed filament from the Ams to the extruder and thr extruder will engage. But when thr ams does it itself it fails to reach the extruder.

At first i thought it could be due to using the printed reusable spools. So i tried using the 250g orange pla included with the printer on bambu’s own spool and it does the exact same thing. I also did a factory reset because i had updated the printer and ams to the latest firm ware. Not sure if that resets the ams to factory however. It still fails to feed correctly. Stalling at verious points. It will eventucally cycle so many times pushing and pullling that the extruder grinds a cicle into the filament and gets stuck. Forcing me to gently pull out the filament by hand.

I also verified that there is no blockages or clogs inside the extruder on the printer or nozzle. It has no problem loading filament when the ptfe tube is disconnected or if the ams is disconnected and i use the external spool rail on the back of the printer.

Any ideas? The entire system is brand new. I have printed maybe 8 prints on the printer, all of which were done without the ams because i needed to print spools first. I also noticed that the filament sold spoolless is very loose on the reusable spools resulting inbinding and other issues in the ams. I tried a tightly wound spool of pla and it managed to push that the furthest. Often right up to the extruder/ tool head but would never engage.

The rfid chips are not being read correctly either neither on the reusable spools i printed included on the printer or the one directly from bambu lab

1 Like

Update.

I have disconnected the ptfe tube going from the ams to the printer, i have disconnected the tube that connects to the right side of the hub box and goes into the top chamber of the printe, and i have disconnected the tube connected to the extruder. No abnormalities found in the tubing aside from a black line on the inside of one of the ptfe tubs. Perhaps wear? Looks as if material was deposited there.

I donr know what i am missing. Do i need to take the ams fully apart to see if the connector retention ports are allined correctly? It seems like the ams is getting a lot of resistance while trying to load the filament. It struggles to feed correctly.

Is anyone else having issues? Especially with the spoolless filament and printed reusable spools? It also doesnt re load the spool right when it tries to retract. Filament gets crossed, tangled, or pulled so tight it travels down the side wall of the spool and gets stuck.

Also there was no noticeable damage to the package when i received the printer. However i did notice that the package was very cold. Will attached a video link later showing what the ams is doing. I eventually get the error "failed to retract/pull filament back. Its like an endless loop. Powering does not fix it.

1 Like

No fun. I have 3 AMS units working across 2 different X1C units and all more-or-less worked without error right out of the box.

The brand and condition of the filament spool could be a factor, but that shouldn’t be the case when working with the default test spools that come in the X1 box. So, if you eliminate that variable, it sounds like something else is happening in your case.

If you’re sure all of the PTFE tube connections are well seated (check with a gentle tug after inserting), the only other thing I’d check is the tube path from the AMS to the X1. If your AMS unit is not sitting on top of the X1, the PTFE tube might be bending at an angle that’s putting extra pressure on the feeder motor.

In my experience, though, AMS units are pretty plug-and-play. Maybe, ultimately, you got a lemon? :confused:

2 Likes

I have the same problems as you, unfortunately I pulled off all PTFE tubes, I suspect with me the extruder is broken, meanwhile the filament stutters when it comes out of the nozzle. Have a 0.6 nozzle installed. Wanted to print PA CF with it. Have not yet finished a print. issue [0700 8003]

Greeting Eddy

Update number 2. I found the problem causing resistance in the ams. The feeder stepper motor in the back that has 4 inlets and outputs one line to the printer was tightened far to much from thr factory. The rubber rings were compressed far to much making the extruder have to work extra hard to force the filament up to the printer. After i fixed that by losing 4 hex heads the ams will push the filament to the extruder in the tool head everytime. It is engaging with the extruder on the tool head. Loads it then immediately the tool head and ams reverse and pull the filament back into the ams. Its an endless loop. Leads me to believe this is a firmware issue or chipset issue. It will cycle like this endlessly for about 10 times. Sometimes i get an error other times it continues to load and unload the filament into the tool head. Seems to be a lemon indeed. I will upload a video for you guys after work today. Absolutely love the printer and bambu lab as a company. But really disappointed that i received a doa ams unit. Wondering if the ams firmware update caused the problem. I never tried to run either until after i updated both the printer and ams.

1 Like

How long does bambu labs typically take to respond to a ticket?

Hello,

I have solved the problem, the extruder was the problem, there was still some filament left at the sensor, I had not removed it during the last disassembly. The AMS is working normally again.

I just fixed my issue, it was a similar problem. The AMS kept pushing filament in and retracting. My first instinct was there being a piece of broken filament causing the blockage but when I took apart the AMS to check the 4 PTFE tubes, they were clear. Here’s how I fixed it, there actually was some hidden broken filament. I posted the solution on discord but here’s some screenshots of what I did





Wanted to update you guys. The issue was a faulty stepper motor in the AMS. After working with support, testing continuity, voltage, sensors, etc, they narrowed it down to the feeder motor in the ams. Motor wine. Needless to say they replacee the feeder stepper motor in the ams and it works perfectly now. There was no jam. No blockage what so ever. I explained that in the original post :p.

My first fault with the AMS (or the printer) was due to a similar problem. @MunirAdlan41 your post really helped… I knew it was a rouge piece of filament, as I saw one inch snap off and get pulled in as I loaded a new freshly dried spool (in the middle of a two day print). My fault since the end of the filament had been sticking out of the drier. Problem was on slot-2, but my resolution was to push some filament through slot-1 of the 4-port-inlet to get the snapped piece out (now only a CM long for some reason), attempting through slot-2 failed.

I too loosened the 4-port-inlet first, which made accessing / viewing a lot easier. This whole area of clearing the AMS (the 4-post-inlet) currently appears to be awaiting documentation from Bambu.

I have the same issue:
During a 6 hour print with a lot of color changes over all four AMS slots, I get around 30-40 errors causing this to be a 20 hour print.
When I go check at the printer and press “Retry” the AMS retracts the filament and I can see that the AMS has eaten chunks out of the filament, this causes burrs on the filament which can not pass though the AMS feeder, causing an error.
To continue printing I have to take the filament out of the feeder and cut almost 1 meter of the filament (which shows 3-4 grinding marks), re-insert into the feeder en then it feeds fine for another 10 minutes
Judging by the direction of these burrs, the grinding of the filament happens during forward feeding, not on retractions.
The issue happened mostly on slot 1, but the rest of the slots also have this issue.
I have taken the entire AMS apart, disassembled the feeder, the manifold and all the tubing.
There was a lot of the grinded filament in the manifold and the feeder which I cleaned.
The issue was not solved by this.
Then I took the hotend apart, replaced the blade, cleaned the extruder but this also did not solve the issue.

My guess is that there is something with the buffer which sends a signal to the AMS to feed filament to the extruder while the extruder is not asking for more filament but I have not caught the buffer getting stuck or something yet…

I had the same issue! Every time the AMS loaded new filament during a multifilament part it would grind the filament which over time ended up causing it to jam. I usually could only change filament two to three times before it would jam entirely. After going through several tear downs I ended up finding a solder bridge on the AMS main IC (see image). After fixing the solder bridge it worked as intended, just wanted to share in case others have a similar issue.

The support staff was initially responsive but then went quiet for a few weeks so I ended up doing this without their guidance and probably voided my warranty as a result. So I wouldn’t recommend doing this unless you are okay with a voided warranty.