Problems with loading the filament from AMS to printer

after a while, today I finally opened my fresh new Bambu P1S + AMS COMBO.
everything assembled and done carefully acc to the manual. I am encountering this issue when I tried to load the filament from the AMS.
things I checked:

  1. it happened on all slots.
  2. try the other Bambu provided filament spools.
  3. tried to disconnect and connect the PTFE tubes everywhere again and made sure everything is smooth.
  4. Loading external spool works good with no issues and I even printed the PTFE tube mode try to solve the issue.
  5. I checked for clogging everywhere, and even did a cold pull. as I mentioned single spool prints with no issue when I load the filament manualy by hands.
  6. I reached the extruder itself, everything is moving smooth with no issues or blocking.
  7. I checked the filament buffer on the back everything is smooth and the spring sits well.
  8. several power on/off and connect and disconnect the AMS cables + Buffer.
    please watch videos to demonstrate my issues.

Thanks in advanced.


Are you sure you are getting past the filament buffer? Take off the inlet side and make sure the ptfe tube is cut square at the end of the tube. Its possible it could be cut wrong and hanging up there.

Welcome to the forums!


thanks for your replay.
yes I can see the filament clearly making its all way to the hotend extruder and stop there and starting that wiggle you see.

either buffer or coupler would be my guess. Your ams moves much faster than mine though. where does it start to slow down and labor at? Could be a faulty rjnout sensor in the head. Maybe try heating it and pushing some filament into the head by hand or try the external roll holder to see if theres a difference.

Any luck with this yet? I just got my P1S and I am having the exact same issue. I put in a support ticket but hoping it may be an easy fix as I really need to get this printer going.

1 Like

Brandnew p1s > Same problem
Filament goes all the way to the printhead and does exactly whats in the video.
When I turn off the printer at this moment and turn it back on - the filament is loaded and I can print until the next filament change.
So the AMS itself (motor / tubes etc.) doesnt seems to be faulty.

1 Like

After sending logs to Bambu about this, it apeared by the’re claim that the main motor inside the ams is faulty. They sent a replacement, I am still waiting for it to arrive.


Hi all, just a good update, I got the ams motor replacement from bambu today, the problem solved and the AMS is now finally work! :slight_smile:


I also got a motor replacement > no change at all.
After that I send another video where you cann see how badly the spools wind up and they believed it has something to do with the speed of the AMS.
So I got a new Motherboard and now all my Problems are fixed too!

I’m having exactly se same issue! Even the bad filament rewind case!
I’ve done every possible test and found the issue might be AMS motherboard or AMS Internal HUB Motor

When you say ams motor replacement, are you taking about the “AMS Internal Hub Motor”. Mine is having similar issues too. Just wanting to make sure I order the right part, since mine is doing something similar.

1 Like

I had a similar problem but it was due to liquid leakage from some additional AMS frontal desiccant holders down on the mother board, under the four feeders. The circuit board was flooded and gave weird AMS behaviour. When I get permissions I will write a full post about this.


Any update? Thank you!

If you don’t mind me asking. How did you get a new motherboard? I can’t seem to find it on the spare parts page. Thank you!

Yes, it was the AMS Internal HUB Motor
Bambu sent me a new one and now everything runs smooth
Time has passed… 1000h already :sweat_smile:

1 Like

Congrats! I’m waiting to hear back from support to see what they recommend. I’m glad for you it was a quick and easy fix! :slight_smile: Keep it up!!

I am having the exact same issue. No filament loads from my ams spools.

At this point I have had this problem on 3 different printers. First one was bad motor in AMS and bad motherboard in AMS. Second one was bad motor in AMS. And third was bad motherboard in AMS. so put in a support ticket with Bambu so they can troubleshoot and send you replacement parts.