LAN only mode is terrible - this is what Bambu Lab should do about it

Bambu Lab please open source the bambu_network.dll so that the community can diagnose and submit fixes for networking problems.

In general Bambu Lab software has problems, but network communication is the biggest problem and affects almost every user. Many posts have discussed cloud issues and network security issues. We users want our printers to be reliable!

When I bought my P1P I thought it supported LAN only mode, based on postings that I read. However, Bambu Lab had not provided a single source of correct information and LAN only mode was only supported on the X1C at that time.

Now the P1P has LAN only mode and it is terrible. I’ll discuss it in another post.

I have been working with Bambu Studio developers to try to diagnose all the problems with LAN only mode for weeks. I am a software developer so tracking down the problem should not be hard and I have spent many days running tests and providing more information.

The problem is - Bambu Lab is keeping all network communication proprietary. Bambu Studio downloads and uses two DLLs that are not part of the open source GitHub repo. The bambu_network.dll crashes frequently, but can’t be debugged. The network requests timeout most of the time. MQTT should be maintaining a constant connection, but Bambu Studio has to reconnect to the printer every time it does something because the connection is not maintained.

Bambu Lab - I hope that you are reading this. Your hardware is great! Your have already stated that you are not really a software company. All your networking problems would be fixed almost immediately if you would just open source the printer API and the networking DLL code. The community has experts that would rapidly find and fix network communications problems.

I am tired of having Bambu Studio hang every single time I send a print to my P1P. I have to restart it to then start the camera feed.


Thanks for re-addressing this issue.
I really don’t see much Bambu Lab participation here. Folks may say well they are buried with product growth. Hard to understand why that issue becomes a reason to pass up on free help. In addition you point out this is the biggest problem, and I agree. But there are many more issues that that could use some free help to achieve improvements.

For me calibration is critical; without a calibration procedures how does one guarantee specifications and maintain those through the life of the product. Look at all the posting for print issues. Folks are flying blind because there is no specific calibration system to reference the printer to. Yes there are visual measures, but there should be a finite metric.

I have to agree. First off, WiFi only connections are terrible in a professional environment and a cloud service lock-in unacceptable. Cloud performance is truly awful most of the time.

The P1Ps network (LAN AND cloud) issues make the machine useless on a daily basis. I honestly regret getting the P1P, as my X1 does not suffer from the same issues.

The X1 is no prince among paupers! the entire cloud system sucks because it wants to default setting back to factory settings. This makes imported projects a pain in the a55 needing to be completely reviewed so you don’t find the printer printing changes you didn’t want. The other thing is the AMS part of the interface on the Prepare tab you have 6 color slots on the Device you have 4 and they are independent of each other set up everything with colors in prepare it should transfer to the Device tab so you know you are getting the same material settings you prepared for the job. I’d say temps for the print should be based on the project and what you set up having to be 100% sure by constantly having to manually input material changes at the device tab is a problem. As for networking one of the updates has made the cam lag (was able to keep up before) now it can be 2-3 seconds behind with large skips trying to catch up. Oh and just to add insult to injury BL decided to use Microsoft Edge as part of its networking so now we all have Edge pissing away our processing power in the background. might want to look up your GPU VRAM usage too BL runs that up as well.

I am working as hard as I can with both Bambu Lab tech support and with developers at GitHub Bambu Studio trying to get this fixed.

I have sent logs, done experiments, used Wireshark, and last night I wrote a MQTT app to see how well the printer communicates without Bambu Studio.

The big surprise is that
BambuStudio can be connected to the printer (LAN only mode) and showing status on the devices page, with updates showing as things change, but then selecting print will open the print dialog box and then say “synching status of printer” for a while and then fail with a timeout. It was already connected!

I can start my app and have it connect, request all information from the printer and receive the printer status and from the time my app requests a connection to the time it receives full printer status is .1 seconds.

The problems is in the networking dll that bambu studio uses, and possible how Studio maintains the connection to the printer.


Once you have the P1P connected to WIFI it works fine without an internet connection. I am running it that way.

1 Like

User_33… I tried you method today, and found the BS hung and wouldn’t let me send the print to the P1P.
I setup a Wifi connection on the P1P, the Bambu Studio was setup with either Wifi or ported to the router. In both cases when the Internet was disconnected from the router BS became unhappy. As a side note, Bambu Labs required me to re-select the P1P when I toggled back out of Lan only mode.

Please advise.

1 Like

I would be happy to help. I need more details. We can even have a live chat while you try if you like. Go to my reddit profile (julie777) and use the Chat button.

You can help me too. How did you get a real user name to appear on this forum. I can’t find any way to change it. I read that you could use Handy so I went and changed it there but here is still shows the made up user name.

If you want it bad enough…

I created a poll for this. Please vote.


User_33… Navigated to, as far as I can tell there is no triple 7 julie. I did see four users there but they had more sevens. Chat would be good, thanks

1 Like

Try this

OK, worked, and up and running. 3:15 here.

The following is my interpretation of the instructions I received from user_33… for how to switch to LAN only mode.
I have successfully setup my P1P to work in LAN only mode which means no Internet, no cloud usage and somewhat faster setup time.

It does not mean no Wifi, so mesh network privacy issues are still possible. There is less load on Bambu Lab’s cloud, which would save them money and speed up folks who stay on the cloud service.

Instructions: Temporary use Bambu Handy BT to setup and bind the printer, then Bambu Handy through BT tells the printer it can connect to Bambu Studio. LAN only mode can now be switch to ON. Note, it takes almost a minute for Bambu Studio to switch to LAN only mode and the print plate page will update with “LAN only” listed near the bottom and the “Send” button will become active.

Once everything is running the Internet can be disconnected and their will be a connection between Bambu Studio and the printer. In testing this I remove the Wifi and the Bambu Studio connection did drop, but reconnecting the Wifi and the connection came back without any trouble. Rumor is that a message may pop up at some point (I haven’t witness this yet, but it shouldn’t cause a problem).

I too do not want Wifi, my home network is all hardwired. I can tolerate it for a few seconds while I move files to the printer, I did setup a stand alone system to maintain hardware isolation.


Just tried the process listed on an X1 Carbon running with no luck. As soon as you change to Lan mode the printer goes offline and cannot be seen by BambuStudio.

Testing Environment
OS: Mac Ventura
VPN: Disabled
Network Filter: Disabled
Network Security: Disabled
Network: Same vlan as printer
Ports: All appropriate LAN based ports including SSDP listed on Bambu wiki site enabled on vlan

I checked and I can ping the printer from the client so Im at a loss on why BanbuStudio cannot see the printer.

Open to suggestions at this point.

After you set your X1 to LAN only mode, try restarting it, and logging out of your account on Bambu Studio.
If you just turn off LAN only mode it can take a while to switch everything.

Also, when you switch to lan only mode you need to write down the IP address and access code.
You will likely also need to go to the device page and click on the “no printer” in the upper left corner to be able to find the printer. They it will complain that the password is wrong. You have to try again before it will allow you to enter the access code.

It is a pain in the A@@!


Thanks for the advice.

Still no luck. I even tried putting the X1 and BambuStudio on an old ATT Router/AP I had laying around with no luck.

At this point since it works online the only thing Im pretty sure of is that the problem is not associated with my network infrastructure which only leaves my Mac and BambuStudio as question marks. Unfortunately I don’t have a Windows box to test at this point and they don’t have a unix version of BambuStudio.

As an update to the previous post, your procedure worked fine on a Windows 10 device but does not appear to work on a Mac running Venture 13.4.

I guess I will have to open a case with Bambu Lab.

Not gonna happen. Its china. Theyre robably keeping a copy of every single .stl in a database for future use. Wait until you start seeing your designs on ali baba lol

After many days of network sniffing, hints from others and lots of head banging, I solved my LAN Only problems. The biggest issue was, I found out that on my Mac (Ventura 13.5.1), any changes made in the Firewall only become effective after a reboot (at least on my machine). This is not normal behavior in my opinion. This made troubleshooting difficult.

Ultimately after learning that BambuStudio listens for Broadcasts on port 2021 it became obvious that I needed to enable “Allow Incoming connections” for BambuStudio in the Firewall. After changing this and rebooting I was able to discover and communicate with the printer when connected to the vlan in question.

Cross VLAN discovery on the other hand required a simple hack by gashton which connects to BambuStudio and tells it where to find the printer. It does need to be done each time you start BambuStudio. Although a bit more work it has the advantage of not requiring a multi-homed machine and keeps you from having to open up your firewall to all your IOT traffic.

The good news is that the two changes allowed me to successfully use the following features with no impact on my ability to leverage “LAN Only” mode on the printer. Your milage may vary !

  1. VPN when “Local network sharing” is enabled
  2. Apple Firewall / Options / Stealth Mode Enabled
  3. Multhomed networks
  4. Mixed mode wireless networks ( 5 GHz & 2.5 Ghz sharing same SSDI/Password)
1 Like

Following your tips (and disabling my firewall) I was able to see my printer in “LAN Mode”.
However, that was with the AppImage 1.7.4. If I try with version 1.7.7, even with the firewall disabled, I can’t see the printer in LAN Mode.
How are you all doing? Are you able to use ver 1.7.7 in LAN Mode?

Regards, M.